summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-11-12 07:52:33 +0000
committerJustin Lecher <jlec@gentoo.org>2014-11-12 07:52:33 +0000
commitb542dedda03130d6357fe89e6508ce7059b7e6c5 (patch)
tree736c1383718c4d1bbd5f641496cf5b370c573461 /app-misc
parentVersion bump. (diff)
downloadgentoo-2-b542dedda03130d6357fe89e6508ce7059b7e6c5.tar.gz
gentoo-2-b542dedda03130d6357fe89e6508ce7059b7e6c5.tar.bz2
gentoo-2-b542dedda03130d6357fe89e6508ce7059b7e6c5.zip
app-misc/devtodo: Fix bash completion with pyth using spaces, #417945; drop old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/devtodo/ChangeLog8
-rw-r--r--app-misc/devtodo/devtodo-0.1.20-r3.ebuild (renamed from app-misc/devtodo/devtodo-0.1.20-r1.ebuild)13
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.20-bashcom_spaces.patch32
3 files changed, 47 insertions, 6 deletions
diff --git a/app-misc/devtodo/ChangeLog b/app-misc/devtodo/ChangeLog
index bc23c695d7e9..be38139d5713 100644
--- a/app-misc/devtodo/ChangeLog
+++ b/app-misc/devtodo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/devtodo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.107 2014/11/11 10:51:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.108 2014/11/12 07:52:33 jlec Exp $
+
+*devtodo-0.1.20-r3 (12 Nov 2014)
+
+ 12 Nov 2014; Justin Lecher <jlec@gentoo.org> -devtodo-0.1.20-r1.ebuild,
+ +devtodo-0.1.20-r3.ebuild, +files/devtodo-0.1.20-bashcom_spaces.patch:
+ Fix bash completion with pyth using spaces, #417945; drop old
11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> devtodo-0.1.20-r2.ebuild:
Stable for ia64, wrt bug #526420
diff --git a/app-misc/devtodo/devtodo-0.1.20-r1.ebuild b/app-misc/devtodo/devtodo-0.1.20-r3.ebuild
index 6a9b249233c2..d287056441a3 100644
--- a/app-misc/devtodo/devtodo-0.1.20-r1.ebuild
+++ b/app-misc/devtodo/devtodo-0.1.20-r3.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.20-r1.ebuild,v 1.12 2014/10/22 07:27:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.20-r3.ebuild,v 1.1 2014/11/12 07:52:33 jlec Exp $
-EAPI="5"
+EAPI=5
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_IN_SOURCE_BUILD=1
+
inherit autotools-utils bash-completion-r1 eutils flag-o-matic toolchain-funcs
DESCRIPTION="A nice command line todo list for developers"
@@ -14,7 +15,7 @@ SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
RDEPEND="
@@ -23,9 +24,11 @@ RDEPEND="
DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog QuickStart README doc/scripts.sh doc/scripts.tcsh doc/todorc.example )
+
PATCHES=(
- "${FILESDIR}/${P}-gentoo.diff"
- "${FILESDIR}/${P}-gcc43.patch"
+ "${FILESDIR}"/${P}-gentoo.diff
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-bashcom_spaces.patch
)
src_prepare() {
diff --git a/app-misc/devtodo/files/devtodo-0.1.20-bashcom_spaces.patch b/app-misc/devtodo/files/devtodo-0.1.20-bashcom_spaces.patch
new file mode 100644
index 000000000000..8567ab4b0562
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-0.1.20-bashcom_spaces.patch
@@ -0,0 +1,32 @@
+ contrib/devtodo.bash-completion | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/contrib/devtodo.bash-completion b/contrib/devtodo.bash-completion
+index 07139b0..c058dad 100644
+--- a/contrib/devtodo.bash-completion
++++ b/contrib/devtodo.bash-completion
+@@ -15,20 +15,20 @@ _devtodo() {
+ --purge"
+
+ if [[ ${cur} == -* || ${COMP_CWORD} -eq 1 ]] ; then
+- COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
++ COMPREPLY=( $(compgen -W "${opts}" -- "${cur}") )
+ return 0
+ fi
+
+ case "${prev}" in
+ -p|--priority)
+ COMPREPLY=( $(compgen -W "default veryhigh high medium low verylow" \
+- -- ${cur}) )
++ -- "${cur}") )
+ ;;
+ --database-loaders)
+- COMPREPLY=( $(compgen -W "xml binary" -- ${cur}) )
++ COMPREPLY=( $(compgen -W "xml binary" -- "${cur}") )
+ ;;
+ -l|--link|--*database)
+- COMPREPLY=( $(compgen -f -- ${cur}) )
++ _filedir
+ ;;
+ *)
+ COMPREPLY=()