summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2007-05-26 10:58:39 +0000
committerTorsten Veller <tove@gentoo.org>2007-05-26 10:58:39 +0000
commitca9b35165e7e486fae8268f48d0b782c63182633 (patch)
tree3e2490f9d7f83fa63a037ff7d615b0264174b1a0 /app-misc
parentRevbump to move src.zip to right location, while still symlinking from previo... (diff)
downloadgentoo-2-ca9b35165e7e486fae8268f48d0b782c63182633.tar.gz
gentoo-2-ca9b35165e7e486fae8268f48d0b782c63182633.tar.bz2
gentoo-2-ca9b35165e7e486fae8268f48d0b782c63182633.zip
Version bump. Added unicode useflag.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/wyrd/ChangeLog7
-rw-r--r--app-misc/wyrd/files/digest-wyrd-1.4.23
-rw-r--r--app-misc/wyrd/wyrd-1.4.2.ebuild39
3 files changed, 48 insertions, 1 deletions
diff --git a/app-misc/wyrd/ChangeLog b/app-misc/wyrd/ChangeLog
index c31b4c6fc6d2..e2ca31f8d4c4 100644
--- a/app-misc/wyrd/ChangeLog
+++ b/app-misc/wyrd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/wyrd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/ChangeLog,v 1.11 2007/01/25 04:24:40 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/ChangeLog,v 1.12 2007/05/26 10:58:39 tove Exp $
+
+*wyrd-1.4.2 (26 May 2007)
+
+ 26 May 2007; Torsten Veller <tove@gentoo.org> +wyrd-1.4.2.ebuild:
+ Version bump. Added unicode useflag.
25 Jan 2007; Steve Dibb <beandog@gentoo.org> wyrd-1.4.1.ebuild:
add ~amd64, bug 150499
diff --git a/app-misc/wyrd/files/digest-wyrd-1.4.2 b/app-misc/wyrd/files/digest-wyrd-1.4.2
new file mode 100644
index 000000000000..e0697229993c
--- /dev/null
+++ b/app-misc/wyrd/files/digest-wyrd-1.4.2
@@ -0,0 +1,3 @@
+MD5 9de1c07c4f662a2b28d4cf29ed6818b9 wyrd-1.4.2.tar.gz 203752
+RMD160 d998545556ba045ac4e56ba5305dc0ca36283300 wyrd-1.4.2.tar.gz 203752
+SHA256 a72c5712d1e5cf1e76a2e2eb970f54b812a826dfb3536e5f873cf4d98c0553c0 wyrd-1.4.2.tar.gz 203752
diff --git a/app-misc/wyrd/wyrd-1.4.2.ebuild b/app-misc/wyrd/wyrd-1.4.2.ebuild
new file mode 100644
index 000000000000..22888392ca3f
--- /dev/null
+++ b/app-misc/wyrd/wyrd-1.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.4.2.ebuild,v 1.1 2007/05/26 10:58:39 tove Exp $
+
+inherit eutils
+
+DESCRIPTION="Text-based front-end to Remind"
+HOMEPAGE="http://www.eecs.umich.edu/~pelzlpj/wyrd/"
+SRC_URI="http://www.eecs.umich.edu/~pelzlpj/wyrd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="unicode"
+
+DEPEND=">=dev-lang/ocaml-3.08
+ sys-libs/ncurses
+ >=x11-misc/remind-03.00.24"
+
+pkg_setup() {
+ use unicode || return 0
+ if ! built_with_use sys-libs/ncurses unicode ; then
+ eerror "To use unicode in wyrd you must build sys-libs/ncurses"
+ eerror "with unicode support."
+ die "Please rebuilt sys-libs/ncurses with unicode in USE!"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable unicode utf8 ) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install died"
+
+ dodoc ChangeLog || die "dodoc failed"
+ dohtml doc/manual.html || die "dohtml failed"
+}