summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-09-12 05:03:37 +0000
committerAlin Năstac <mrness@gentoo.org>2009-09-12 05:03:37 +0000
commitd42dedea9410ff5e7a94709826d68e2a70dcf823 (patch)
tree444b783e10688d6ca5c1c8a34960276ad4623949 /app-mobilephone/gammu
parentRemove old version. (diff)
downloadgentoo-2-d42dedea9410ff5e7a94709826d68e2a70dcf823.tar.gz
gentoo-2-d42dedea9410ff5e7a94709826d68e2a70dcf823.tar.bz2
gentoo-2-d42dedea9410ff5e7a94709826d68e2a70dcf823.zip
Version bump (#284176).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone/gammu')
-rw-r--r--app-mobilephone/gammu/ChangeLog8
-rw-r--r--app-mobilephone/gammu/files/gammu-skip-locktest.patch12
-rw-r--r--app-mobilephone/gammu/gammu-1.26.1.ebuild87
3 files changed, 106 insertions, 1 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index 2dc9ccafd138..8dcd8e7bd4c4 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/gammu
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.72 2009/09/05 06:19:02 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.73 2009/09/12 05:03:36 mrness Exp $
+
+*gammu-1.26.1 (12 Sep 2009)
+
+ 12 Sep 2009; Alin Năstac <mrness@gentoo.org>
+ +files/gammu-skip-locktest.patch, +gammu-1.26.1.ebuild:
+ Version bump (#284176).
*gammu-1.26.0 (05 Sep 2009)
diff --git a/app-mobilephone/gammu/files/gammu-skip-locktest.patch b/app-mobilephone/gammu/files/gammu-skip-locktest.patch
new file mode 100644
index 000000000000..a509879d5edb
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-skip-locktest.patch
@@ -0,0 +1,12 @@
+diff -Nru tests/CMakeLists.txt tests/CMakeLists.txt
+--- tests/CMakeLists.txt 2009-09-04 10:56:25.000000000 +0200
++++ tests/CMakeLists.txt 2009-09-05 07:46:58.000000000 +0200
+@@ -739,7 +739,7 @@
+
+ # Test for locking, only on !WIN32 and if we can write to lock dir
+ if (NOT WIN32)
+- execute_process(COMMAND test -w /var/lock/ RESULT_VARIABLE VAR_LOCK_WRITABLE)
++ set (VAR_LOCK_WRITABLE 1)
+ if (VAR_LOCK_WRITABLE EQUAL 0)
+ add_executable(locking locking.c)
+ target_link_libraries(locking libGammu)
diff --git a/app-mobilephone/gammu/gammu-1.26.1.ebuild b/app-mobilephone/gammu/gammu-1.26.1.ebuild
new file mode 100644
index 000000000000..d0d78005049a
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.26.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.26.1.ebuild,v 1.1 2009/09/12 05:03:36 mrness Exp $
+
+EAPI="2"
+
+inherit cmake-utils distutils
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+HOMEPAGE="http://www.gammu.org"
+SRC_URI="http://dl.cihar.com/gammu/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="curl debug bluetooth irda mysql postgres dbi nls python usb"
+
+RDEPEND="bluetooth? ( || ( net-wireless/bluez net-wireless/bluez-libs ) )
+ curl? ( net-misc/curl )
+ usb? ( dev-libs/libusb:1 )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-server )
+ dbi? ( >=dev-db/libdbi-0.8.3 )
+ dev-util/dialog
+ dev-lang/python
+ !dev-python/python-gammu" # needs to be removed from the tree
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )
+ dev-util/cmake"
+
+# sys-devel/gettext is needed for creating .mo files
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv sw zh_CN zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-skip-locktest.patch
+
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -rf locale/${lang} || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ # debug flag is used inside cmake-utils.eclass
+ local mycmakeargs="$(cmake-utils_use_with bluetooth Bluez) \
+ $(cmake-utils_use_with irda IRDA) \
+ $(cmake-utils_use_with curl CURL) \
+ $(cmake-utils_use_with usb USB) \
+ $(cmake-utils_use_with python PYTHON) \
+ $(cmake-utils_use_with mysql MySQL) \
+ $(cmake-utils_use_with postgres Postgres) \
+ $(cmake-utils_use_with dbi LibDBI) \
+ $(cmake-utils_use_with nls GettextLibs) \
+ $(cmake-utils_use_with nls Iconv) \
+ -DBUILD_SHARED_LIBS=ON -DINSTALL_DOC_DIR=share/doc/${PF}"
+ if use python; then
+ mycmakeargs="${mycmakearg} -DBUILD_PYTHON=/usr/bin/python"
+ fi
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${WORKDIR}"/${PN}_build/common cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}