summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-09-18 10:09:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-09-18 10:09:07 +0000
commit9527dbe35611473fd125d2a49cd07d91ed7a3c6d (patch)
tree4e252272bd901c6074c1d4266f100c9c453b411b /app-mobilephone/gnokii
parentversion bump (diff)
downloadgentoo-2-9527dbe35611473fd125d2a49cd07d91ed7a3c6d.tar.gz
gentoo-2-9527dbe35611473fd125d2a49cd07d91ed7a3c6d.tar.bz2
gentoo-2-9527dbe35611473fd125d2a49cd07d91ed7a3c6d.zip
Version bump: Dear upstream, please don't break my phone like 0.6.27 did - robbat2
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone/gnokii')
-rw-r--r--app-mobilephone/gnokii/ChangeLog9
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.28.1.ebuild127
2 files changed, 135 insertions, 1 deletions
diff --git a/app-mobilephone/gnokii/ChangeLog b/app-mobilephone/gnokii/ChangeLog
index b6fa5f2bb8a3..9b1974c8efa3 100644
--- a/app-mobilephone/gnokii/ChangeLog
+++ b/app-mobilephone/gnokii/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-mobilephone/gnokii
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.99 2009/08/31 22:08:39 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.100 2009/09/18 10:09:07 robbat2 Exp $
+
+*gnokii-0.6.28.1 (18 Sep 2009)
+
+ 18 Sep 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +gnokii-0.6.28.1.ebuild:
+ Version bump: Dear upstream, please don't break my phone like 0.6.27 did -
+ robbat2
31 Aug 2009; Mike Auty <ikelos@gentoo.org> gnokii-0.6.27-r2.ebuild,
gnokii-0.6.27-r4.ebuild, gnokii-9999.ebuild:
diff --git a/app-mobilephone/gnokii/gnokii-0.6.28.1.ebuild b/app-mobilephone/gnokii/gnokii-0.6.28.1.ebuild
new file mode 100644
index 000000000000..5f3749a83f05
--- /dev/null
+++ b/app-mobilephone/gnokii/gnokii-0.6.28.1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.28.1.ebuild,v 1.1 2009/09/18 10:09:07 robbat2 Exp $
+
+EAPI=2
+
+inherit eutils linux-info autotools
+
+DESCRIPTION="user space driver and tools for use with mobile phones"
+HOMEPAGE="http://www.gnokii.org/"
+if [ "$PV" != "9999" ]; then
+ SRC_URI="http://www.gnokii.org/download/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+else
+ SRC_URI=""
+ KEYWORDS=""
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/gnokii.git"
+ inherit git
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls bluetooth ical irda sms postgres mysql usb X debug"
+
+RDEPEND="!app-mobilephone/smstools
+ sys-apps/pcsc-lite
+ X? ( >=x11-libs/gtk+-2 )
+ bluetooth? ( || ( net-wireless/bluez >=net-wireless/bluez-libs-2.25 ) )
+ sms? (
+ !app-mobilephone/smstools
+ >=dev-libs/glib-2
+ postgres? ( >=virtual/postgresql-base-8.0 )
+ mysql? ( >=virtual/mysql-4.1 )
+ )
+ ical? ( dev-libs/libical )
+ usb? ( =virtual/libusb-0* )"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ nls? ( sys-devel/gettext )
+ dev-util/intltool"
+
+CONFIG_CHECK="~UNIX98_PTYS"
+
+S="${WORKDIR}/${PN}-${PV%.1}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" cs de et fi fr it nl pl pt sk sl sv zh_CN"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+src_prepare() {
+ if [ "$PV" != "9999" ]; then
+ # merged upstream
+ #epatch "${FILESDIR}"/${PN}-0.6.27-icon.patch
+ #epatch "${FILESDIR}"/${PN}-0.6.27-disable-database.patch
+ #epatch "${FILESDIR}"/${PN}-0.6.27-TP-PI.patch
+ :
+ else
+ epatch "${FILESDIR}"/${P}-icon.patch
+ epatch "${FILESDIR}"/${P}-translations.patch
+ intltoolize --force --copy --automake || die "intltoolize error"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ strip-linguas ${MY_AVAILABLE_LINGUAS}
+
+ local config_xdebug="--disable-xdebug"
+ use X && use debug && config_xdebug="--enable-xdebug"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable ical libical) \
+ $(use_enable usb libusb) \
+ $(use_enable irda) \
+ $(use_enable bluetooth) \
+ $(use_with X x) \
+ $(use_enable sms smsd) \
+ $(use_enable mysql) \
+ $(use_enable postgres) \
+ $(use_enable debug fulldebug) \
+ ${config_xdebug} \
+ $(use_enable debug rlpdebug) \
+ --enable-security \
+ --disable-unix98test \
+ --enable-libpcsclite \
+ || die "configure failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ insinto /etc
+ doins Docs/sample/gnokiirc
+ sed -i -e 's:/usr/local:/usr:' "${D}/etc/gnokiirc"
+
+ # only one file needs suid root to make a pseudo device
+ fperms 4755 /usr/sbin/mgnokiidev
+
+ if use X; then
+ insinto /usr/share/pixmaps
+ newins Docs/sample/logo/gnokii.xpm xgnokii.xpm
+ fi
+
+ if use sms; then
+ pushd "${S}/smsd"
+ insinto /usr/share/doc/${PN}/smsd
+ use mysql && doins sms.tables.mysql.sql README.MySQL
+ use postgres && doins sms.tables.pq.sql
+ doins README ChangeLog README.Tru64 action
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "Make sure the user that runs gnokii has read/write access to the device"
+ elog "which your phone is connected to."
+ elog "The simple way of doing that is to add your user to the uucp group."
+ if [ "$PV" == "9999" ]; then
+ elog "This is the GIT version of ${PN}. It is experimental but may have important bug fixes."
+ elog "You can keep track of the most recent commits at:"
+ elog " http://git.savannah.gnu.org/cgit/gnokii.git/"
+ elog "Whenever there is a change you are interested in, you can re-emerge ${P}."
+ fi
+}