summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-09-15 08:48:46 +0000
committerJeroen Roovers <jer@gentoo.org>2014-09-15 08:48:46 +0000
commit7bec82912d072cee77e90a0504b7f7ad86db7398 (patch)
treecb943673e11cece6875d06981c21646176616747 /app-mobilephone
parentAutomated version bump to 3.17_rc5 (diff)
downloadgentoo-2-7bec82912d072cee77e90a0504b7f7ad86db7398.tar.gz
gentoo-2-7bec82912d072cee77e90a0504b7f7ad86db7398.tar.bz2
gentoo-2-7bec82912d072cee77e90a0504b7f7ad86db7398.zip
Set S (bug #522700). Respect LDFLAGS. Convert sed script to patch. Convert helpful comment into USE default.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/yaps/ChangeLog7
-rw-r--r--app-mobilephone/yaps/files/yaps-0.96-string.patch10
-rw-r--r--app-mobilephone/yaps/yaps-0.96-r5.ebuild59
3 files changed, 41 insertions, 35 deletions
diff --git a/app-mobilephone/yaps/ChangeLog b/app-mobilephone/yaps/ChangeLog
index 22bde775f54d..6aaee4d4a02d 100644
--- a/app-mobilephone/yaps/ChangeLog
+++ b/app-mobilephone/yaps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/yaps
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/ChangeLog,v 1.31 2014/09/07 16:28:30 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/ChangeLog,v 1.32 2014/09/15 08:48:46 jer Exp $
+
+ 15 Sep 2014; Jeroen Roovers <jer@gentoo.org> yaps-0.96-r5.ebuild,
+ +files/yaps-0.96-string.patch:
+ Set S (bug #522700). Respect LDFLAGS. Convert sed script to patch. Convert
+ helpful comment into USE default.
07 Sep 2014; Manuel Rüger <mrueg@gentoo.org> -yaps-0.96-r4.ebuild:
Cleanup old.
diff --git a/app-mobilephone/yaps/files/yaps-0.96-string.patch b/app-mobilephone/yaps/files/yaps-0.96-string.patch
new file mode 100644
index 000000000000..6641e2f7d4e3
--- /dev/null
+++ b/app-mobilephone/yaps/files/yaps-0.96-string.patch
@@ -0,0 +1,10 @@
+--- a/scr.c
++++ b/scr.c
+@@ -2,6 +2,7 @@
+ # include "config.h"
+ # include <stdio.h>
+ # include <stdlib.h>
++# include <string.h>
+ # include "pager.h"
+ # include "script.h"
+
diff --git a/app-mobilephone/yaps/yaps-0.96-r5.ebuild b/app-mobilephone/yaps/yaps-0.96-r5.ebuild
index bbc6e16b26cc..f25b14a2fa0c 100644
--- a/app-mobilephone/yaps/yaps-0.96-r5.ebuild
+++ b/app-mobilephone/yaps/yaps-0.96-r5.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/yaps-0.96-r5.ebuild,v 1.2 2014/09/07 13:09:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/yaps-0.96-r5.ebuild,v 1.3 2014/09/15 08:48:46 jer Exp $
EAPI=5
-
inherit eutils toolchain-funcs
DESCRIPTION="Yet Another Pager Software (optional with CAPI support)"
@@ -14,41 +13,32 @@ SRC_URI="capi? ( ftp://ftp.melware.net/capi4yaps/${P}.c4.tgz )
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
-IUSE="capi lua slang unicode"
+IUSE="+capi lua slang unicode"
-RDEPEND="capi? ( net-dialup/capi4k-utils )
+RDEPEND="
+ capi? ( net-dialup/capi4k-utils )
slang? ( >=sys-libs/slang-1.4 )
lua? ( dev-lang/lua )
- !media-sound/abcmidi" # also contains "yaps"
-DEPEND="${RDEPEND}
- !capi? ( sys-apps/sed )
- lua? ( virtual/pkgconfig )"
+ !media-sound/abcmidi
+"
+DEPEND="
+ ${RDEPEND}
+ lua? ( virtual/pkgconfig )
+"
-pkg_setup() {
- if ! use capi; then
- ewarn
- ewarn "You are now compiling some very old and unmaintained stuff!"
- ewarn
- ewarn "YAPS with CAPI 2.0 support is actively maintained, but needs"
- ewarn "net-dialup/capi4k-utils installed. We recommend this"
- ewarn "version, since it can still be used with an ordinary"
- ewarn "modem (that's what you probably wanted). So just add 'capi'"
- ewarn "to your USE flags to get the new and maintained version."
- ewarn
- fi
-}
+if use capi; then
+ S="${WORKDIR}"/${P}.c4
+fi
src_prepare() {
- use capi && mv -f "${S}.c4" "${S}"
- cd "${S}"
-
# apply patches
epatch "${FILESDIR}/${P}-gentoo.diff"
epatch "${FILESDIR}/${P}-getline-rename.patch"
# fix compile warning
- use capi || \
- sed -i -e 's:^\(.*\)\(<stdlib.h>\):\1\2\n\1<string.h>:g' scr.c
+ if ! use capi; then
+ epatch "${FILESDIR}"/${P}-string.patch
+ fi
# if specified, convert all relevant files from latin1 to UTF-8
if use unicode; then
@@ -60,10 +50,13 @@ src_prepare() {
}
src_compile() {
- local myconf=""
- use lua && myconf="${myconf} LUA=True"
- use slang && myconf="${myconf} SLANG=True"
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" ${myconf} || die "emake failed"
+ emake \
+ $(usex lua LUA=true '') \
+ $(usex slang SLANG=true '') \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CXX="$(tc-getCXX)"
}
src_install() {
@@ -71,14 +64,12 @@ src_install() {
insinto /etc
doins yaps.rc
keepdir /usr/lib/yaps
+
doman yaps.1
dohtml yaps.html
dodoc BUGREPORT COPYRIGHT README yaps.lsm yaps.doc
newdoc contrib/README README.contrib
+
insinto /usr/share/doc/${PF}/contrib
doins contrib/{m2y.pl,tap.sl}
}
-
-pkg_postinst() {
- elog "Please edit /etc/yaps.rc to suit your needs."
-}