summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-06-01 21:44:29 +0000
committerAlin Năstac <mrness@gentoo.org>2008-06-01 21:44:29 +0000
commit952c95745cb664dc9a79622faa78834086a0e296 (patch)
tree2f0c74080eba13092694ffc04d36ccfbee48d10c /app-mobilephone
parentold (diff)
downloadgentoo-2-952c95745cb664dc9a79622faa78834086a0e296.tar.gz
gentoo-2-952c95745cb664dc9a79622faa78834086a0e296.tar.bz2
gentoo-2-952c95745cb664dc9a79622faa78834086a0e296.zip
Improve ebuild (#215378).
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gnokii/ChangeLog8
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.26-r1.ebuild (renamed from app-mobilephone/gnokii/gnokii-0.6.26.ebuild)46
2 files changed, 21 insertions, 33 deletions
diff --git a/app-mobilephone/gnokii/ChangeLog b/app-mobilephone/gnokii/ChangeLog
index 079e7a3bac37..6425f695bf9b 100644
--- a/app-mobilephone/gnokii/ChangeLog
+++ b/app-mobilephone/gnokii/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/gnokii
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.74 2008/06/01 12:18:38 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/ChangeLog,v 1.75 2008/06/01 21:44:29 mrness Exp $
+
+*gnokii-0.6.26-r1 (01 Jun 2008)
+
+ 01 Jun 2008; Alin Năstac <mrness@gentoo.org> -gnokii-0.6.26.ebuild,
+ +gnokii-0.6.26-r1.ebuild:
+ Improve ebuild (#215378).
*gnokii-0.6.26 (01 Jun 2008)
diff --git a/app-mobilephone/gnokii/gnokii-0.6.26.ebuild b/app-mobilephone/gnokii/gnokii-0.6.26-r1.ebuild
index b09ecc4b1927..32b0b5df85c9 100644
--- a/app-mobilephone/gnokii/gnokii-0.6.26.ebuild
+++ b/app-mobilephone/gnokii/gnokii-0.6.26-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.26.ebuild,v 1.1 2008/06/01 12:18:38 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.26-r1.ebuild,v 1.1 2008/06/01 21:44:29 mrness Exp $
WANT_AUTOMAKE="none"
@@ -36,15 +36,10 @@ CONFIG_CHECK="UNIX98_PTYS"
MY_AVAILABLE_LINGUAS=" cs de et fi fr it nl pl pt sk sl sv zh_CN"
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_compile() {
strip-linguas ${MY_AVAILABLE_LINGUAS}
-}
-src_compile() {
- config_xdebug="--disable-xdebug"
+ local config_xdebug="--disable-xdebug"
use X && use debug && config_xdebug="--enable-xdebug"
econf \
@@ -54,49 +49,36 @@ src_compile() {
$(use_enable irda) \
$(use_enable bluetooth) \
$(use_with X x) \
- $(use_enable debug) \
+ $(use_with sms smsd) \
+ $(use_enable debug fulldebug) \
${config_xdebug} \
$(use_enable debug rlpdebug) \
- --enable-security \
+ --enable-security \
--disable-unix98test \
+ --disable-libpcsclite \
|| die "configure failed"
emake -j1 || die "make failed"
-
- if use sms; then
- pushd "${S}/smsd"
- emake || die "smsd make install failed"
- popd
- fi
}
src_install() {
einstall || die "make install failed"
- if use X; then
- insinto /usr/share/pixmaps
- newins Docs/sample/logo/gnokii.xpm xgnokii.xpm
- fi
-
insinto /etc
doins Docs/sample/gnokiirc
sed -i -e 's:/usr/local:/usr:' "${D}/etc/gnokiirc"
- doman Docs/man/*
-
- dodir "/usr/share/doc/${PF}"
- cp -r Docs/sample "${D}/usr/share/doc/${PF}/sample"
- cp -r Docs/protocol "${D}/usr/share/doc/${PF}/protocol"
- rm -rf Docs/man Docs/sample Docs/protocol
- dodoc Docs/* ChangeLog TODO MAINTAINERS
-
# only one file needs suid root to make a pseudo device
fperms 4755 /usr/sbin/mgnokiidev
- if use sms; then
+ if use X; then
+ insinto /usr/share/pixmaps
+ newins Docs/sample/logo/gnokii.xpm xgnokii.xpm
+ fi
+
+ if use sms; then
pushd "${S}/smsd"
- einstall || die "smsd make install failed"
- insinto /usr/share/doc/${PF}/smsd
+ insinto /usr/share/doc/${PN}/smsd
use mysql && doins sms.tables.mysql.sql README.MySQL
use postgres && doins sms.tables.pq.sql
doins README ChangeLog README.Tru64 action