summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-07-09 19:29:40 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-07-09 19:29:40 +0000
commitc61837d2d14f7dc3e38ab7f7d255d0c0af6dab9a (patch)
tree52553331e3beaa314353af76001b106acdb4a9a7 /app-mobilephone
parentmarked x86 per bug 425518 (diff)
downloadgentoo-2-c61837d2d14f7dc3e38ab7f7d255d0c0af6dab9a.tar.gz
gentoo-2-c61837d2d14f7dc3e38ab7f7d255d0c0af6dab9a.tar.bz2
gentoo-2-c61837d2d14f7dc3e38ab7f7d255d0c0af6dab9a.zip
Fix build with GCC 4.7 wrt bug #425254. Bump EAPI, add missing deps, drop useless README.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/past/ChangeLog10
-rw-r--r--app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch10
-rw-r--r--app-mobilephone/past/past-0.0.4.ebuild14
3 files changed, 26 insertions, 8 deletions
diff --git a/app-mobilephone/past/ChangeLog b/app-mobilephone/past/ChangeLog
index 07f0e241373b..0c679c8820c9 100644
--- a/app-mobilephone/past/ChangeLog
+++ b/app-mobilephone/past/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-mobilephone/past
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/past/ChangeLog,v 1.1 2009/11/11 17:53:35 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/past/ChangeLog,v 1.2 2012/07/09 19:29:40 kensington Exp $
+
+ 09 Jul 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/past-0.0.4-gcc-4.7.patch, past-0.0.4.ebuild:
+ Fix build with GCC 4.7 wrt bug #425254. Bump EAPI, add missing deps, drop
+ useless README.
*past-0.0.4 (11 Nov 2009)
11 Nov 2009; Samuli Suominen <ssuominen@gentoo.org> +past-0.0.4.ebuild:
Initial commit.
-
diff --git a/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch b/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
new file mode 100644
index 000000000000..d2a82e025688
--- /dev/null
+++ b/app-mobilephone/past/files/past-0.0.4-gcc-4.7.patch
@@ -0,0 +1,10 @@
+--- src/device.cpp
++++ src/device.cpp
+@@ -22,6 +22,7 @@
+
+ extern "C" {
+ #include <gnokii.h>
++#include <unistd.h>
+ }
+
+ #include "device.h"
diff --git a/app-mobilephone/past/past-0.0.4.ebuild b/app-mobilephone/past/past-0.0.4.ebuild
index 707e2df72b99..9dc43621b80a 100644
--- a/app-mobilephone/past/past-0.0.4.ebuild
+++ b/app-mobilephone/past/past-0.0.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/past/past-0.0.4.ebuild,v 1.1 2009/11/11 17:53:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/past/past-0.0.4.ebuild,v 1.2 2012/07/09 19:29:40 kensington Exp $
-EAPI=2
+EAPI=4
inherit cmake-utils
DESCRIPTION="A simple SMS tool"
@@ -14,7 +14,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-DEPEND="x11-libs/qt-gui:4
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
app-mobilephone/gnokii[sms]"
+RDEPEND="${DEPEND}"
-DOCS="ChangeLog README TODO"
+DOCS=( ChangeLog TODO )
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )