summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2014-08-19 13:46:46 +0000
committerChris Reffett <creffett@gentoo.org>2014-08-19 13:46:46 +0000
commitd404fdf7b05d4f0f4f8b89353feb7de75b1068b9 (patch)
tree08ee160b975272f22b50195fe5b6ce7a1c397038 /app-mobilephone
parentVersion bump. (diff)
downloadgentoo-2-d404fdf7b05d4f0f4f8b89353feb7de75b1068b9.tar.gz
gentoo-2-d404fdf7b05d4f0f4f8b89353feb7de75b1068b9.tar.bz2
gentoo-2-d404fdf7b05d4f0f4f8b89353feb7de75b1068b9.zip
QA: revbump, EAPI bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/yaps/ChangeLog8
-rw-r--r--app-mobilephone/yaps/yaps-0.96-r5.ebuild84
2 files changed, 91 insertions, 1 deletions
diff --git a/app-mobilephone/yaps/ChangeLog b/app-mobilephone/yaps/ChangeLog
index 1144322ca087..f5dfa39168fa 100644
--- a/app-mobilephone/yaps/ChangeLog
+++ b/app-mobilephone/yaps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/yaps
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/ChangeLog,v 1.28 2014/04/09 07:18:39 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/ChangeLog,v 1.29 2014/08/19 13:46:46 creffett Exp $
+
+*yaps-0.96-r5 (19 Aug 2014)
+
+ 19 Aug 2014; Christopher Reffett <2011creffett@gentoo.org>
+ +yaps-0.96-r5.ebuild:
+ QA: revbump, EAPI bump
09 Apr 2014; Tom Wijsman <TomWij@gentoo.org> metadata.xml:
[QA] Dissolve the mobile-phone herd to maintainer-needed because it is empty
diff --git a/app-mobilephone/yaps/yaps-0.96-r5.ebuild b/app-mobilephone/yaps/yaps-0.96-r5.ebuild
new file mode 100644
index 000000000000..2e7b3f9df100
--- /dev/null
+++ b/app-mobilephone/yaps/yaps-0.96-r5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/yaps/yaps-0.96-r5.ebuild,v 1.1 2014/08/19 13:46:46 creffett Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Yet Another Pager Software (optional with CAPI support)"
+HOMEPAGE="ftp://sunsite.unc.edu/pub/Linux/apps/serialcomm/machines/"
+SRC_URI="capi? ( ftp://ftp.melware.net/capi4yaps/${P}.c4.tgz )
+ !capi? ( ftp://sunsite.unc.edu/pub/Linux/apps/serialcomm/machines/${P}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="capi lua slang unicode"
+
+RDEPEND="capi? ( net-dialup/capi4k-utils )
+ slang? ( >=sys-libs/slang-1.4 )
+ lua? ( dev-lang/lua )
+ !media-sound/abcmidi" # also contains "yaps"
+DEPEND="${RDEPEND}
+ !capi? ( sys-apps/sed )
+ lua? ( virtual/pkgconfig )"
+
+pkg_setup() {
+ if ! use capi; then
+ ewarn
+ ewarn "You are now compiling some very old and unmaintained stuff!"
+ ewarn
+ ewarn "YAPS with CAPI 2.0 support is actively maintained, but needs"
+ ewarn "net-dialup/capi4k-utils installed. We recommend this"
+ ewarn "version, since it can still be used with an ordinary"
+ ewarn "modem (that's what you probably wanted). So just add 'capi'"
+ ewarn "to your USE flags to get the new and maintained version."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ use capi && mv -f "${S}.c4" "${S}"
+ cd "${S}"
+
+ # apply patches
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-getline-rename.patch"
+
+ # fix compile warning
+ use capi || \
+ sed -i -e 's:^\(.*\)\(<stdlib.h>\):\1\2\n\1<string.h>:g' scr.c
+
+ # if specified, convert all relevant files from latin1 to UTF-8
+ if use unicode; then
+ for i in yaps.doc; do
+ einfo "Converting '${i}' to UTF-8"
+ iconv -f latin1 -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use lua && myconf="${myconf} LUA=True"
+ use slang && myconf="${myconf} SLANG=True"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" ${myconf} || die "emake failed"
+}
+
+src_install() {
+ dobin yaps
+ insinto /etc
+ doins yaps.rc
+ keepdir /usr/lib/yaps
+ doman yaps.1
+ dohtml yaps.html
+ dodoc BUGREPORT COPYRIGHT README yaps.lsm yaps.doc
+ newdoc contrib/README README.contrib
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/{m2y.pl,tap.sl}
+}
+
+pkg_postinst() {
+ elog "Please edit /etc/yaps.rc to suit your needs."
+}