summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-06-20 23:05:37 +0000
committerAlin Năstac <mrness@gentoo.org>2008-06-20 23:05:37 +0000
commitf4aafe24f68dfaaf6f8fe5a4cd3f4e3bef2ce836 (patch)
treeb79952b6ce1323cb8f7c45fc609177459e9f78e1 /app-mobilephone
parentRemove dev-java/freemarker mask. (diff)
downloadgentoo-2-f4aafe24f68dfaaf6f8fe5a4cd3f4e3bef2ce836.tar.gz
gentoo-2-f4aafe24f68dfaaf6f8fe5a4cd3f4e3bef2ce836.tar.bz2
gentoo-2-f4aafe24f68dfaaf6f8fe5a4cd3f4e3bef2ce836.zip
Fix broken build on boxes with glibc-2.8 (#227153).
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/vmoconv/ChangeLog6
-rw-r--r--app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch12
-rw-r--r--app-mobilephone/vmoconv/vmoconv-1.0.ebuild12
3 files changed, 27 insertions, 3 deletions
diff --git a/app-mobilephone/vmoconv/ChangeLog b/app-mobilephone/vmoconv/ChangeLog
index 5110f97d620c..2849b66ea9a7 100644
--- a/app-mobilephone/vmoconv/ChangeLog
+++ b/app-mobilephone/vmoconv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-mobilephone/vmoconv
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/vmoconv/ChangeLog,v 1.4 2008/05/30 06:31:59 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/vmoconv/ChangeLog,v 1.5 2008/06/20 23:05:36 mrness Exp $
+
+ 20 Jun 2008; Alin Năstac <mrness@gentoo.org>
+ +files/vmoconv-1.0-glibc28.patch, vmoconv-1.0.ebuild:
+ Fix broken build on boxes with glibc-2.8 (#227153).
30 May 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Andrej Kacian (Ticho) from metadata.xml (as per #59986).
diff --git a/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch b/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
new file mode 100644
index 000000000000..5f3269cc4f8c
--- /dev/null
+++ b/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
@@ -0,0 +1,12 @@
+diff -Naur vmoconv-1.0.orig/src/gsm2vmo.c vmoconv-1.0/src/gsm2vmo.c
+--- vmoconv-1.0.orig/src/gsm2vmo.c 2008-06-15 12:57:07.000000000 -0400
++++ vmoconv-1.0/src/gsm2vmo.c 2008-06-15 12:57:36.000000000 -0400
+@@ -27,7 +27,7 @@
+ * 12 bit header and 260 bits standard GSM frame, as described
+ * in GSM 06.10 and GSM 06.12. The header is 0x2010 always.
+ */
+-
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/app-mobilephone/vmoconv/vmoconv-1.0.ebuild b/app-mobilephone/vmoconv/vmoconv-1.0.ebuild
index c390385db465..b82178729c9d 100644
--- a/app-mobilephone/vmoconv/vmoconv-1.0.ebuild
+++ b/app-mobilephone/vmoconv/vmoconv-1.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/vmoconv/vmoconv-1.0.ebuild,v 1.5 2007/08/18 08:19:38 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/vmoconv/vmoconv-1.0.ebuild,v 1.6 2008/06/20 23:05:36 mrness Exp $
+
+inherit eutils
DESCRIPTION="A tool that converts Siemens phones VMO and VMI audio files to gsm and wav."
HOMEPAGE="http://triq.net/obex/"
@@ -11,6 +13,12 @@ SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-glibc28.patch"
+}
+
src_compile() {
econf || die "configure failed"
# ugly workaround, otherwise make tries to build binaries before