summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-05-15 16:47:28 +0000
committerAlin Năstac <mrness@gentoo.org>2007-05-15 16:47:28 +0000
commitf9a2ca3595d6cf3393b628cba418a3e542d795c4 (patch)
treefcec16f583f753cedf487f682b7c9644154d4265 /app-mobilephone
parentamd64 stable (diff)
downloadgentoo-2-f9a2ca3595d6cf3393b628cba418a3e542d795c4.tar.gz
gentoo-2-f9a2ca3595d6cf3393b628cba418a3e542d795c4.tar.bz2
gentoo-2-f9a2ca3595d6cf3393b628cba418a3e542d795c4.zip
Version bump. The new version works with kernel 2.6.21 (#178635).
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/gammu/ChangeLog8
-rw-r--r--app-mobilephone/gammu/files/digest-gammu-1.11.03
-rw-r--r--app-mobilephone/gammu/files/gammu-1.11.0-fixups.patch29
-rw-r--r--app-mobilephone/gammu/gammu-1.11.0.ebuild49
4 files changed, 88 insertions, 1 deletions
diff --git a/app-mobilephone/gammu/ChangeLog b/app-mobilephone/gammu/ChangeLog
index 814cfbd0e77e..3e722065c3f8 100644
--- a/app-mobilephone/gammu/ChangeLog
+++ b/app-mobilephone/gammu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/gammu
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.36 2007/05/06 04:51:11 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/ChangeLog,v 1.37 2007/05/15 16:47:28 mrness Exp $
+
+*gammu-1.11.0 (15 May 2007)
+
+ 15 May 2007; Alin Năstac <mrness@gentoo.org>
+ +files/gammu-1.11.0-fixups.patch, +gammu-1.11.0.ebuild:
+ Version bump. The new version works with kernel 2.6.21 (#178635).
06 May 2007; Tobias Scherbaum <dertobi123@gentoo.org>
gammu-1.09.00.ebuild:
diff --git a/app-mobilephone/gammu/files/digest-gammu-1.11.0 b/app-mobilephone/gammu/files/digest-gammu-1.11.0
new file mode 100644
index 000000000000..08b70f1a1481
--- /dev/null
+++ b/app-mobilephone/gammu/files/digest-gammu-1.11.0
@@ -0,0 +1,3 @@
+MD5 7b46148677ba82dd2f4eca749bc9e975 gammu-1.11.0.tar.bz2 920489
+RMD160 903624c472b9d5225783e064d3a393060a4dcc37 gammu-1.11.0.tar.bz2 920489
+SHA256 5d18cbf162edb8f54c47621b8dbf0683359e74ad67a985360cfcc4c810f2a086 gammu-1.11.0.tar.bz2 920489
diff --git a/app-mobilephone/gammu/files/gammu-1.11.0-fixups.patch b/app-mobilephone/gammu/files/gammu-1.11.0-fixups.patch
new file mode 100644
index 000000000000..93575a47a50b
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-1.11.0-fixups.patch
@@ -0,0 +1,29 @@
+diff -Nru gammu-1.11.0.orig/common/phone/at/atgen.c gammu-1.11.0/common/phone/at/atgen.c
+--- gammu-1.11.0.orig/common/phone/at/atgen.c 2007-05-11 11:14:47.000000000 +0300
++++ gammu-1.11.0/common/phone/at/atgen.c 2007-05-15 19:37:00.000000000 +0300
+@@ -642,7 +642,7 @@
+ if (GetLineLength(msg.Buffer, Priv->Lines, 2) <= MAX_MANUFACTURER_LENGTH) {
+ CopyLineString(s->Phone.Data.Manufacturer, msg.Buffer, Priv->Lines, 2);
+ } else {
+- smprintf(s, "WARNING: Manufacturer name too long, increase MAX_MANUFACTURER_LENGTH to at least %zd\n", GetLineLength(msg.Buffer, Priv->Lines, 2));
++ smprintf(s, "WARNING: Manufacturer name too long, increase MAX_MANUFACTURER_LENGTH to at least %d\n", GetLineLength(msg.Buffer, Priv->Lines, 2));
+ s->Phone.Data.Manufacturer[0] = 0;
+ }
+ /* Sometimes phone adds this before manufacturer (Sagem) */
+diff -Nru gammu-1.11.0.orig/common/service/gsmcal.c gammu-1.11.0/common/service/gsmcal.c
+--- gammu-1.11.0.orig/common/service/gsmcal.c 2007-05-03 12:55:44.000000000 +0300
++++ gammu-1.11.0/common/service/gsmcal.c 2007-05-15 19:39:36.000000000 +0300
+@@ -677,11 +677,11 @@
+ if (Version == Mozilla_iCalendar) {
+ if (!header) {
+ *Length += sprintf(Buffer + (*Length), ";BYDAY=%s",
+- DaysOfWeek[note->Entries[j].Number]);
++ DaysOfWeek[note->Entries[i].Number]);
+ header = true;
+ } else {
+ *Length += sprintf(Buffer + (*Length), ",%s",
+- DaysOfWeek[note->Entries[j].Number]);
++ DaysOfWeek[note->Entries[i].Number]);
+ }
+ } else {
+ *Length += sprintf(Buffer + (*Length), " %s",
diff --git a/app-mobilephone/gammu/gammu-1.11.0.ebuild b/app-mobilephone/gammu/gammu-1.11.0.ebuild
new file mode 100644
index 000000000000..ae84df2f292a
--- /dev/null
+++ b/app-mobilephone/gammu/gammu-1.11.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gammu/gammu-1.11.0.ebuild,v 1.1 2007/05/15 16:47:28 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="a fork of the gnokii project, a tool to handle your cellular phone"
+HOMEPAGE="http://www.gammu.org"
+SRC_URI="ftp://dl.cihar.com/gammu/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="debug bluetooth irda mysql postgres"
+
+RDEPEND="bluetooth? ( net-wireless/bluez-libs )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}
+ irda? ( virtual/os-headers )
+ sys-devel/autoconf-wrapper
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-fixups.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ use bluetooth || myconf="${myconf} --disable-bluetooth"
+ use mysql || myconf="${myconf} --disable-mysql"
+ use postgres || myconf="${myconf} --disable-pgsql"
+ use irda || myconf="${myconf} --disable-irda"
+ econf \
+ --prefix=/usr \
+ --enable-cb \
+ --enable-7110incoming \
+ ${myconf} || die "configure failed"
+
+ emake shared || die "make failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" installshared || die "install failed"
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${P}"
+}