summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-04-03 13:41:46 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-04-03 13:41:46 +0000
commit3650d44c31d3df24f6215432effa0045eb3fc775 (patch)
tree5fcea9e72ae5c33e22db78034a6dd8eb0a39aba8 /app-office/dia
parentuse system pcre as suggested by Dennis Schridde in bug #215837 (diff)
downloadgentoo-2-3650d44c31d3df24f6215432effa0045eb3fc775.tar.gz
gentoo-2-3650d44c31d3df24f6215432effa0045eb3fc775.tar.bz2
gentoo-2-3650d44c31d3df24f6215432effa0045eb3fc775.zip
Remove man generation if USE="-doc", fix bug #205067.
Always install documentation where gnome can find it. Conditional destination doesn't do any good anyway, fix #159381 (Portage version: 2.1.4.4)
Diffstat (limited to 'app-office/dia')
-rw-r--r--app-office/dia/ChangeLog11
-rw-r--r--app-office/dia/dia-0.96.1-r1.ebuild90
-rw-r--r--app-office/dia/files/dia-0.96.1-gnome-doc.patch113
-rw-r--r--app-office/dia/files/dia-0.96.1-xml-fixes.patch23
4 files changed, 236 insertions, 1 deletions
diff --git a/app-office/dia/ChangeLog b/app-office/dia/ChangeLog
index a33deeb13b3f..200c6a7bedeb 100644
--- a/app-office/dia/ChangeLog
+++ b/app-office/dia/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-office/dia
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.99 2008/03/09 16:21:33 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.100 2008/04/03 13:41:46 eva Exp $
+
+*dia-0.96.1-r1 (03 Apr 2008)
+
+ 03 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/dia-0.96.1-gnome-doc.patch, +files/dia-0.96.1-xml-fixes.patch,
+ +dia-0.96.1-r1.ebuild:
+ Remove man generation if USE="-doc", fix bug #205067. Always install
+ documentation where gnome can find it. Conditional destination doesn't do
+ any good anyway, fix #159381.
09 Mar 2008; Mart Raudsepp <leio@gentoo.org> dia-0.95.1.ebuild,
dia-0.96.1.ebuild:
diff --git a/app-office/dia/dia-0.96.1-r1.ebuild b/app-office/dia/dia-0.96.1-r1.ebuild
new file mode 100644
index 000000000000..11809e69a966
--- /dev/null
+++ b/app-office/dia/dia-0.96.1-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.96.1-r1.ebuild,v 1.1 2008/04/03 13:41:46 eva Exp $
+
+inherit eutils gnome2 libtool autotools versionator python
+
+DESCRIPTION="Diagram/flowchart creation program"
+HOMEPAGE="http://www.gnome.org/projects/dia/"
+LICENSE="GPL-2"
+
+# dia used -1 instead of .1 for the new version.
+MY_PV_MM=$(get_version_component_range 1-2 )
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV_MM}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+# the doc USE flag doesn't seem to do anything without docbook2html
+IUSE="cairo doc gnome gnome-print png python zlib"
+
+RDEPEND=">=x11-libs/gtk+-2.6.0
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/pango-1.1.5
+ >=dev-libs/libxml2-2.3.9
+ >=dev-libs/libxslt-1
+ >=media-libs/freetype-2.0.95
+ dev-libs/popt
+ zlib? ( sys-libs/zlib )
+ png? (
+ media-libs/libpng
+ >=media-libs/libart_lgpl-2 )
+ gnome? (
+ >=gnome-base/libgnome-2.0
+ >=gnome-base/libgnomeui-2.0 )
+ gnome-print? ( gnome-base/libgnomeprint )
+ cairo? ( x11-libs/cairo )
+ python? (
+ >=dev-lang/python-1.5.2
+ >=dev-python/pygtk-1.99 )
+ doc? (
+ ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with cairo)
+ $(use_with python)
+ $(use_enable doc db2html)
+ $(use_enable gnome)
+ $(use_with gnome-print gnomeprint)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Disable python -c 'import gtk' during compile to prevent using
+ # X being involved (#31589)
+ # changed the patch to a sed to make it a bit more portable - AllanonJL
+ sed -i -e '/AM_CHECK_PYMOD/d' configure.in
+
+ # Fix compilation in a gnome environment, bug #159831
+ epatch "${FILESDIR}/${PN}-0.96.1-gnome-doc.patch"
+
+ # Fix broken XML in documentation
+ epatch "${FILESDIR}/${PN}-0.96.1-xml-fixes.patch"
+
+ # Skip man generation
+ use doc || sed -i -e '/if HAVE_DB2MAN/,/man_MANS/d' doc/*/Makefile.am
+
+ # Fix tests
+ echo "dia.desktop.in" >> po/POTFILES.skip
+
+ eautoreconf
+ intltoolize --force || die "intltoolize failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize "${ROOT}"/usr/share/dia
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use python && python_mod_cleanup /usr/share/dia
+}
diff --git a/app-office/dia/files/dia-0.96.1-gnome-doc.patch b/app-office/dia/files/dia-0.96.1-gnome-doc.patch
new file mode 100644
index 000000000000..370fad1a5435
--- /dev/null
+++ b/app-office/dia/files/dia-0.96.1-gnome-doc.patch
@@ -0,0 +1,113 @@
+--- xmldocs.make 2007-01-06 23:39:36.000000000 +0100
++++ xmldocs.make 2008-02-12 12:45:21.000000000 +0100
+@@ -36,11 +36,7 @@
+ # ********** Begin of section some packagers may need to modify **********
+ # This variable (docdir) specifies where the documents should be installed.
+ # This default value should work for most packages.
+-if HAVE_GNOME
+ docdir = $(datadir)/gnome/help/$(docname)/$(lang)
+-else
+-docdir = $(datadir)/help/$(docname)/$(lang)
+-endif
+
+ # ********** You should not have to edit below this line **********
+ xml_files = $(entities) $(docname).xml
+--- doc/Makefile.am 2008-02-12 12:51:13.000000000 +0100
++++ doc/Makefile.am 2008-02-12 12:45:59.000000000 +0100
+@@ -11,6 +11,7 @@
+ helpdir = $(datadir)/gnome/help/dia
+ else
+ helpdir = $(pkgdatadir)/help
++docdir = $(datadir)/help/$(docname)/$(lang)
+ endif
+
+ # a simple rule to symlink en to C
+--- doc/en/Makefile.am 2008-02-12 12:51:13.000000000 +0100
++++ doc/en/Makefile.am 2008-02-12 12:47:12.000000000 +0100
+@@ -5,6 +5,11 @@
+ entities=
+
+ include $(top_srcdir)/xmldocs.make
++
++if ! HAVE_GNOME
++docdir = $(datadir)/help/$(docname)/$(lang)
++endif
++
+ dist-hook: app-dist-hook
+
+ nodist_include_EXTRAS = dia.1
+--- doc/eu/Makefile.am 2008-02-12 12:51:13.000000000 +0100
++++ doc/eu/Makefile.am 2008-02-12 12:47:23.000000000 +0100
+@@ -5,6 +5,11 @@
+ entities=
+
+ include $(top_srcdir)/xmldocs.make
++
++if ! HAVE_GNOME
++docdir = $(datadir)/help/$(docname)/$(lang)
++endif
++
+ dist-hook: app-dist-hook
+
+ EXTRA_DIST += \
+--- doc/pl/Makefile.am 2008-02-12 12:51:13.000000000 +0100
++++ doc/pl/Makefile.am 2008-02-12 12:47:33.000000000 +0100
+@@ -5,6 +5,11 @@
+ entities=
+
+ include $(top_srcdir)/xmldocs.make
++
++if ! HAVE_GNOME
++docdir = $(datadir)/help/$(docname)/$(lang)
++endif
++
+ dist-hook: app-dist-hook
+
+ EXTRA_DIST += \
+--- configure.in 2008-02-12 12:13:12.000000000 +0100
++++ configure.in 2008-02-12 12:40:16.000000000 +0100
+@@ -111,17 +111,19 @@
+ fi
+
+ AC_MSG_CHECKING([whether GNOME specific code should be used])
+-AC_ARG_ENABLE(gnome,[ --enable-gnome enable gnome code],
+- GNOME=$enableval, GNOME=no)
+-if test "$GNOME" = "yes" ; then
++AC_ARG_ENABLE(gnome,
++ AC_HELP_STRING([--enable-gnome],[enable gnome code]),,
++ enable_gnome=no)
++if test "x$enable_gnome" = "xyes" ; then
+ GTK_MODULES="$GTK_MODULES libgnome-2.0 libgnomeui-2.0"
+ AC_DEFINE(GNOME,1,[Define if building with GNOME support])
++ AC_DEFINE(HAVE_GNOME,1,[Define if building with GNOME support])
+ AC_DEFINE_UNQUOTED(GNOME_ICONDIR, "${prefix}/share/pixmaps", [GNOME icon directory])
+- have_gnome=true
++ have_gnome=yes
+ else
+- have_gnome=false
++ have_gnome=no
+ fi
+-AM_CONDITIONAL(HAVE_GNOME, $have_gnome)
++AM_CONDITIONAL(HAVE_GNOME, [test "x$have_gnome" != "xno"])
+ AC_MSG_RESULT($GNOME)
+
+ dnl GTK2: libgnomecanvas-2.0 ?
+@@ -130,7 +132,8 @@
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
+-AM_CONDITIONAL(HAVE_BONOBO,false)
++#AM_CONDITIONAL(HAVE_BONOBO,false)
++AM_CONDITIONAL(HAVE_BONOBO,[test "true" = "false"])
+
+ dnl Look for Gnome Print
+ AC_ARG_WITH(gnomeprint,
+@@ -534,7 +537,7 @@
+ Source code location: ${srcdir}
+ Compiler: ${CC}
+
+- Gnome support: ${GNOME}
++ Gnome support: ${have_gnome}
+ Python support: ${with_python}
+ Libart support (PNG export): ${have_libart}
+ Cairo support (experimental): ${with_cairo}
diff --git a/app-office/dia/files/dia-0.96.1-xml-fixes.patch b/app-office/dia/files/dia-0.96.1-xml-fixes.patch
new file mode 100644
index 000000000000..d225a70425b8
--- /dev/null
+++ b/app-office/dia/files/dia-0.96.1-xml-fixes.patch
@@ -0,0 +1,23 @@
+--- doc/en/dia.xml 2007-03-29 08:08:39.000000000 +0200
++++ doc/en/dia.xml 2008-04-03 12:04:19.000000000 +0200
+@@ -4,8 +4,7 @@
+
+ <!DOCTYPE book
+
+- PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN" "../../dtd/docbookx.dtd"
+-
++ PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN" "http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd"
+ [
+
+ <!ENTITY VERSION "0.96.1">
+--- doc/en/usage-layers.xml 2007-01-21 17:12:45.000000000 +0100
++++ doc/en/usage-layers.xml 2008-04-03 12:03:43.000000000 +0200
+@@ -26,7 +26,7 @@
+ </para>
+ </tip>
+ <para>
+- Each new diagram comes with the default layer labelled “Background”. Of course you can change its name and settings to customize it to your needs as you can do with any other layer.
++ Each new diagram comes with the default layer labelled <emphasis>Background</emphasis>. Of course you can change its name and settings to customize it to your needs as you can do with any other layer.
+ </para>
+ <para>
+ You can use layers to create overlay slide show by drawing each incremental slide in a