summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-06 20:15:36 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-06 20:15:36 +0000
commit7d88dbf7b26efbf91a26be36aa593640ac1ffdfd (patch)
treea2486ace6c6e6cbfe9ac89cd963d2cd1cdb6448f /app-office/dia
parenta new app, a kde interface to cdrecord etc (diff)
downloadgentoo-2-7d88dbf7b26efbf91a26be36aa593640ac1ffdfd.tar.gz
gentoo-2-7d88dbf7b26efbf91a26be36aa593640ac1ffdfd.tar.bz2
gentoo-2-7d88dbf7b26efbf91a26be36aa593640ac1ffdfd.zip
gnome-office almost finished, need to look at gnome-extra/gnome-db
Diffstat (limited to 'app-office/dia')
-rw-r--r--app-office/dia/dia-0.88.1-r1.ebuild53
-rw-r--r--app-office/dia/dia-0.88.1.ebuild64
-rw-r--r--app-office/dia/files/digest-dia-0.88.1-r1 (renamed from app-office/dia/files/digest-dia-0.88.1)0
3 files changed, 53 insertions, 64 deletions
diff --git a/app-office/dia/dia-0.88.1-r1.ebuild b/app-office/dia/dia-0.88.1-r1.ebuild
new file mode 100644
index 000000000000..a4166b7c9e36
--- /dev/null
+++ b/app-office/dia/dia-0.88.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1-r1.ebuild,v 1.1 2001/10/06 20:15:36 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Diagram Creation Program"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
+
+RDEPEND=">=dev-libs/libxml-1.8.15
+ >=media-libs/gdk-pixbuf-0.11.0-r1
+ >=dev-libs/popt-1.5
+ bonobo? ( >=gnome-base/bonobo-1.0.9-r1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+# python? ( dev-lang/python-2.0 )"
+
+src_compile() {
+ local myconf
+
+ if [ "`use gnome`" ] ; then
+ myconf="--enable-gnome"
+ fi
+
+ if [ "`use bonobo`" ]; then
+ myconf="--enable-gnome --enable-bonobo"
+ fi
+
+# if [ "`use python`" ] ; then
+# myconf="$myconf --with-python"
+# fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myconf} || die
+
+ # enable-gnome-print not recoomended
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
+}
diff --git a/app-office/dia/dia-0.88.1.ebuild b/app-office/dia/dia-0.88.1.ebuild
deleted file mode 100644
index 04c4fc3c382e..000000000000
--- a/app-office/dia/dia-0.88.1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1.ebuild,v 1.7 2001/10/06 14:36:55 azarah Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Diagram Creation Program"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
-HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
-
-DEPEND=">=dev-libs/libxml-1.8.13 nls? ( sys-devel/gettext )
- >=media-libs/gdk-pixbuf-0.11.0
- >=dev-libs/popt-1.5
- bonobo? ( >=gnome-base/bonobo-1.0.4 )
- python? ( dev-lang/python-2.0 )"
-
-RDEPEND=">=dev-libs/libxml-1.8.13
- >=media-libs/gdk-pixbuf-0.11.0
- >=dev-libs/popt-1.5
- bonobo? ( >=gnome-base/bonobo-1.0.4 )"
-
-src_compile() {
-
- local myconf
- local myprefix
- myprefix="--prefix=/usr/X11R6 --sysconfdir=/etc/X11"
- if [ "`use gnome`" ] ; then
- myconf="--enable-gnome"
- myprefix="--prefix=/opt/gnome --sysconfdir=/etc/opt/gnome"
- else
- myconf=""
- fi
-
- if [ "`use bonobo`" ]; then
- myconf="--enable-gnome --enable-bonobo"
- fi
-# if [ "`use python`" ] ; then
-# myconf="$myconf --with-python"
-# fi
- if [ -z "`use nls`" ] ; then
- myconf="$myconf --disable-nls"
- fi
- try ./configure --host=${CHOST} ${myprefix} ${myconf}
- # enable-gnome-print not recoomended
- try pmake
-
-}
-
-src_install () {
- myprefix="prefix=${D}/usr/X11R6 sysconfdir=${D}/etc/X11"
- if [ "`use gnome`" ] ; then
- myconf="--enable-gnome"
- myprefix="prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome"
- fi
- try make $myprefix install
- dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
-
-}
-
-
-
-
-
diff --git a/app-office/dia/files/digest-dia-0.88.1 b/app-office/dia/files/digest-dia-0.88.1-r1
index 77311d467dc7..77311d467dc7 100644
--- a/app-office/dia/files/digest-dia-0.88.1
+++ b/app-office/dia/files/digest-dia-0.88.1-r1