summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-07-14 22:41:36 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-07-14 22:41:36 +0000
commite9879077a355396f4092cb88e3a9c8996aec65a2 (patch)
tree9f574653f91ea06ae23107797420f33169d5f016 /app-office/dia
parentAdd new upstream version with the official fix for CVE-2009-0692, fix DoS iss... (diff)
downloadgentoo-2-e9879077a355396f4092cb88e3a9c8996aec65a2.tar.gz
gentoo-2-e9879077a355396f4092cb88e3a9c8996aec65a2.tar.bz2
gentoo-2-e9879077a355396f4092cb88e3a9c8996aec65a2.zip
Version bump. Fix inverted test to build documentation, bug #271047. Fix bashism in configure.ac. Fix automagic libemf detection, bug #276148.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-office/dia')
-rw-r--r--app-office/dia/ChangeLog9
-rw-r--r--app-office/dia/dia-0.97-r1.ebuild104
-rw-r--r--app-office/dia/files/dia-0.97-automagic-libemf.patch63
-rw-r--r--app-office/dia/files/dia-0.97-fix-bashism.patch60
4 files changed, 235 insertions, 1 deletions
diff --git a/app-office/dia/ChangeLog b/app-office/dia/ChangeLog
index 6a754710b3e6..c91f98253c89 100644
--- a/app-office/dia/ChangeLog
+++ b/app-office/dia/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/dia
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.112 2009/06/27 10:26:45 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.113 2009/07/14 22:41:36 eva Exp $
+
+*dia-0.97-r1 (14 Jul 2009)
+
+ 14 Jul 2009; Gilles Dartiguelongue <eva@gentoo.org> +dia-0.97-r1.ebuild,
+ +files/dia-0.97-automagic-libemf.patch, +files/dia-0.97-fix-bashism.patch:
+ Version bump. Fix inverted test to build documentation, bug #271047. Fix
+ bashism in configure.ac. Fix automagic libemf detection, bug #276148.
27 Jun 2009; Romain Perier <mrpouet@gentoo.org> dia-0.97.ebuild:
Fix bug #275468 -- automake failure for doc/*/Makefile.am to a bad sed
diff --git a/app-office/dia/dia-0.97-r1.ebuild b/app-office/dia/dia-0.97-r1.ebuild
new file mode 100644
index 000000000000..214a3f3d9ebd
--- /dev/null
+++ b/app-office/dia/dia-0.97-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.97-r1.ebuild,v 1.1 2009/07/14 22:41:36 eva Exp $
+
+EAPI="2"
+
+inherit eutils gnome2 libtool autotools versionator python
+
+MY_P=${P/_/-}
+DESCRIPTION="Diagram/flowchart creation program"
+HOMEPAGE="http://www.gnome.org/projects/dia/"
+LICENSE="GPL-2"
+
+# dia used -1 instead of .1 for the new version.
+MY_PV_MM=$(get_version_component_range 1-2)
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV_MM}/${MY_P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+# the doc USE flag doesn't seem to do anything without docbook2html
+# FIXME: configure mixes debug and devel meaning (see -DGTK_DISABLE...)
+IUSE="cairo doc gnome png python zlib"
+
+RDEPEND=">=x11-libs/gtk+-2.6.0
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/pango-1.8
+ >=dev-libs/libxml2-2.3.9
+ >=dev-libs/libxslt-1
+ >=media-libs/freetype-2.0.95
+ dev-libs/popt
+ zlib? ( sys-libs/zlib )
+ png? (
+ media-libs/libpng
+ >=media-libs/libart_lgpl-2 )
+ gnome? (
+ >=gnome-base/libgnome-2.0
+ >=gnome-base/libgnomeui-2.0 )
+ cairo? ( >=x11-libs/cairo-1 )
+ python? (
+ >=dev-lang/python-1.5.2
+ >=dev-python/pygtk-1.99 )
+ doc? (
+ ~app-text/docbook-xml-dtd-4.5
+ app-text/docbook-xsl-stylesheets )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ dev-util/pkgconfig
+ doc? ( dev-libs/libxslt )"
+
+DOCS="AUTHORS ChangeLog KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with cairo)
+ $(use_with python)
+ $(use_enable doc db2html)
+ $(use_enable gnome)
+ --disable-libemf
+ --without-swig
+ --without-hardbooks
+ --disable-static
+ --docdir=/usr/share/doc/${PF}"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix compilation in a gnome environment, bug #159831
+ epatch "${FILESDIR}/${PN}-0.97.0-gnome-doc.patch"
+
+ # Fix compilation with USE="python", bug #271855
+ if use python; then
+ epatch "${FILESDIR}/${P}-acinclude-python-fixes.patch"
+ fi
+
+ # Skip man generation
+ if ! use doc; then
+ sed -i -e '/if HAVE_DB2MAN/,/endif/d' doc/*/Makefile.am \
+ || die "sed 2 failed"
+ fi
+
+ # Fix automagic libEMF, bug #276148
+ epatch "${FILESDIR}/${P}-automagic-libemf.patch"
+
+ # Fix bashism
+ epatch "${FILESDIR}/${P}-fix-bashism.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_need_rebuild
+ python_mod_optimize /usr/share/dia
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/share/dia
+}
diff --git a/app-office/dia/files/dia-0.97-automagic-libemf.patch b/app-office/dia/files/dia-0.97-automagic-libemf.patch
new file mode 100644
index 000000000000..d23c05b1bab2
--- /dev/null
+++ b/app-office/dia/files/dia-0.97-automagic-libemf.patch
@@ -0,0 +1,63 @@
+From 8e41f38007b46f1a1da655b81acd88fc491df59e Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 14 Jul 2009 20:17:18 +0200
+Subject: [PATCH] Make libemf plugin optional.
+
+---
+ configure.in | 36 +++++++++++++++++++++++-------------
+ 1 files changed, 23 insertions(+), 13 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 11f3705..cc5d3aa 100644
+--- a/configure.in
++++ b/configure.in
+@@ -214,23 +214,33 @@ AC_SUBST(PNG_LIBS)
+ LIBS="${old_LIBS} ${PNG_LIBS}"
+
+ dnl check for libEMF to provide Windows Metafile plug-in on Linux
+-old_CPPFLAGS="${CPPFLAGS}"
+-old_CFLAGS="${CFLAGS}"
+-old_LIBS="${LIBS}"
+-CPPFLAGS="${CPPFLAGS} -I /usr/include/libEMF"
+-AC_CHECK_HEADER(emf.h, emf_ok=yes, emf_ok=no)
+-AC_CHECK_LIB(EMF, CreateEnhMetaFileWithFILEW, , emf_ok=no, -lstdc++)
+-if test "$emf_ok" = yes; then
+- LIBEMF_CFLAGS='-I /usr/include/libEMF'
+- LIBEMF_LIBS='-lEMF -lstdc++'
+- AC_DEFINE(HAVE_LIBEMF,1,[libEMF library available])
++AC_ARG_ENABLE([libemf],
++ AS_HELP_STRING([--enable-libemf], [enable plugin for windows metafile support]),
++ ,
++ enable_libemf=yes)
++
++if test "$enable_libemf" = "yes"; then
++ old_CPPFLAGS="${CPPFLAGS}"
++ old_CFLAGS="${CFLAGS}"
++ old_LIBS="${LIBS}"
++
++ CPPFLAGS="${CPPFLAGS} -I /usr/include/libEMF"
++ AC_CHECK_HEADER(emf.h, emf_ok=yes, emf_ok=no)
++ AC_CHECK_LIB(EMF, CreateEnhMetaFileWithFILEW, , emf_ok=no, -lstdc++)
++
++ if test "$emf_ok" = yes; then
++ LIBEMF_CFLAGS='-I /usr/include/libEMF'
++ LIBEMF_LIBS='-lEMF -lstdc++'
++ AC_DEFINE(HAVE_LIBEMF,1,[libEMF library available])
++ fi
++
++ CPPFLAGS="${old_CPPFLAGS}"
++ CFLAGS="${old_CFLAGS}"
++ LIBS="${old_LIBS}"
+ fi
+ AC_SUBST(LIBEMF_CFLAGS)
+ AC_SUBST(LIBEMF_LIBS)
+ AM_CONDITIONAL(WITH_LIBEMF, test "$emf_ok" = yes)
+-CPPFLAGS="${old_CPPFLAGS}"
+-CFLAGS="${old_CFLAGS}"
+-LIBS="${old_LIBS}"
+
+ dnl
+ dnl Debugging
+--
+1.6.3.3
+
diff --git a/app-office/dia/files/dia-0.97-fix-bashism.patch b/app-office/dia/files/dia-0.97-fix-bashism.patch
new file mode 100644
index 000000000000..21d62a5508dc
--- /dev/null
+++ b/app-office/dia/files/dia-0.97-fix-bashism.patch
@@ -0,0 +1,60 @@
+From 8d1b50c5c8441a24bb5b6c38637155ebe2976c06 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 14 Jul 2009 19:57:25 +0200
+Subject: [PATCH] Fix bashism
+
+---
+ configure.in | 10 +++++-----
+ 1 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index d9c0bf4..11f3705 100644
+--- a/configure.in
++++ b/configure.in
+@@ -61,7 +61,7 @@ PKG_CHECK_MODULES(PANGOVERSION, pango >= 1.8.0, ,
+
+ AC_ARG_WITH(freetype,
+ [ --without-freetype compile without FreeType support],,with_freetype=yes)
+-if test "x$with_freetype" == "xyes"; then
++if test "x$with_freetype" = "xyes"; then
+ PKG_CHECK_MODULES(PANGOFT2,pangoft2,have_pangoft2=true,have_pangoft2=false)
+ if test "$have_pangoft2" = "true"; then
+ dnl On Solaris with Forte C, at least, need to link app/dia with -lfreetype.
+@@ -149,7 +149,7 @@ AM_CONDITIONAL(WITH_CAIRO, test "x$with_cairo" != "xno")
+
+ dnl with gtk+ >= 2.8 this is no longer optional
+ PKG_CHECK_MODULES(PANGOCAIRO,pangocairo, pangocairo_ok=yes, pangocairo_ok=no)
+-if test "x$pangocairo_ok" == "xyes"; then
++if test "x$pangocairo_ok" = "xyes"; then
+ AC_DEFINE(HAVE_PANGOCAIRO_H,1,[Defined to render text with pangocairo not cairos toy API])
+ fi
+
+@@ -260,7 +260,7 @@ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Needed for glib gettext])
+
+ AC_CHECK_PROG(XGETTEXT, xgettext, xgettext, none)
+-if test "$XGETTEXT" == none ; then
++if test "$XGETTEXT" = none ; then
+ AC_MSG_ERROR([xgettext program not found: $XGETTEXT.])
+ fi
+
+@@ -487,14 +487,14 @@ dnl
+ dnl use jw only if we don't find dblatex
+ dnl
+ AC_PATH_PROG(JW,jw,no)
+-if test "x$dblatex" == "xno"; then
++if test "x$dblatex" = "xno"; then
+ AM_CONDITIONAL(WITH_JW, test "x$jw" != "xno")
+ else
+ AM_CONDITIONAL(WITH_JW, test "xno" != "xno")
+ fi
+ hardbook_ok=no
+ xsltproc_ok=no
+-if test "x$with_hardbooks" == "xno"; then
++if test "x$with_hardbooks" = "xno"; then
+ AM_CONDITIONAL(WITH_JW, test "xno" != "xno")
+ AM_CONDITIONAL(WITH_HTMLDOC, test "xno" != "xno")
+ AM_CONDITIONAL(WITH_PDFDOC, test "xno" != "xno")
+--
+1.6.3.3
+