summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 22:58:49 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 22:58:49 +0000
commit714ba728f16e383520848a8b1a3206dc819c55f4 (patch)
treec662753752acd29f460ec84864bcfb9c4cc6d457 /app-office/gnumeric
parentChanged einstall||die to einstall (diff)
downloadgentoo-2-714ba728f16e383520848a8b1a3206dc819c55f4.tar.gz
gentoo-2-714ba728f16e383520848a8b1a3206dc819c55f4.tar.bz2
gentoo-2-714ba728f16e383520848a8b1a3206dc819c55f4.zip
Changed econf||die to econf
Diffstat (limited to 'app-office/gnumeric')
-rw-r--r--app-office/gnumeric/gnumeric-1.1.6.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/app-office/gnumeric/gnumeric-1.1.6.ebuild b/app-office/gnumeric/gnumeric-1.1.6.ebuild
index 85ddab75ecc2..23af2d482652 100644
--- a/app-office/gnumeric/gnumeric-1.1.6.ebuild
+++ b/app-office/gnumeric/gnumeric-1.1.6.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.1.6.ebuild,v 1.5 2002/10/05 05:39:09 drobbins Exp $
-
-IUSE="nls libgda gb evo python guile perl"
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.1.6.ebuild,v 1.6 2002/11/30 22:58:49 vapier Exp $
#provide Xmake and Xemake
inherit virtualx
-S=${WORKDIR}/${P}
DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
SRC_URI="mirror://gnome/2.0.0/sources/${PN}/${P}.tar.bz2"
HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
@@ -15,6 +12,7 @@ HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="nls libgda gb evo python guile perl"
#Eye Of Gnome (media-gfx/eog) is for image support.
RDEPEND="=x11-libs/gtk+-2.0*
@@ -35,12 +33,10 @@ RDEPEND="=x11-libs/gtk+-2.0*
libgda? ( >=gnome-extra/libgda-0.2.91
>=gnome-base/bonobo-1.0.17 )
evo? ( >=net-mail/evolution-1.0.8 )"
-
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext
>=dev-util/intltool-0.11 )"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -69,7 +65,7 @@ src_compile() {
&& myconf="${myconf} --with-python" \
|| myconf="${myconf} --without-python"
- econf ${myconf} || die
+ econf ${myconf}
#'gnumeric --dump-func-defs' needs to write to ${HOME}/.gnome/, or
#else the build fails.
@@ -81,7 +77,7 @@ src_compile() {
src_install() {
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
- einstall || die
+ einstall
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
}
@@ -91,7 +87,7 @@ pkg_postinst() {
echo ">>> updating GConf2 (modemlights)"
for SCHEMA in gnumeric-dialogs.schemas gnumeric-general.schemas ; do
echo $SCHEMA
- /usr/bin/gconftool-2 --makefile-install-rule \
+ /usr/bin/gconftool-2 --makefile-install-rule \
/etc/gconf/schemas/${SCHEMA}
done
}