summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 15:56:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 15:56:15 +0000
commit8fb60e74f21fe82f2345fac001f6446355ac5846 (patch)
tree349670fa5c515c961c04b22385ecd082b0ca6784 /app-office/karbon
parentStable on Alpha. (diff)
downloadgentoo-2-8fb60e74f21fe82f2345fac001f6446355ac5846.tar.gz
gentoo-2-8fb60e74f21fe82f2345fac001f6446355ac5846.tar.bz2
gentoo-2-8fb60e74f21fe82f2345fac001f6446355ac5846.zip
Update to 1.6.0 final.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'app-office/karbon')
-rw-r--r--app-office/karbon/ChangeLog8
-rw-r--r--app-office/karbon/files/digest-karbon-1.6.03
-rw-r--r--app-office/karbon/karbon-1.6.0.ebuild52
3 files changed, 62 insertions, 1 deletions
diff --git a/app-office/karbon/ChangeLog b/app-office/karbon/ChangeLog
index 75cdd3361bb3..4d208ccd922d 100644
--- a/app-office/karbon/ChangeLog
+++ b/app-office/karbon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/karbon
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.51 2006/10/17 20:37:49 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.52 2006/10/19 15:56:15 flameeyes Exp $
+
+*karbon-1.6.0 (19 Oct 2006)
+
+ 19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -karbon-1.6_beta1.ebuild, -karbon-1.6_rc1.ebuild, +karbon-1.6.0.ebuild:
+ Update to 1.6.0 final.
17 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> karbon-1.5.2.ebuild:
Stable on ia64.
diff --git a/app-office/karbon/files/digest-karbon-1.6.0 b/app-office/karbon/files/digest-karbon-1.6.0
new file mode 100644
index 000000000000..2e01d4cedd36
--- /dev/null
+++ b/app-office/karbon/files/digest-karbon-1.6.0
@@ -0,0 +1,3 @@
+MD5 e669cf19b2e1c7db7029c0772c527c0d koffice-1.6.0.tar.bz2 56718478
+RMD160 be09c18005eb33f6dc35ab0359cc97a8a658ce7c koffice-1.6.0.tar.bz2 56718478
+SHA256 9eddaae640ada9bd184f001e2489854daf7094b73e5f15b0b8deffb4cc654ae2 koffice-1.6.0.tar.bz2 56718478
diff --git a/app-office/karbon/karbon-1.6.0.ebuild b/app-office/karbon/karbon-1.6.0.ebuild
new file mode 100644
index 000000000000..ff720eaf1563
--- /dev/null
+++ b/app-office/karbon/karbon-1.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-1.6.0.ebuild,v 1.1 2006/10/19 15:56:15 flameeyes Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice vector drawing application."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ >=media-gfx/imagemagick-5.5.2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkopalette lib/kopalette
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/karbon"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = liboofilter karbon" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}