summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-14 20:38:15 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-14 20:38:15 +0000
commitd4ae090832019ff0e7ed753c3398e613cf9e17f9 (patch)
tree8ff00965637a92db49d9ba47a1f7da7f89a27d55 /app-office/kexi
parentarm stable (diff)
downloadgentoo-2-d4ae090832019ff0e7ed753c3398e613cf9e17f9.tar.gz
gentoo-2-d4ae090832019ff0e7ed753c3398e613cf9e17f9.tar.bz2
gentoo-2-d4ae090832019ff0e7ed753c3398e613cf9e17f9.zip
KOffice version bump
(Portage version: 2.1.9.31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-office/kexi')
-rw-r--r--app-office/kexi/ChangeLog8
-rw-r--r--app-office/kexi/files/kexi-2.3.0-link.patch11
-rw-r--r--app-office/kexi/kexi-2.3.0.ebuild56
3 files changed, 74 insertions, 1 deletions
diff --git a/app-office/kexi/ChangeLog b/app-office/kexi/ChangeLog
index b44c7c199b4e..fedb7b3db24c 100644
--- a/app-office/kexi/ChangeLog
+++ b/app-office/kexi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kexi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.102 2011/01/12 20:02:43 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.103 2011/01/14 20:38:14 dilfridge Exp $
+
+*kexi-2.3.0 (14 Jan 2011)
+
+ 14 Jan 2011; Andreas K. Huettel <dilfridge@gentoo.org> +kexi-2.3.0.ebuild,
+ +files/kexi-2.3.0-link.patch:
+ Version bump
12 Jan 2011; Andreas K. Huettel <dilfridge@gentoo.org> kexi-2.2.2.ebuild:
Drop dependency on kchart, that ebuild is only a dummy anyway
diff --git a/app-office/kexi/files/kexi-2.3.0-link.patch b/app-office/kexi/files/kexi-2.3.0-link.patch
new file mode 100644
index 000000000000..f2da1448f676
--- /dev/null
+++ b/app-office/kexi/files/kexi-2.3.0-link.patch
@@ -0,0 +1,11 @@
+diff -ruN kexi-2.3.0.orig/kexi/migration/kspread/CMakeLists.txt kexi-2.3.0/kexi/migration/kspread/CMakeLists.txt
+--- kexi-2.3.0.orig/kexi/migration/kspread/CMakeLists.txt 2010-12-29 11:36:25.000000000 +0100
++++ kexi-2.3.0/kexi/migration/kspread/CMakeLists.txt 2011-01-09 01:26:42.838672101 +0100
+@@ -18,6 +18,7 @@
+ kexidb
+ kexiutils
+ kspreadcommon
++ kspreadodf
+ )
+
+ install(TARGETS keximigrate_kspread DESTINATION ${PLUGIN_INSTALL_DIR})
diff --git a/app-office/kexi/kexi-2.3.0.ebuild b/app-office/kexi/kexi-2.3.0.ebuild
new file mode 100644
index 000000000000..9c03c5bc1fcc
--- /dev/null
+++ b/app-office/kexi/kexi-2.3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-2.3.0.ebuild,v 1.1 2011/01/14 20:38:14 dilfridge Exp $
+
+EAPI=3
+
+KMNAME="koffice"
+inherit kde4-meta
+
+DESCRIPTION="KOffice integrated environment for database management"
+KEYWORDS="~amd64 ~x86"
+IUSE="freetds mysql postgres reports xbase"
+
+DEPEND="
+ sys-libs/readline
+ app-arch/bzip2
+ ~app-office/kspread-${PV}:${SLOT}
+ freetds? ( dev-db/freetds )
+ mysql? ( virtual/mysql )
+ postgres? ( =dev-libs/libpqxx-2.6* )
+ reports? ( ~app-office/koffice-libs-${PV}:${SLOT}[reports] )
+ xbase? ( dev-db/xbase )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}"-link.patch )
+
+KMLOADLIBS="koffice-libs"
+KMEXTRACTONLY="
+ KoConfig.h.cmake
+ libs/
+ kspread/
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_WEBFORMS=Off
+ $(cmake-utils_use_with freetds FreeTDS)
+ $(cmake-utils_use_with mysql MySQL)
+ $(cmake-utils_use_with postgres PostgreSQL)
+ $(cmake-utils_use_with postgres Pqxx)
+ $(cmake-utils_use_with xbase XBase)
+ -DBUILD_kexi=ON
+ $(cmake-utils_use_build reports koreport)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+ rm -f "${D}/usr/include/KoConfig.h"
+}