summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-04-04 19:25:42 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-04-04 19:25:42 +0000
commit5dd84a804958813be24e10aafd0167e3c8950b0e (patch)
tree846b71514f0fb37471dd92f42d5159ad90e189e2 /app-office/koffice
parentre-added kde3 progs (diff)
downloadgentoo-2-5dd84a804958813be24e10aafd0167e3c8950b0e.tar.gz
gentoo-2-5dd84a804958813be24e10aafd0167e3c8950b0e.tar.bz2
gentoo-2-5dd84a804958813be24e10aafd0167e3c8950b0e.zip
fixes.. hopefully ready now
Diffstat (limited to 'app-office/koffice')
-rw-r--r--app-office/koffice/koffice-1.2_pre20020402.ebuild36
1 files changed, 32 insertions, 4 deletions
diff --git a/app-office/koffice/koffice-1.2_pre20020402.ebuild b/app-office/koffice/koffice-1.2_pre20020402.ebuild
index 0ac16b9487d0..95b80bb22cdc 100644
--- a/app-office/koffice/koffice-1.2_pre20020402.ebuild
+++ b/app-office/koffice/koffice-1.2_pre20020402.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2_pre20020402.ebuild,v 1.1 2002/04/02 18:44:38 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2_pre20020402.ebuild,v 1.2 2002/04/04 19:25:42 verwilst Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde-base || die
-need-kde 2.2.2
+need-kde 3
S=${WORKDIR}/${PN}
DESCRIPTION="KDE Office Set"
@@ -16,6 +16,34 @@ SRC_URI="http://www.ibiblio.org/gentoo/distfiles/koffice-20020402.tar.bz2"
DEPEND="$DEPEND
>=dev-lang/python-2.0-r5"
-# >=sys-devel/automake-1.4
-# >=sys-devel/autoconf-1.13"
+
+
+src_compile() {
+
+ export LIBPYTHON="`python-config --libs`"
+ export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+
+ myconf="$myconf --enable-all"
+ kde_src_compile myconf
+
+ #the dir kchar/kdchart cannot be compiled with the -fomit-frame-pointer flag present
+ CFLAGS2="$CFLAGS"
+ CXXFLAGS2="$CXXFLAGS"
+
+ CFLAGS=${CFLAGS/-fomit-frame-pointer}
+ CXXFLAGS=${CXXFLAGS/-fomit-frame-pointer}
+
+ cd ${S}
+ kde_src_compile configure
+ cd kchart/kdchart
+ emake || die
+
+ cd ${S}
+ CFLAGS="$CFLAGS2"
+ CXXFLAGS="$CXXFLAGS2"
+ kde_src_compile configure
+ emake || die
+
+}
+