summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-11-11 19:08:43 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-11-11 19:08:43 +0000
commitcb11425bf013f045274f8dd22fbb71da5fdf00c8 (patch)
treeed4ce4c02e71922d09b540240461b05cb2ddb97d /app-office/kword/kword-1.6.3-r2.ebuild
parentStable on x86 wrt bug #198590 (diff)
downloadgentoo-2-cb11425bf013f045274f8dd22fbb71da5fdf00c8.tar.gz
gentoo-2-cb11425bf013f045274f8dd22fbb71da5fdf00c8.tar.bz2
gentoo-2-cb11425bf013f045274f8dd22fbb71da5fdf00c8.zip
Added an upstream patch to fix security bug 198409. Fixed the desktop files as per bug 190006. Thanks to gentoofan23 for providing patches!
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-office/kword/kword-1.6.3-r2.ebuild')
-rw-r--r--app-office/kword/kword-1.6.3-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-office/kword/kword-1.6.3-r2.ebuild b/app-office/kword/kword-1.6.3-r2.ebuild
new file mode 100644
index 000000000000..d59262f47b56
--- /dev/null
+++ b/app-office/kword/kword-1.6.3-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-1.6.3-r2.ebuild,v 1.1 2007/11/11 19:08:42 philantrop Exp $
+
+KMNAME=koffice
+MAXKOFFICEVER=${PV}
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice word processor."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ $(deprange 1.6.2 $MAXKOFFICEVER app-office/kspread)
+ >=app-text/wv2-0.1.8
+ >=media-gfx/imagemagick-5.5.2
+ >=app-text/libwpd-0.8.2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkspreadcommon kspread"
+
+KMEXTRACTONLY="
+ lib/
+ kspread/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kword"
+
+need-kde 3.5
+
+PATCHES="${FILESDIR}/koffice-xpdf-CVE-2007-3387.diff
+ ${FILESDIR}/koffice-1.6.3-xpdf2-CVE-2007-4352-5392-5393.diff"
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile libs first
+ echo "SUBDIRS = liboofilter kword" > "$S"/filters/Makefile.am
+
+ for i in $(find "${S}"/lib -iname "*\.ui"); do
+ ${QTDIR}/bin/uic ${i} > ${i%.ui}.h
+ done
+
+ kde-meta_src_unpack makefiles
+
+ # Fix the desktop file. cf. bug 190006
+ sed -i -e "s:x-mswrite:x-mswrite;:g" "${S}"/kword/kword.desktop
+}