summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-18 15:23:23 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-18 15:23:23 +0000
commit51e27194e3a7f108610c6baf0f998907be960fbe (patch)
tree083e60dcc411cc375aad1b9af34d752dce2d2ea9 /app-office/ooodi
parentDisable beeping and delays when in regression test mode. (diff)
downloadgentoo-2-51e27194e3a7f108610c6baf0f998907be960fbe.tar.gz
gentoo-2-51e27194e3a7f108610c6baf0f998907be960fbe.tar.bz2
gentoo-2-51e27194e3a7f108610c6baf0f998907be960fbe.zip
cleanups/fix for #15919
Diffstat (limited to 'app-office/ooodi')
-rw-r--r--app-office/ooodi/ChangeLog5
-rw-r--r--app-office/ooodi/ooodi-0.55.ebuild33
2 files changed, 17 insertions, 21 deletions
diff --git a/app-office/ooodi/ChangeLog b/app-office/ooodi/ChangeLog
index 80ac7084b0dd..f5974166c3ca 100644
--- a/app-office/ooodi/ChangeLog
+++ b/app-office/ooodi/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-office/ooodi
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ooodi/ChangeLog,v 1.2 2003/02/12 05:13:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ooodi/ChangeLog,v 1.3 2003/02/18 15:23:23 vapier Exp $
*ooodi-0.55 (29 Nov 2002)
+ 18 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ Ebuild fixed/cleaned up and fix #15919.
+
29 Nov 2002: Seth Chandler <sethbc@gentoo.org>: ooodi-0.55.ebuild
added ooodi-0.55 to portage. Ebuild submitted by David Holm
(dholm@telia.com).
diff --git a/app-office/ooodi/ooodi-0.55.ebuild b/app-office/ooodi/ooodi-0.55.ebuild
index 92015b4633a5..2d99909cbc2c 100644
--- a/app-office/ooodi/ooodi-0.55.ebuild
+++ b/app-office/ooodi/ooodi-0.55.ebuild
@@ -1,35 +1,28 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: David Holm <david@realityrift.com>
-# $Header: /var/cvsroot/gentoo-x86/app-office/ooodi/ooodi-0.55.ebuild,v 1.2 2003/02/13 09:18:44 vapier Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/ooodi/ooodi-0.55.ebuild,v 1.3 2003/02/18 15:23:23 vapier Exp $
-# This ebuild was generated by Ebuilder v0.4.
-
-DESCRIPTION="OOodi provides an automated dictionary installer for the OpenOffice.org word processer. It uses GTK+ for the user interface and libcurl for automated download of selected dictionaries."
-SRC_URI="http://switch.dl.sourceforge.net/sourceforge/ooodi/OOodi-0.55.tar.gz"
+MY_P="OOodi-${PV}"
+DESCRIPTION="automated dictionary installer for OpenOffice"
+SRC_URI="mirror://sourceforge/ooodi/${MY_P}.tar.gz"
HOMEPAGE="http://ooodi.sourceforge.net/"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-IUSE=""
+IUSE="nls"
+
DEPEND="net-ftp/curl
- x11-libs/gtk+"
+ =x11-libs/gtk+-1*"
-P="OOodi-0.55"
+S="${WORKDIR}/${MY_P}"
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf `use_enable nls` || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
- dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README
+ dodoc AUTHORS ChangeLog NEWS README
}
-
-