summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-09-24 06:46:13 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-09-24 06:46:13 +0000
commit033b9e6f9238277b12d8fda548ef765ca9107dad (patch)
treefc01d5b1bb9e6cd30495b75efd7453f289c6311b /app-office/oooqs
parentold (diff)
downloadgentoo-2-033b9e6f9238277b12d8fda548ef765ca9107dad.tar.gz
gentoo-2-033b9e6f9238277b12d8fda548ef765ca9107dad.tar.bz2
gentoo-2-033b9e6f9238277b12d8fda548ef765ca9107dad.zip
Fix icons to correctly display for both openoffice and openoffice-ximian,
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-office/oooqs')
-rw-r--r--app-office/oooqs/ChangeLog6
-rw-r--r--app-office/oooqs/files/fixxooo.patch71
2 files changed, 67 insertions, 10 deletions
diff --git a/app-office/oooqs/ChangeLog b/app-office/oooqs/ChangeLog
index a726d424537e..6029ab0c8da2 100644
--- a/app-office/oooqs/ChangeLog
+++ b/app-office/oooqs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/oooqs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/ChangeLog,v 1.16 2005/04/24 11:28:22 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/ChangeLog,v 1.17 2005/09/24 06:46:13 suka Exp $
+
+ 24 Sep 2005; Andreas Proschofsky <suka@gentoo.org> files/fixxooo.patch:
+ Fix icons to correctly display for both openoffice and openoffice-ximian,
+ closes bug #94857
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> oooqs-2.0.3.ebuild:
Stable on ppc.
diff --git a/app-office/oooqs/files/fixxooo.patch b/app-office/oooqs/files/fixxooo.patch
index c3afe7a9d528..a1c2d609b14e 100644
--- a/app-office/oooqs/files/fixxooo.patch
+++ b/app-office/oooqs/files/fixxooo.patch
@@ -1,5 +1,6 @@
---- src/oooqs.cpp 2004-08-25 13:57:33.801575240 +0200
-+++ src/oooqs.cpp 2004-08-25 13:57:33.802575088 +0200
+diff -ru oooqs-2.0.3/src/oooqs.cpp oooqs-2.0.3-fixed/src/oooqs.cpp
+--- oooqs-2.0.3/src/oooqs.cpp 2005-06-01 20:08:30.000000000 +0300
++++ oooqs-2.0.3-fixed/src/oooqs.cpp 2005-06-01 20:07:55.000000000 +0300
@@ -3,6 +3,7 @@
*/
@@ -8,7 +9,59 @@
#include <qmap.h>
#include <kaboutdata.h>
-@@ -92,9 +93,15 @@
+@@ -44,21 +45,36 @@
+ */
+ KPopupMenu* menu = contextMenu();
+
+- ( new KAction( i18n( "Textdocument" ),
+- "ooo_writer", 0, this,
+- SLOT( startWriter() ), this ) ) ->plug( menu );
+- ( new KAction( i18n( "Spreadsheet" ),
+- "ooo_calc", 0, this,
+- SLOT( startCalc() ), this ) ) ->plug( menu );
+- ( new KAction( i18n( "Presentation" ),
+- "ooo_impress", 0, this,
+- SLOT( startImpress() ), this ) ) ->plug( menu );
+- ( new KAction( i18n( "Drawing" ),
+- "ooo_draw", 0, this,
+- SLOT( startDraw() ), this ) ) ->plug( menu );
+- ( new KAction( i18n( "From Template" ),
+- "wizard", 0, this,
+- SLOT( startTemplate() ), this ) ) ->plug( menu );
++ if ( QFile::exists( QDir::homeDirPath() + QDir::separator() + ".xversionrc" ) ) {
++ ( new KAction( i18n( "Textdocument" ),
++ "ximian-openoffice-writer", 0, this,
++ SLOT( startWriter() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Spreadsheet" ),
++ "ximian-openoffice-calc", 0, this,
++ SLOT( startCalc() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Presentation" ),
++ "ximian-openoffice-impress", 0, this,
++ SLOT( startImpress() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Drawing" ),
++ "ximian-openoffice-draw", 0, this,
++ SLOT( startDraw() ), this ) ) ->plug( menu );
++ } else {
++ ( new KAction( i18n( "Textdocument" ),
++ "ooo_writer", 0, this,
++ SLOT( startWriter() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Spreadsheet" ),
++ "ooo_calc", 0, this,
++ SLOT( startCalc() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Presentation" ),
++ "ooo_impress", 0, this,
++ SLOT( startImpress() ), this ) ) ->plug( menu );
++ ( new KAction( i18n( "Drawing" ),
++ "ooo_draw", 0, this,
++ SLOT( startDraw() ), this ) ) ->plug( menu );
++ }
++ ( new KAction( i18n( "From Template" ),
++ "wizard", 0, this,
++ SLOT( startTemplate() ), this ) ) ->plug( menu );
+ menu->insertSeparator();
+ ( new KAction( i18n( "Open Document" ),
+ "fileopen", 0, this,
+@@ -92,9 +108,15 @@
Try to autodetect settings if they aren't found in our own config.
*/
if ( _exec.length() < 2 ) {
@@ -17,13 +70,13 @@
- + ".sversionrc", true );
+ if ( QFile::exists( QDir::homeDirPath() + QDir::separator() + ".xversionrc" ) ) {
+ oooConfig = new KSimpleConfig(
-+ QDir::homeDirPath() + QDir::separator()
-+ + ".xversionrc", true );
-+ } else {
++ QDir::homeDirPath() + QDir::separator()
++ + ".xversionrc", true );
++ } else {
+ oooConfig = new KSimpleConfig(
-+ QDir::homeDirPath() + QDir::separator()
-+ + ".sversionrc", true );
-+}
++ QDir::homeDirPath() + QDir::separator()
++ + ".sversionrc", true );
++ }
oooConfig->setGroup( "Versions" );
versions = oooConfig->entryMap( "Versions" );
/**