summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-10-08 21:25:28 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-10-08 21:25:28 +0000
commiteafeb667af6c870f1ea471ca5320215aa6e437c7 (patch)
tree4425028bb13709dc03ec4d754a500061989a45cc /app-office/openoffice-bin
parentStable ppc-macos, Bug 108332 (diff)
downloadgentoo-2-eafeb667af6c870f1ea471ca5320215aa6e437c7.tar.gz
gentoo-2-eafeb667af6c870f1ea471ca5320215aa6e437c7.tar.bz2
gentoo-2-eafeb667af6c870f1ea471ca5320215aa6e437c7.zip
clean up wrapper
(Portage version: 2.0.53_rc4)
Diffstat (limited to 'app-office/openoffice-bin')
-rw-r--r--app-office/openoffice-bin/ChangeLog6
-rwxr-xr-xapp-office/openoffice-bin/files/2.0.0/ooo-wrapper219
-rw-r--r--app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild4
3 files changed, 11 insertions, 18 deletions
diff --git a/app-office/openoffice-bin/ChangeLog b/app-office/openoffice-bin/ChangeLog
index 33c8056067cb..5d0019f10e72 100644
--- a/app-office/openoffice-bin/ChangeLog
+++ b/app-office/openoffice-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/openoffice-bin
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.99 2005/10/08 20:50:28 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/ChangeLog,v 1.100 2005/10/08 21:25:28 suka Exp $
+
+ 08 Oct 2005; Andreas Proschofsky <suka@gentoo.org>
+ files/2.0.0/ooo-wrapper2, openoffice-bin-2.0.0_rc2.ebuild:
+ clean up wrapper
08 Oct 2005; Simon Stelling <blubb@gentoo.org>
openoffice-bin-2.0.0_rc1.ebuild:
diff --git a/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2 b/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2
index 8222add9ae93..e67fd85a5843 100755
--- a/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2
+++ b/app-office/openoffice-bin/files/2.0.0/ooo-wrapper2
@@ -25,27 +25,16 @@ use IO::Handle;
use Fcntl ':flock';
my $Debug = $ENV{OOO_DEBUG};
-my $DebugRH = $ENV{OOO_RH_DEBUG};
-# Define the vendor of this particular OOo pacakge
+# Define the vendor of this particular OOo package
my $VendorName = 'Gentoo';
# Define system installation directory
# Autoconf totally sucks for @libdir@ type substitution
-my $SystemInstallDir = '/usr/lib/openoffice';
+my $SystemInstallDir = 'INSTDIR';
# Suffix for parallel installable versioning
my $BinSuffix = '2';
# ooo-build version
my $OOO_BUILDVERSION = 'PV';
-# Debugging
-
-if ( $DebugRH ) {
- $Debug = 1;
- $VendorName = "RedHat";
-}
-if ($Debug && $BinSuffix =~ /^\@/) {
- $SystemInstallDir = "/usr/lib/ooo-1.9";
- $BinSuffix = '1.9';
-}
#=============================================================================
# Main
@@ -64,7 +53,7 @@ while ($ARGV[0]) {
(defined $widgets_set) || die "Error: The option --widgets-set requires a value\n" .
"For example: --widgets-set gtk\n";
} elsif (m/^--version/) {
- print "This is OpenOffice.org built with ooo-build-$OOO_BUILDVERSION\n";
+ print "This is OpenOffice.org $OOO_BUILDVERSION\n";
exit 0;
} else {
push @ooo_argv, $_;
@@ -102,7 +91,7 @@ if ($session_quickstart) {
# FIXME: the following two fixes should be done by OOo itself
# create the user config directory with safe rights 700 if it we find
# the right path and the directory does not exist
-if (open BOOTSTRAPRC, "/usr/lib/openoffice/program/bootstraprc") {
+if (open BOOTSTRAPRC, "$SystemInstallDir/program/bootstraprc") {
while (my $line = <BOOTSTRAPRC>) {
chomp $line;
if (($line =~ m/^\s*UserInstallation\s*=\s*([^\s]*)\s*$/) && ($1)) {
diff --git a/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild b/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild
index 9a4ace9e54ca..053bb0b0961c 100644
--- a/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild,v 1.3 2005/10/08 20:33:39 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild,v 1.4 2005/10/08 21:25:28 suka Exp $
inherit eutils fdo-mime rpm multilib
@@ -147,7 +147,7 @@ src_install () {
# Install wrapper script
newbin ${FILESDIR}/${MY_PV3}/ooo-wrapper2 ooffice2
sed -i -e s/PV/${PV}/g ${D}/usr/bin/ooffice2 || die
- sed -i -e "s:lib/:$(get_libdir)/:" ${D}/usr/bin/ooffice2 || die
+ sed -i -e "s|INSTDIR|${INSTDIR}|g" ${D}/usr/bin/ooffice2 || die
# Component symlinks
for app in base calc draw fromtemplate impress math web writer; do