summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2004-08-29 06:21:37 +0000
committerAndreas Proschofsky <suka@gentoo.org>2004-08-29 06:21:37 +0000
commit33e48c63765aeea4b23cd57699e91f4b83021d5f (patch)
treee190fadec8aaaf54b9c06bba128c0061738a0ab7 /app-office/openoffice-ximian
parentremove 99.2 (Manifest recommit) (diff)
downloadgentoo-2-33e48c63765aeea4b23cd57699e91f4b83021d5f.tar.gz
gentoo-2-33e48c63765aeea4b23cd57699e91f4b83021d5f.tar.bz2
gentoo-2-33e48c63765aeea4b23cd57699e91f4b83021d5f.zip
removing parallel build stuff again :(
Diffstat (limited to 'app-office/openoffice-ximian')
-rw-r--r--app-office/openoffice-ximian/ChangeLog5
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.3.2.ebuild23
2 files changed, 14 insertions, 14 deletions
diff --git a/app-office/openoffice-ximian/ChangeLog b/app-office/openoffice-ximian/ChangeLog
index c0bb2be81d1c..6e0be560de8d 100644
--- a/app-office/openoffice-ximian/ChangeLog
+++ b/app-office/openoffice-ximian/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-office/openoffice-ximian
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.66 2004/08/28 15:34:20 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.67 2004/08/29 06:21:37 suka Exp $
+
+ 29 Aug 2004; suka@gentoo.org openoffice-ximian-1.3.2.ebuild:
+ backing out parallel build stuff, seems to break the build for some :(
28 Aug 2004; suka@gentoo.org openoffice-ximian-1.3.2.ebuild:
At last enable parallel build! Should work fine now, although number of
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.3.2.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.3.2.ebuild
index 16aa6865d7df..bab2576ea92c 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.3.2.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.2.ebuild,v 1.2 2004/08/28 15:34:21 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.2.ebuild,v 1.3 2004/08/29 06:21:37 suka Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -345,21 +345,18 @@ src_compile() {
# Build as minimal as possible
export BUILD_MINIMAL="${LANGNO}"
- #Get info for parallel build
- export JOBS=`echo "${MAKEOPTS}" | sed -e "s/.*-j\([0-9]\+\).*/\1/"`
-
- if [ "${JOBS}" -gt 10 ]
- then
- export JOBS="10"
- einfo "dmake fails with too much parallel jobs, so limiting to 10"
- fi
-
- export buildcmd="${S}/solenv/bin/build.pl --all product=full strip=true --dlv_switch link"
+ # Set $ECPUS to amount of processes multiprocessing build should use.
+ # NOTE: Setting this too high might cause dmake to segfault!!
+ # Setting this to anything but "1" on my pentium4 causes things
+ # to segfault :(
+ [ -z "${ECPUS}" ] && export ECPUS="1"
# Should the build use multiprocessing?
- if [ "${JOBS}" -gt 1 ]
+ if [ "${ECPUS}" -gt 1 ]
then
- export buildcmd="${buildcmd} -P${JOBS}"
+ buildcmd="${S}/solenv/bin/build.pl --all -P${ECPUS} product=full strip=true --dlv_switch link"
+ else
+ buildcmd="${S}/solenv/bin/build.pl --all product=full strip=true --dlv_switch link"
fi
if [ -z "$(grep 'CCCOMP' ${S}/${LinuxEnvSet})" ]