summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 08:36:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 08:36:58 +0000
commit455335b93fa3d6b25f2031b7099798c1cd1585cf (patch)
tree23f34f7a6026338cde51897768565c036c1cda64 /app-office/osmo/osmo-0.2.10.ebuild
parentAdded orc USE flag to gst-plugins-ffmpeg, so mask on all but supported archit... (diff)
downloadgentoo-2-455335b93fa3d6b25f2031b7099798c1cd1585cf.tar.gz
gentoo-2-455335b93fa3d6b25f2031b7099798c1cd1585cf.tar.bz2
gentoo-2-455335b93fa3d6b25f2031b7099798c1cd1585cf.zip
Import Fedora patch to fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'app-office/osmo/osmo-0.2.10.ebuild')
-rw-r--r--app-office/osmo/osmo-0.2.10.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/app-office/osmo/osmo-0.2.10.ebuild b/app-office/osmo/osmo-0.2.10.ebuild
index 71819fd4f1e6..de852491e643 100644
--- a/app-office/osmo/osmo-0.2.10.ebuild
+++ b/app-office/osmo/osmo-0.2.10.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/osmo/osmo-0.2.10.ebuild,v 1.4 2010/11/02 15:46:13 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/osmo/osmo-0.2.10.ebuild,v 1.5 2011/01/30 08:36:58 ssuominen Exp $
-EAPI=2
-inherit flag-o-matic
+EAPI=3
+inherit eutils flag-o-matic
DESCRIPTION="A handy personal organizer"
HOMEPAGE="http://clayo.org/osmo/"
@@ -25,6 +25,11 @@ RDEPEND=">=x11-libs/gtk+-2.12:2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ has_version ">=x11-libs/libnotify-0.7" && epatch \
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
+
src_configure() {
append-flags -I/usr/include/libical
@@ -35,5 +40,5 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog README TRANSLATORS || die
+ dodoc AUTHORS ChangeLog README TRANSLATORS
}