summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-10-26 11:23:41 +0000
committerPacho Ramos <pacho@gentoo.org>2014-10-26 11:23:41 +0000
commit6c9785cf9d1c85a39b91f88585f1c8e2fc7e9e33 (patch)
treed81ed03736d5208d8055a1148642eb911b4277d0 /app-office/pinpoint
parentEAPI bump. Fix building against sys-libs/ncurses[tinfo] (bug #526798). (diff)
downloadgentoo-2-6c9785cf9d1c85a39b91f88585f1c8e2fc7e9e33.tar.gz
gentoo-2-6c9785cf9d1c85a39b91f88585f1c8e2fc7e9e33.tar.bz2
gentoo-2-6c9785cf9d1c85a39b91f88585f1c8e2fc7e9e33.zip
Bump to newer snapshot including many fixes and also being ported to newer clutter-gst slot
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-office/pinpoint')
-rw-r--r--app-office/pinpoint/ChangeLog9
-rw-r--r--app-office/pinpoint/pinpoint-0.1.5_pre20141026.ebuild58
2 files changed, 66 insertions, 1 deletions
diff --git a/app-office/pinpoint/ChangeLog b/app-office/pinpoint/ChangeLog
index 39bb4f175925..01c0877909e9 100644
--- a/app-office/pinpoint/ChangeLog
+++ b/app-office/pinpoint/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/pinpoint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/pinpoint/ChangeLog,v 1.9 2014/03/09 11:54:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/pinpoint/ChangeLog,v 1.10 2014/10/26 11:23:41 pacho Exp $
+
+*pinpoint-0.1.5_pre20141026 (26 Oct 2014)
+
+ 26 Oct 2014; Pacho Ramos <pacho@gentoo.org>
+ +pinpoint-0.1.5_pre20141026.ebuild:
+ Bump to newer snapshot including many fixes and also being ported to newer
+ clutter-gst slot
09 Mar 2014; Pacho Ramos <pacho@gentoo.org> pinpoint-0.1.4-r1.ebuild:
x86 stable, bug 499954
diff --git a/app-office/pinpoint/pinpoint-0.1.5_pre20141026.ebuild b/app-office/pinpoint/pinpoint-0.1.5_pre20141026.ebuild
new file mode 100644
index 000000000000..1045137f9cc5
--- /dev/null
+++ b/app-office/pinpoint/pinpoint-0.1.5_pre20141026.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/pinpoint/pinpoint-0.1.5_pre20141026.ebuild,v 1.1 2014/10/26 11:23:41 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools gnome2
+
+DESCRIPTION="A tool for making hackers do excellent presentations"
+HOMEPAGE="https://wiki.gnome.org/Apps/Pinpoint"
+
+MY_PV="215ccad331a39c6e95d173938fcfffe6eb4d75d6" #snapshot
+SRC_URI="https://git.gnome.org/browse/${PN}/snapshot/${PN}-${MY_PV}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gstreamer +pdf"
+
+# rsvg is used for svg-in-pdf -- clubbing it under pdf for now
+RDEPEND="
+ >=media-libs/clutter-1.12:1.0
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/cairo-1.9.4
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ gstreamer? ( media-libs/clutter-gst:2.0 )
+ pdf? ( gnome-base/librsvg:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # dax support is disabled because we don't have it in tree yet and it's
+ # experimental
+ gnome2_src_configure \
+ --disable-dax \
+ $(use_enable gstreamer cluttergst) \
+ $(use_enable pdf rsvg)
+}
+
+src_install() {
+ gnome2_src_install
+
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto "/usr/share/doc/${PF}/examples"
+ doins introduction.pin bg.jpg bowls.jpg linus.jpg
+}