summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-11-12 20:29:58 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-11-12 20:29:58 +0000
commit33e1a71d156e579cebaea90a409d602305032c1c (patch)
tree537b53cce855463a19660b904ecbac518f454891 /app-office/plan/plan-1.9-r1.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-33e1a71d156e579cebaea90a409d602305032c1c.tar.gz
gentoo-2-33e1a71d156e579cebaea90a409d602305032c1c.tar.bz2
gentoo-2-33e1a71d156e579cebaea90a409d602305032c1c.zip
Fix pre-stripped files issue ( bug 251868 ) and respect LDFLAGS
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'app-office/plan/plan-1.9-r1.ebuild')
-rw-r--r--app-office/plan/plan-1.9-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-office/plan/plan-1.9-r1.ebuild b/app-office/plan/plan-1.9-r1.ebuild
new file mode 100644
index 000000000000..90174c48098d
--- /dev/null
+++ b/app-office/plan/plan-1.9-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/plan/plan-1.9-r1.ebuild,v 1.1 2009/11/12 20:29:57 hwoarang Exp $
+
+inherit eutils
+
+DESCRIPTION="Motif based schedule planner"
+HOMEPAGE="http://www.bitrot.de/plan.html"
+SRC_URI="ftp://ftp.fu-berlin.de/unix/X11/apps/plan/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/openmotif"
+
+S=${WORKDIR}/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ epatch "${WORKDIR}"/${P}-errno.patch
+ epatch "${WORKDIR}"/${P}-gentoo.patch
+ epatch "${WORKDIR}"/${P}-webplan.patch
+ epatch "${FILESDIR}"/makefile.patch
+ epatch "${FILESDIR}"/nostrip.patch
+ epatch "${FILESDIR}"/ldflags.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) SHARE=/usr/share/plan linux || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ SHARE=/usr/share/plan \
+ install || die "install failed"
+ keepdir /usr/share/plan/netplan.dir
+
+ cd "${S}"/..
+ dodoc HISTORY README || die "dodoc failed"
+
+ cd "${S}"/../misc
+ doman netplan.1 plan.1 plan.4 || die "doman failed"
+
+ insinto /usr/share/${PN}/misc
+ doins netplan.boot BlackWhite Monochrome plan.fti Plan.xpm plan.xpm \
+ || die "misc files install failed"
+ exeinto /usr/share/${PN}/misc
+ doexe Killpland cvs vsc msschedule2plan plan2vcs || die "misc files install failed"
+
+ cd "${S}"/../web
+ insinto /usr/share/${PN}/web
+ doins help.html bottom.html cgi-lib.pl common.pl holiday_webplan rtsban.jpg \
+ || die "webplan install failed"
+ exeinto /usr/share/${PN}/web
+ doexe *.cgi || die "webplan install failed"
+}
+
+pkg_postinst() {
+ elog
+ elog " Check /usr/share/${PN}/holiday for examples to set your"
+ elog " ~/.holiday according to your country."
+ elog
+ elog " WebPlan ${PV} can be found in /usr/share/${PN}/web."
+ elog
+}