summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2004-11-09 08:39:08 +0000
committerMike Gardiner <obz@gentoo.org>2004-11-09 08:39:08 +0000
commit6d404a26ad687a0d073fe2c3692b710482371c54 (patch)
tree8af9d2c4d496ff34afbf3a757ca651b1fbe5ee9b /app-office/planner/planner-0.12.1.ebuild
parentstable on ppc gsla: 69868 (Manifest recommit) (diff)
downloadgentoo-2-6d404a26ad687a0d073fe2c3692b710482371c54.tar.gz
gentoo-2-6d404a26ad687a0d073fe2c3692b710482371c54.tar.bz2
gentoo-2-6d404a26ad687a0d073fe2c3692b710482371c54.zip
New version, a bugfix release, as requested in bug #62265
Diffstat (limited to 'app-office/planner/planner-0.12.1.ebuild')
-rw-r--r--app-office/planner/planner-0.12.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-office/planner/planner-0.12.1.ebuild b/app-office/planner/planner-0.12.1.ebuild
new file mode 100644
index 000000000000..3c245d682d53
--- /dev/null
+++ b/app-office/planner/planner-0.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/planner-0.12.1.ebuild,v 1.1 2004/11/09 08:39:08 obz Exp $
+
+inherit gnome2
+
+DESCRIPTION="Project manager for Gnome2"
+HOMEPAGE="http://planner.imendio.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="doc libgda python"
+
+RDEPEND=">=x11-libs/gtk+-2.0.5
+ >=x11-libs/pango-1.0.3
+ >=dev-libs/glib-2.0.4
+ >=gnome-base/libgnomecanvas-2.0.1
+ >=gnome-base/libglade-2.0.0
+ >=gnome-base/libgnomeui-2.0.1
+ >=gnome-base/gnome-vfs-2.0.2
+ >=gnome-base/libgnomeprintui-2.1.9
+ >=gnome-base/libbonoboui-2.0.0
+ >=dev-libs/libxml2-2.5.4
+ >=gnome-extra/libgsf-1.4
+ app-text/scrollkeeper
+ libgda? ( >=gnome-extra/libgda-1.0 )
+ python? ( >=dev-python/pygtk-2.0.0-r1 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ dev-util/intltool
+ doc?( >=dev-util/gtk-doc-0.10 )"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL README"
+
+# darn thing breaks in paralell make :/
+MAKEOPTS="${MAKEOPTS} -j1"
+G2CONF="${G2CONF} $(use_enable libgda database) $(use_enable python) --disable-dotnet"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+ einfo "You will have to unmerge mrproject and libmrproject after this"
+ einfo "those projects will soon dissapear, as soon as we can mark planner as stable"
+ echo ""
+ einfo "emerge unmerge mrproject libmrproject"
+}