summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-22 08:40:02 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-22 08:40:02 +0000
commit8ef6e0f8feb7878cc995c299cccd48ec25683b5b (patch)
tree83db62110e3620af09f7b98dc4b251d62011f94c /app-office/scribus
parentuse CXXFLAGS for building c++ components (bug #453240). Thanks ago (diff)
downloadgentoo-2-8ef6e0f8feb7878cc995c299cccd48ec25683b5b.tar.gz
gentoo-2-8ef6e0f8feb7878cc995c299cccd48ec25683b5b.tar.bz2
gentoo-2-8ef6e0f8feb7878cc995c299cccd48ec25683b5b.zip
app-office/scribus: Rename USE spell to aspell to better fit its meaning; handle cups support not automagically; add missing deps
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-office/scribus')
-rw-r--r--app-office/scribus/ChangeLog7
-rw-r--r--app-office/scribus/files/scribus-1.4.2-cups.patch29
-rw-r--r--app-office/scribus/metadata.xml1
-rw-r--r--app-office/scribus/scribus-1.4.2-r1.ebuild16
4 files changed, 47 insertions, 6 deletions
diff --git a/app-office/scribus/ChangeLog b/app-office/scribus/ChangeLog
index 13e9d68bf2aa..b4038b3e8835 100644
--- a/app-office/scribus/ChangeLog
+++ b/app-office/scribus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/scribus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.170 2013/01/22 07:54:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/ChangeLog,v 1.171 2013/01/22 08:40:02 jlec Exp $
+
+ 22 Jan 2013; Justin Lecher <jlec@gentoo.org> scribus-1.4.2-r1.ebuild,
+ +files/scribus-1.4.2-cups.patch, metadata.xml:
+ Rename USE spell to aspell to better fit its meaning; handle cups support not
+ automagically; add missing deps
*scribus-1.4.2-r1 (22 Jan 2013)
diff --git a/app-office/scribus/files/scribus-1.4.2-cups.patch b/app-office/scribus/files/scribus-1.4.2-cups.patch
new file mode 100644
index 000000000000..87f0d7a04abd
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.4.2-cups.patch
@@ -0,0 +1,29 @@
+ CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 141301f..78578de 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -612,7 +612,7 @@ ENDIF (OLDRENDERLIBLOST OR WANT_QTARTHUR OR RENDER_LIB STREQUAL "QTARTHUR" OR NO
+ #>>Render Library
+
+ #<<CUPS
+-IF(NOT WIN32)
++IF(NOT WIN32 AND WANT_CUPS)
+ IF (${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} LESS 2.5)
+ SET(Cups_DIR ${CMAKE_MODULE_PATH})
+ ENDIF (${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} LESS 2.5)
+@@ -621,10 +621,10 @@ IF(NOT WIN32)
+ SET(HAVE_CUPS 1)
+ MESSAGE("CUPS Library Found OK")
+ ENDIF(CUPS_FOUND)
+-ELSE(NOT WIN32)
++ELSE(NOT WIN32 AND WANT_CUPS)
+ # Windows doesn't use CUPS
+ SET(CUPS_INCLUDE_DIR)
+-ENDIF(NOT WIN32)
++ENDIF(NOT WIN32 AND WANT_CUPS)
+ #>>CUPS
+
+ #<<LibXML2
diff --git a/app-office/scribus/metadata.xml b/app-office/scribus/metadata.xml
index 543beb3061d4..83a43683a8e9 100644
--- a/app-office/scribus/metadata.xml
+++ b/app-office/scribus/metadata.xml
@@ -13,6 +13,7 @@
<use>
<flag name="minimal">Don't install headers (only required for e.g. plug-in developers)</flag>
<flag name="templates">Document tamplates</flag>
+ <flag name="aspell">Enable support for spell checking with <pkg>app-text/aspell</pkg></flag>
<flag name="hunspell">Enable support for spell checking with <pkg>app-text/hunspell</pkg></flag>
<flag name="linguas_cs_CZ">Language support for cs_CZ</flag>
<flag name="linguas_da_DK">Language support for da_DK</flag>
diff --git a/app-office/scribus/scribus-1.4.2-r1.ebuild b/app-office/scribus/scribus-1.4.2-r1.ebuild
index ac2907272d37..7f2b091071f0 100644
--- a/app-office/scribus/scribus-1.4.2-r1.ebuild
+++ b/app-office/scribus/scribus-1.4.2-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.4.2-r1.ebuild,v 1.1 2013/01/22 07:54:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/scribus/scribus-1.4.2-r1.ebuild,v 1.2 2013/01/22 08:40:02 jlec Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE=tk
inherit cmake-utils fdo-mime multilib python-single-r1
@@ -15,13 +16,14 @@ SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="cairo debug examples hunspell +minimal +pdf spell templates"
+IUSE="aspell cairo +cups debug examples hunspell +minimal +pdf templates"
# a=$(ls resources/translations/po/scribus.*ts | sed -e 's:\.: :g' | awk '{print $2}'); echo ${a}
IUSE_LINGUAS=" af ar bg br ca cs_CZ cy da_DK de de_1901 de_CH el en_AU en_GB en_US es_ES et eu fi fr gl hu id it ja ko lt_LT nb_NO nl pl_PL pt pt_BR ru sa sk_SK sl sq sr sv th_TH tr uk zh_CN zh_TW"
IUSE+=" ${IUSE_LINGUAS// / linguas_}"
COMMON_DEPEND="
+ dev-python/imaging[tk,${PYTHON_USEDEP}]
dev-libs/boost
dev-libs/hyphen
dev-libs/libxml2
@@ -36,15 +38,18 @@ COMMON_DEPEND="
x11-libs/qt-gui:4
virtual/jpeg
cairo? ( x11-libs/cairo[X,svg] )
+ cups? ( net-print/cups )
pdf? ( app-text/podofo )
- spell? ( app-text/aspell )
+ aspell? ( app-text/aspell )
hunspell? ( app-text/hunspell )"
RDEPEND="${COMMON_DEPEND}
app-text/ghostscript-gpl"
-DEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-docs.patch
+ "${FILESDIR}"/${P}-cups.patch
"${FILESDIR}"/${PN}-1.4.0-minizip.patch
)
@@ -85,9 +90,10 @@ src_configure() {
-DWANT_QT3SUPPORT=OFF
-DGENTOOVERSION=${PVR}
-DWANT_GUI_LANG=${langs#,}
- $(cmake-utils_use_has spell ASPELL)
+ $(cmake-utils_use_has aspell ASPELL)
$(cmake-utils_use_has pdf PODOFO)
$(cmake-utils_use_want cairo)
+ $(cmake-utils_use_want cups CUPS)
$(cmake-utils_use_want debug DEBUG)
$(cmake-utils_use_want minimal NOHEADERINSTALL)
$(cmake-utils_use_want hunspell HUNSPELL)