summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-17 22:18:09 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-17 22:18:09 +0000
commitb7d8bd9c6e0397ec53c563836355fc8012a9394e (patch)
tree047f5efe15542faf633c0455380dd9f1251186ed /app-office/siag
parentnew version, removed old one (diff)
downloadgentoo-2-b7d8bd9c6e0397ec53c563836355fc8012a9394e.tar.gz
gentoo-2-b7d8bd9c6e0397ec53c563836355fc8012a9394e.tar.bz2
gentoo-2-b7d8bd9c6e0397ec53c563836355fc8012a9394e.zip
1 missing digest, and a update for siag... which closes bug #3808 party on.
Diffstat (limited to 'app-office/siag')
-rw-r--r--app-office/siag/ChangeLog8
-rw-r--r--app-office/siag/files/digest-siag-3.5.2-r21
-rw-r--r--app-office/siag/siag-3.5.2-r2.ebuild75
3 files changed, 83 insertions, 1 deletions
diff --git a/app-office/siag/ChangeLog b/app-office/siag/ChangeLog
index f73defaae22e..0aecfbff0b10 100644
--- a/app-office/siag/ChangeLog
+++ b/app-office/siag/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for app-office/siag
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/siag/ChangeLog,v 1.3 2002/06/06 13:57:01 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/siag/ChangeLog,v 1.4 2002/06/17 22:18:09 lostlogic Exp $
*siag-3.5.2 (5 Jun 2002)
+ 17 Jun 2002; Brandon Low <lostlogic@gentoo.org> siag-3.5.2-r2.ebuild
+
+ Fix sandbox violation if KDEDIR is not defined, if installing siag and KDE
+ please ensure that you have USE="kde" and that you insatll siag AFTER installing
+ KDE to ensure that siag can properly link itself to KDE.
+
6 Jun 2002; Brandon Low <lostlogic@gentoo.org> siag-3.5.2-r1.ebuild
Fix stupid but important typo /usr != /use
diff --git a/app-office/siag/files/digest-siag-3.5.2-r2 b/app-office/siag/files/digest-siag-3.5.2-r2
new file mode 100644
index 000000000000..a5c41821208e
--- /dev/null
+++ b/app-office/siag/files/digest-siag-3.5.2-r2
@@ -0,0 +1 @@
+MD5 80169faebe7bca9fd531b53b6c5d3ed5 siag-3.5.2.tar.gz 1514672
diff --git a/app-office/siag/siag-3.5.2-r2.ebuild b/app-office/siag/siag-3.5.2-r2.ebuild
new file mode 100644
index 000000000000..f448f2c63b67
--- /dev/null
+++ b/app-office/siag/siag-3.5.2-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/siag/siag-3.5.2-r2.ebuild,v 1.1 2002/06/17 22:18:09 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A free Office package for Linux"
+SRC_URI="ftp://siag.nu/pub/siag/${P}.tar.gz"
+HOMEPAGE="http://siag.nu/"
+
+DEPEND="virtual/x11
+ >=dev-libs/gmp-3.1.1
+ >=media-libs/xpm-3.4
+ >=x11-misc/mowitz-0.2.1
+ >=dev-lang/tcl-8.0.0"
+# >=media-libs/t1lib-1.0.1"
+
+RDEPEND="virtual/x11"
+# >=media-libs/t1lib-1.0.1"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ if [ -z "`use kde`" ] || [ -z ${KDEDIR} ]; then
+ einfo "Not using KDE"
+ for file in `find . -iname "Makefile.*"`; do
+ grep -v "kdeinst" ${file} >${file}.hacked && \
+ mv ${file}.hacked ${file} || die "Hacking of ${file} failed"
+ done
+ else
+ einfo "Using KDE"
+ sed -e "s:VERBOSE=no:VERBOSE=no\nKDEDIR=${D}${KDEDIR}:" common/kdeinst \
+ > common/kdeinst.hacked && \
+ mv common/kdeinst.hacked common/kdeinst || die "Hacking of kdeinst failed"
+ fi
+
+}
+
+src_compile() {
+
+ local myconf
+#Causes segfaults in 3.5.2 on my system...
+# if [ "`use guile`" ]
+# then
+# myconf="$myconf --with-guile"
+# else
+# myconf="$myconf --without-guile"
+# fi
+ ./configure --prefix=/usr \
+ --with-x \
+ --with-xawm="Xaw" \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --with-tcl \
+ --with-gmp \
+ $myconf || die "Configure failed"
+# --with-t1lib \
+
+ make || die "Make failed"
+
+}
+
+src_install () {
+
+ if [ -n "`use kde`" ] && [ ! -z ${KDEDIR} ]; then
+ echo "Still using KDE"
+ dodir ${KDEDIR}
+ fi
+
+ make DESTDIR=${D} install || die "Install failed"
+
+}
+