summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-01-22 09:13:05 +0000
committerHanno Böck <hanno@gentoo.org>2009-01-22 09:13:05 +0000
commit5caefac5911fc40f883f114ec2091e15f35a497a (patch)
tree6f74b0013e9ec70313f6029fc5125d8644716313 /app-office/taxbird
parentlibgeier bump (diff)
downloadgentoo-2-5caefac5911fc40f883f114ec2091e15f35a497a.tar.gz
gentoo-2-5caefac5911fc40f883f114ec2091e15f35a497a.tar.bz2
gentoo-2-5caefac5911fc40f883f114ec2091e15f35a497a.zip
taxbird bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taxbird')
-rw-r--r--app-office/taxbird/ChangeLog10
-rw-r--r--app-office/taxbird/taxbird-0.10.ebuild6
-rw-r--r--app-office/taxbird/taxbird-0.12.ebuild43
3 files changed, 54 insertions, 5 deletions
diff --git a/app-office/taxbird/ChangeLog b/app-office/taxbird/ChangeLog
index b979b63d6b4c..6c01a2a05215 100644
--- a/app-office/taxbird/ChangeLog
+++ b/app-office/taxbird/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/taxbird
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.15 2008/11/14 16:01:15 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.16 2009/01/22 09:13:05 hanno Exp $
+
+*taxbird-0.12 (22 Jan 2009)
+
+ 22 Jan 2009; Hanno Boeck <hanno@gentoo.org> taxbird-0.10.ebuild,
+ +taxbird-0.12.ebuild:
+ Version bump.
14 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+files/taxbird-0.11-asneeded.patch, taxbird-0.10.ebuild,
diff --git a/app-office/taxbird/taxbird-0.10.ebuild b/app-office/taxbird/taxbird-0.10.ebuild
index a0dabda52ccc..e3709b62d780 100644
--- a/app-office/taxbird/taxbird-0.10.ebuild
+++ b/app-office/taxbird/taxbird-0.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/taxbird-0.10.ebuild,v 1.5 2008/11/14 16:01:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/taxbird-0.10.ebuild,v 1.6 2009/01/22 09:13:05 hanno Exp $
inherit eutils fdo-mime flag-o-matic
@@ -41,7 +41,7 @@ src_install() {
# clean out the installed mime files, those get recreated in the pkg_postinst function
einfo "Deleting mime files in ${D}/usr/share/mime"
- rm -f ${D}/usr/share/mime/{aliases,globs,magic,mime.cache,subclasses,XMLnamespaces}
+ rm -f "${D}/usr/share/mime/{aliases,globs,magic,mime.cache,subclasses,XMLnamespaces}"
}
pkg_postinst() {
diff --git a/app-office/taxbird/taxbird-0.12.ebuild b/app-office/taxbird/taxbird-0.12.ebuild
new file mode 100644
index 000000000000..950862323b4b
--- /dev/null
+++ b/app-office/taxbird/taxbird-0.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/taxbird-0.12.ebuild,v 1.1 2009/01/22 09:13:05 hanno Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="Taxbird provides a GUI to submit tax forms to the german digital tax project ELSTER."
+HOMEPAGE="http://www.taxbird.de/"
+SRC_URI="http://www.taxbird.de/download/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/libgeier
+ dev-libs/openssl
+ =gnome-extra/gtkhtml-2*
+ gnome-base/libgnomeui
+ sys-devel/gettext
+ dev-scheme/guile"
+
+pkg_setup() {
+ if has_version ">=dev-scheme/guile-1.8.0" && ! built_with_use dev-scheme/guile discouraged deprecated regex; then
+ eerror "This package requires dev-scheme/guile with USE=\"discouraged deprecated regex\"."
+ die "Please reemerge dev-scheme/guile with USE=\"discouraged deprecated regex\"."
+ fi
+}
+
+src_install() {
+ dodoc README* || die "dodoc failed"
+
+ einstall || die "Installation failed!"
+
+ # clean out the installed mime files, those get recreated in the pkg_postinst function
+ einfo "Deleting mime files in ${D}/usr/share/mime"
+ rm -f "${D}/usr/share/mime/{aliases,globs,magic,mime.cache,subclasses,XMLnamespaces}"
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}