summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-01-31 22:33:44 +0000
committerHanno Böck <hanno@gentoo.org>2011-01-31 22:33:44 +0000
commita3b84a6fdbc1dc3f83cc8d5633f8005f51b4eab7 (patch)
tree57df56ad55768c490315de7b4be5022da63337d9 /app-office/taxbird
parentremove old taxbird versions (diff)
downloadgentoo-2-a3b84a6fdbc1dc3f83cc8d5633f8005f51b4eab7.tar.gz
gentoo-2-a3b84a6fdbc1dc3f83cc8d5633f8005f51b4eab7.tar.bz2
gentoo-2-a3b84a6fdbc1dc3f83cc8d5633f8005f51b4eab7.zip
taxbird version bump
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taxbird')
-rw-r--r--app-office/taxbird/ChangeLog9
-rw-r--r--app-office/taxbird/taxbird-0.16.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/app-office/taxbird/ChangeLog b/app-office/taxbird/ChangeLog
index 345f4985eccb..0a41d191bf8f 100644
--- a/app-office/taxbird/ChangeLog
+++ b/app-office/taxbird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taxbird
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.25 2010/07/10 15:18:12 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/ChangeLog,v 1.26 2011/01/31 22:33:44 hanno Exp $
+
+*taxbird-0.16 (31 Jan 2011)
+
+ 31 Jan 2011; Hanno Boeck <hanno@gentoo.org> +taxbird-0.16.ebuild:
+ Version bump.
10 Jul 2010; Christian Faulhammer <fauli@gentoo.org> taxbird-0.15.ebuild:
stable x86, bug 319827
diff --git a/app-office/taxbird/taxbird-0.16.ebuild b/app-office/taxbird/taxbird-0.16.ebuild
new file mode 100644
index 000000000000..272904314b4b
--- /dev/null
+++ b/app-office/taxbird/taxbird-0.16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taxbird/taxbird-0.16.ebuild,v 1.1 2011/01/31 22:33:44 hanno Exp $
+
+EAPI="2"
+
+inherit eutils fdo-mime
+
+DESCRIPTION="Taxbird provides a GUI to submit tax forms to the german digital tax project ELSTER."
+HOMEPAGE="http://www.taxbird.de/"
+SRC_URI="http://www.taxbird.de/download/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libgeier-0.12
+ >=gnome-extra/gtkhtml-3.8
+ gnome-base/libgnomeui
+ sys-devel/gettext
+ >=dev-scheme/guile-1.8.0[regex,deprecated]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dodoc README* || die "dodoc failed"
+
+ einstall || die "Installation failed!"
+
+ # clean out the installed mime files, those get recreated in the pkg_postinst function
+ einfo "Deleting mime files in ${D}/usr/share/mime"
+ find "${D}/usr/share/mime/" -maxdepth 1 -type f -delete
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}