summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-31 13:49:47 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-31 13:49:47 +0000
commited4373f8e00bf348ee9304d67ec3be11e29d1a27 (patch)
treec3794bc00afd50b85b8ec201476a8480c1b1aab5 /app-office/teapot
parentVersion bump, drop old. (diff)
downloadgentoo-2-ed4373f8e00bf348ee9304d67ec3be11e29d1a27.tar.gz
gentoo-2-ed4373f8e00bf348ee9304d67ec3be11e29d1a27.tar.bz2
gentoo-2-ed4373f8e00bf348ee9304d67ec3be11e29d1a27.zip
Version bump (bug 451738)
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-office/teapot')
-rw-r--r--app-office/teapot/ChangeLog11
-rw-r--r--app-office/teapot/files/teapot-2.3.0-doc-dir.patch26
-rw-r--r--app-office/teapot/files/teapot-2.3.0-helpfile.patch33
-rw-r--r--app-office/teapot/teapot-2.3.0.ebuild49
4 files changed, 116 insertions, 3 deletions
diff --git a/app-office/teapot/ChangeLog b/app-office/teapot/ChangeLog
index b080d237c7ca..2e898893f504 100644
--- a/app-office/teapot/ChangeLog
+++ b/app-office/teapot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/teapot
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/teapot/ChangeLog,v 1.4 2011/12/15 22:45:18 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/teapot/ChangeLog,v 1.5 2013/05/31 13:49:47 xmw Exp $
+
+*teapot-2.3.0 (31 May 2013)
+
+ 31 May 2013; Michael Weber <xmw@gentoo.org> +files/teapot-2.3.0-doc-dir.patch,
+ +files/teapot-2.3.0-helpfile.patch, +teapot-2.3.0.ebuild:
+ Version bump (bug 451738)
15 Dec 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #353461
@@ -16,4 +22,3 @@
03 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> +teapot-2.2.0.ebuild,
+files/teapot-2.2.0-doc-dir.patch, +files/teapot-2.2.0-helpfile.patch:
Initial commit wrt #353579 by Kevin McCarthy.
-
diff --git a/app-office/teapot/files/teapot-2.3.0-doc-dir.patch b/app-office/teapot/files/teapot-2.3.0-doc-dir.patch
new file mode 100644
index 000000000000..466d97237285
--- /dev/null
+++ b/app-office/teapot/files/teapot-2.3.0-doc-dir.patch
@@ -0,0 +1,26 @@
+Fix to put docs in correct location based on ${PF}
+This requires -DPF=${PF} passed to cmake
+
+Also prevent the installation of COPYING
+
+Patch by Kevin McCarthy <signals42@gmail.com>
+
+--- teapot-2.3.0/CMakeLists.txt
++++ teapot-2.3.0/CMakeLists.txt
+@@ -99,12 +99,12 @@
+ add_custom_target(pdf DEPENDS teapot.pdf)
+ add_custom_target(html DEPENDS html/index.html)
+ add_custom_target(doc ALL DEPENDS teapot.pdf html/index.html)
+- install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION share/doc/teapot FILES_MATCHING PATTERN *.html PATTERN *.png)
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/teapot.pdf DESTINATION share/doc/teapot)
+- set(HELPFILE "${CMAKE_INSTALL_PREFIX}/share/doc/teapot/index.html")
++ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION share/doc/${PF} FILES_MATCHING PATTERN *.html PATTERN *.png)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/teapot.pdf DESTINATION share/doc/${PF})
++ set(HELPFILE "${CMAKE_INSTALL_PREFIX}/share/doc/${PF}/html/index.html")
+ endif ()
+
+-install(FILES COPYING README DESTINATION share/doc/teapot)
++install(FILES README DESTINATION share/doc/teapot)
+ install(FILES teapot.1 DESTINATION share/man/man1)
+
+ add_custom_target(dist
diff --git a/app-office/teapot/files/teapot-2.3.0-helpfile.patch b/app-office/teapot/files/teapot-2.3.0-helpfile.patch
new file mode 100644
index 000000000000..3df5f2f443aa
--- /dev/null
+++ b/app-office/teapot/files/teapot-2.3.0-helpfile.patch
@@ -0,0 +1,33 @@
+This fixes a bug where HELPFILE was being overridden by a hard coded path
+
+This also fixes an issue with fl_filename_absolute returning a relative path
+preventing fteapot from finding its helpfile when started from any directory
+except /
+
+Patch by Kevin McCarthy <signals42@gmail.com>
+
+--- teapot-2.3.0/fteapot.fl
++++ teapot-2.3.0/fteapot.fl
+@@ -5,6 +5,10 @@
+ decl {\#include <stdint.h>} {private global
+ }
+
++decl {\#include "config.h"} {private global
++}
++
++
+ decl {\#include <limits.h>} {private global
+ }
+
+@@ -824,9 +828,9 @@
+
+ Function {find_helpfile(char *buf, int size, const char *argv0)} {open C return_type void
+ } {
+- code {fl_filename_absolute(buf, size, argv0);
++ code {strncpy(buf, size, argv0);
+ char *p = (char *)fl_filename_name(buf);
+-strncpy(p, "../share/doc/teapot/html/index.html", buf+size-p);
++strncpy(p, HELPFILE, buf+size-p);
+ buf[size-1] = 0;
+
+ // Check if help exists in default installed location, fallback value is valid for build directory
diff --git a/app-office/teapot/teapot-2.3.0.ebuild b/app-office/teapot/teapot-2.3.0.ebuild
new file mode 100644
index 000000000000..8dae27a89dce
--- /dev/null
+++ b/app-office/teapot/teapot-2.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/teapot/teapot-2.3.0.ebuild,v 1.1 2013/05/31 13:49:47 xmw Exp $
+
+EAPI=4
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="A powerful spreadhseet program"
+HOMEPAGE="http://www.syntax-k.de/projekte/teapot/"
+SRC_URI="http://www.syntax-k.de/projekte/teapot/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fltk"
+
+RDEPEND="sys-libs/ncurses
+ fltk? ( >=x11-libs/fltk-1.3.0:1 )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-office/lyx
+ dev-tex/latex2html
+ dev-tex/pgf
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-doc-dir.patch
+ "${FILESDIR}"/${P}-helpfile.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable doc HELP)
+ -DPF=${PF}
+ )
+
+ if use fltk; then
+ mycmakeargs+=(
+ -DFLTK_USE_FILE=/usr/share/cmake/Modules/FLTKConfig.cmake
+ -DFLTK_DIR=/usr/share/cmake/Modules
+ -DFLTK_FLUID_EXECUTABLE=/usr/bin/fluid
+ )
+ append-cxxflags -I/usr/include/fltk-1
+ append-ldflags -L/usr/$(get_libdir)/fltk-1
+ fi
+
+ cmake-utils_src_configure
+}