summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-11-29 04:55:37 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-11-29 04:55:37 +0000
commite79c986fba290297a342dc4aa9512af9ccd82c49 (patch)
tree25d5fbd84c3f3e5320232c607e2ad66f7dc87502 /app-office/texmacs
parentRestrict Jython ABIs. (diff)
downloadgentoo-2-e79c986fba290297a342dc4aa9512af9ccd82c49.tar.gz
gentoo-2-e79c986fba290297a342dc4aa9512af9ccd82c49.tar.bz2
gentoo-2-e79c986fba290297a342dc4aa9512af9ccd82c49.zip
Version bump
(Portage version: 2.2.0_alpha6/cvs/Linux i686)
Diffstat (limited to 'app-office/texmacs')
-rw-r--r--app-office/texmacs/ChangeLog7
-rw-r--r--app-office/texmacs/texmacs-1.0.7.8.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index 0bd37176ea38..e9e416ad642b 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/texmacs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.86 2010/11/10 12:55:14 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.87 2010/11/29 04:55:37 grozin Exp $
+
+*texmacs-1.0.7.8 (29 Nov 2010)
+
+ 29 Nov 2010; Andrey Grozin <grozin@gentoo.org> +texmacs-1.0.7.8.ebuild:
+ Version bump
10 Nov 2010; Andrey Grozin <grozin@gentoo.org> texmacs-1.0.7.6.ebuild,
texmacs-1.0.7.7.ebuild, +files/texmacs-qt.patch:
diff --git a/app-office/texmacs/texmacs-1.0.7.8.ebuild b/app-office/texmacs/texmacs-1.0.7.8.ebuild
new file mode 100644
index 000000000000..7d46fda09283
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.7.8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.8.ebuild,v 1.1 2010/11/29 04:55:37 grozin Exp $
+EAPI=2
+inherit autotools
+MY_P=${P/tex/TeX}-src
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="imlib jpeg netpbm -qt4 svg spell"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-scheme/guile[deprecated]
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ media-libs/freetype
+ x11-libs/libXext
+ x11-apps/xmodmap
+ qt4? ( x11-libs/qt-gui:4 )
+ imlib? ( media-libs/imlib2 )
+ jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg ) )
+ netpbm? ( media-libs/netpbm )
+ spell? ( || ( >=app-text/ispell-3.2 >=app-text/aspell-0.5 ) )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use qt4; then
+ ewarn "Qt port is highly experimental"
+ ewarn "If you want a stable TeXmacs, emerge with USE=-qt4"
+ fi
+}
+
+src_prepare() {
+ # don't strip
+ epatch "${FILESDIR}"/${PN}-strip.patch
+
+ # respect LDFLAGS, bug #338459
+ epatch "${FILESDIR}"/${PN}-ldflags.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with imlib imlib2) \
+ --enable-optimize="${CXXFLAGS}" \
+ $(use_enable qt4 qt)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO || die "dodoc failed"
+ domenu "${FILESDIR}"/TeXmacs.desktop || die "domenu failed"
+
+ # now install the fonts
+ insinto /usr/share/texmf
+ doins -r "${WORKDIR}/fonts" || die "installing fonts failed"
+}