summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-08-21 07:38:16 +0000
committerJustin Lecher <jlec@gentoo.org>2014-08-21 07:38:16 +0000
commit7264c5a91cc22db66f64254a69c575f7a4a92f6f (patch)
treedd20887bfd57c6f9bf21bac340ca262de3a84381 /app-office/texmaker
parentOld. (diff)
downloadgentoo-2-7264c5a91cc22db66f64254a69c575f7a4a92f6f.tar.gz
gentoo-2-7264c5a91cc22db66f64254a69c575f7a4a92f6f.tar.bz2
gentoo-2-7264c5a91cc22db66f64254a69c575f7a4a92f6f.zip
app-office/texmaker: Version Bump, #520006
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-4.1-unbundle.patch7
-rw-r--r--app-office/texmaker/texmaker-4.3.ebuild87
3 files changed, 94 insertions, 8 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index b097e43f3796..a184c7bc0037 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.140 2014/05/22 13:08:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.141 2014/08/21 07:38:16 jlec Exp $
+
+*texmaker-4.3 (21 Aug 2014)
+
+ 21 Aug 2014; Justin Lecher <jlec@gentoo.org> +texmaker-4.3.ebuild,
+ files/texmaker-4.1-unbundle.patch:
+ Version Bump, #520006
*texmaker-4.2 (22 May 2014)
diff --git a/app-office/texmaker/files/texmaker-4.1-unbundle.patch b/app-office/texmaker/files/texmaker-4.1-unbundle.patch
index 1e7e152b6d55..3983733deec2 100644
--- a/app-office/texmaker/files/texmaker-4.1-unbundle.patch
+++ b/app-office/texmaker/files/texmaker-4.1-unbundle.patch
@@ -29,13 +29,6 @@ index 51d2082..607f66e 100644
#else
QString dicDir=PREFIX"/share/texmaker/";
#endif
-@@ -10835,4 +10835,4 @@ if (singlemode && currentEditorView())
- UpdateBibliography();
- }
- }
--}
-\ No newline at end of file
-+}
diff --git a/texmaker.pro b/texmaker.pro
index bce8dd4..2f205bb 100644
--- a/texmaker.pro
diff --git a/app-office/texmaker/texmaker-4.3.ebuild b/app-office/texmaker/texmaker-4.3.ebuild
new file mode 100644
index 000000000000..dd832a545bc5
--- /dev/null
+++ b/app-office/texmaker/texmaker-4.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-4.3.ebuild,v 1.1 2014/08/21 07:38:16 jlec Exp $
+
+EAPI=5
+
+inherit qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtscript:4
+ dev-qt/qtsingleapplication[X]
+ dev-qt/qtwebkit:4
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-i18n/ibus-qt
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.1-unbundle.patch )
+
+DOCS=( utilities/AUTHORS utilities/CHANGELOG.txt )
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ find singleapp hunspell -delete || die
+
+ qt4-r2_src_prepare
+
+ cat >> ${PN}.pro <<- EOF
+ exists(texmakerx_my.pri):include(texmakerx_my.pri)
+ EOF
+
+ cp "${FILESDIR}"/texmakerx_my.pri . || die
+
+ sed \
+ -e '/^#include/s:hunspell/::g' \
+ -e '/^#include/s:singleapp/::g' \
+ -i *.cpp *.h || die
+}
+
+src_configure() {
+ eqmake4 \
+ ${PN}.pro \
+ PREFIX="${EPREFIX}/usr" \
+ DESKTOPDIR="${EPREFIX}/usr/share/applications" \
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}