summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-10-14 12:20:30 +0000
committerHans de Graaff <graaff@gentoo.org>2008-10-14 12:20:30 +0000
commit931ab674021ea9fd8dd6bc60bbdf6e18dc4cb856 (patch)
treebf581caed040d9cc39d891e9ba7b6a2753a422a3 /app-office/tpp
parentInstall documentation in proper directory (diff)
downloadgentoo-2-931ab674021ea9fd8dd6bc60bbdf6e18dc4cb856.tar.gz
gentoo-2-931ab674021ea9fd8dd6bc60bbdf6e18dc4cb856.tar.bz2
gentoo-2-931ab674021ea9fd8dd6bc60bbdf6e18dc4cb856.zip
Version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'app-office/tpp')
-rw-r--r--app-office/tpp/ChangeLog8
-rw-r--r--app-office/tpp/files/tpp-1.3.1-Makefile.patch27
-rw-r--r--app-office/tpp/tpp-1.3.1.ebuild35
-rw-r--r--app-office/tpp/tpp-1.3.ebuild8
4 files changed, 73 insertions, 5 deletions
diff --git a/app-office/tpp/ChangeLog b/app-office/tpp/ChangeLog
index f4d151dc5cee..ba22b759d872 100644
--- a/app-office/tpp/ChangeLog
+++ b/app-office/tpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/tpp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/tpp/ChangeLog,v 1.10 2008/10/14 12:13:48 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/tpp/ChangeLog,v 1.11 2008/10/14 12:20:30 graaff Exp $
+
+*tpp-1.3.1 (14 Oct 2008)
+
+ 14 Oct 2008; Hans de Graaff <graaff@gentoo.org>
+ +files/tpp-1.3.1-Makefile.patch, tpp-1.3.ebuild, +tpp-1.3.1.ebuild:
+ Version bump with minor enhancements. Fix quoting issues.
14 Oct 2008; Hans de Graaff <graaff@gentoo.org>
-files/tpp-1.1.1-Makefile.patch, files/tpp-1.3-Makefile.patch:
diff --git a/app-office/tpp/files/tpp-1.3.1-Makefile.patch b/app-office/tpp/files/tpp-1.3.1-Makefile.patch
new file mode 100644
index 000000000000..c388b6e229e5
--- /dev/null
+++ b/app-office/tpp/files/tpp-1.3.1-Makefile.patch
@@ -0,0 +1,27 @@
+--- tpp-1.3.1.orig/Makefile 2005-06-12 04:39:10.000000000 -0700
++++ tpp-1.3.1/Makefile 2005-07-12 03:46:05.000000000 -0700
+@@ -3,10 +3,10 @@
+ #################################################
+
+ BIN = tpp
+-prefix=/usr/local
+-INSPATH= $(prefix)/bin/
+-DOCPATH = $(prefix)/share/doc/tpp
+-MANPATH = $(prefix)/share/man/man1
++prefix=/usr
++INSPATH= $(DESTDIR)$(prefix)/bin/
++DOCPATH = $(DESTDIR)$(prefix)/share/doc/tpp-1.3.1
++MANPATH = $(DESTDIR)$(prefix)/share/man/man1
+
+ all:
+ @echo "TPP doesn't need to be built. Run \`make install' in order to install it."
+@@ -14,7 +14,9 @@
+ install :
+ mkdir -p $(DOCPATH)
+ install -m644 DESIGN CHANGES COPYING README THANKS $(DOCPATH)
++ mkdir -p $(MANPATH)
+ install -m644 doc/tpp.1 $(MANPATH)
++ mkdir -p $(INSPATH)
+ install tpp.rb $(INSPATH)$(BIN)
+ mkdir -p $(DOCPATH)/contrib
+ mkdir -p $(DOCPATH)/examples
diff --git a/app-office/tpp/tpp-1.3.1.ebuild b/app-office/tpp/tpp-1.3.1.ebuild
new file mode 100644
index 000000000000..2c1c7bd7f5dc
--- /dev/null
+++ b/app-office/tpp/tpp-1.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/tpp/tpp-1.3.1.ebuild,v 1.1 2008/10/14 12:20:30 graaff Exp $
+
+inherit eutils ruby
+
+DESCRIPTION="An ncurses-based presentation tool."
+HOMEPAGE="http://synflood.at/tpp.html"
+SRC_URI="http://synflood.at/tpp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="figlet"
+
+USE_RUBY="ruby18"
+
+RDEPEND="virtual/ruby
+ dev-ruby/ncurses-ruby
+ figlet? ( app-misc/figlet )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/app-office/tpp/tpp-1.3.ebuild b/app-office/tpp/tpp-1.3.ebuild
index 5e8ed3928d40..577a2a279a8f 100644
--- a/app-office/tpp/tpp-1.3.ebuild
+++ b/app-office/tpp/tpp-1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/tpp/tpp-1.3.ebuild,v 1.5 2007/04/11 18:38:07 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/tpp/tpp-1.3.ebuild,v 1.6 2008/10/14 12:20:30 graaff Exp $
inherit eutils ruby
@@ -21,9 +21,9 @@ RDEPEND="virtual/ruby
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/${P}-Makefile.patch
+ epatch "${FILESDIR}/${P}-Makefile.patch"
}
src_compile() {