summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-06-24 01:17:29 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-06-24 01:17:29 +0000
commit07e4b0f644a0c8694654015a735fed17246e2017 (patch)
tree5d25ec5177e7b43da977de338fc80dfa76c33234 /app-office
parentUSE flag qt->qt3/qt4 change bug #137785 (diff)
downloadgentoo-2-07e4b0f644a0c8694654015a735fed17246e2017.tar.gz
gentoo-2-07e4b0f644a0c8694654015a735fed17246e2017.tar.bz2
gentoo-2-07e4b0f644a0c8694654015a735fed17246e2017.zip
USE flag qt->qt3/qt4 change bug #137785
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/ChangeLog7
-rw-r--r--app-office/lyx/lyx-1.3.4.ebuild12
-rw-r--r--app-office/lyx/lyx-1.3.5-r1.ebuild26
-rw-r--r--app-office/lyx/lyx-1.3.5-r2.ebuild26
-rw-r--r--app-office/lyx/lyx-1.3.6.ebuild26
-rw-r--r--app-office/lyx/lyx-1.4.1-r1.ebuild14
6 files changed, 58 insertions, 53 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index 6c62ecb108f9..bc97cf36e2f0 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/lyx
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.84 2006/05/23 06:16:58 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.85 2006/06/24 01:17:29 cardoe Exp $
+
+ 24 Jun 2006; Doug Goldstein <cardoe@gentoo.org> lyx-1.3.4.ebuild,
+ lyx-1.3.5-r1.ebuild, lyx-1.3.5-r2.ebuild, lyx-1.3.6.ebuild,
+ lyx-1.4.1-r1.ebuild:
+ USE flag qt->qt3/qt4 change
23 May 2006; Joshua Jackson <tsunam@gentoo.org> lyx-1.4.1-r1.ebuild:
stable on x86 bug #133942
diff --git a/app-office/lyx/lyx-1.3.4.ebuild b/app-office/lyx/lyx-1.3.4.ebuild
index 4795b68b5666..d0461e9b1bdf 100644
--- a/app-office/lyx/lyx-1.3.4.ebuild
+++ b/app-office/lyx/lyx-1.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.4.ebuild,v 1.16 2006/04/05 07:32:03 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.4.ebuild,v 1.17 2006/06/24 01:17:29 cardoe Exp $
inherit kde-functions eutils libtool
@@ -14,7 +14,7 @@ SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc amd64"
-IUSE="nls cups qt debug gnome"
+IUSE="nls cups qt3 debug gnome"
# these dependencies need looking at.
# does lyx only need qt to compile but not run ?
@@ -32,7 +32,7 @@ DEPEND="|| (
>=dev-lang/perl-5
nls? ( sys-devel/gettext )
app-text/aiksaurus
- qt? ( =x11-libs/qt-3* ) !qt? ( =x11-libs/xforms-1* )"
+ qt3? ( =x11-libs/qt-3* ) !qt3? ( =x11-libs/xforms-1* )"
RDEPEND="${DEPEND}
|| (
@@ -69,7 +69,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if use qt ; then
+ if use qt3 ; then
set-qtdir 3
myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
else
@@ -125,10 +125,10 @@ pkg_postinst() {
einfo "2. unzip /usr/share/doc/${P}/preferences.gz into ~/.lyx/preferences"
einfo "or, read http://www.math.tau.ac.il/~dekelts/lyx/instructions2.html"
einfo "for instructions on using lyx's own preferences dialog to equal effect."
- einfo "3. use lyx's qt interface (compile with USE=qt) for maximum effect."
+ einfo "3. use lyx's qt interface (compile with USE=qt3) for maximum effect."
einfo ""
- if ! useq qt ; then
+ if ! useq qt3; then
draw_line
einfo ""
einfo "If you have a multi-head setup not using xinerama you can only use lyx"
diff --git a/app-office/lyx/lyx-1.3.5-r1.ebuild b/app-office/lyx/lyx-1.3.5-r1.ebuild
index 8327b95838fa..bf2b5942f1f8 100644
--- a/app-office/lyx/lyx-1.3.5-r1.ebuild
+++ b/app-office/lyx/lyx-1.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.5-r1.ebuild,v 1.12 2006/04/05 07:32:03 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.5-r1.ebuild,v 1.13 2006/06/24 01:17:29 cardoe Exp $
inherit kde-functions eutils libtool flag-o-matic
@@ -10,13 +10,13 @@ SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
http://movementarian.org/latex-xft-fonts-0.1.tar.gz
http://www.math.tau.ac.il/~dekelts/lyx/files/hebrew.bind
http://www.math.tau.ac.il/~dekelts/lyx/files/preferences
- cjk? ( qt? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/qt/CJK-LyX-qt-${PV}-1.patch )
- !qt? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/xforms/CJK-LyX-xforms-${PV}-1.patch ) )"
+ cjk? ( qt3? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/qt/CJK-LyX-qt-${PV}-1.patch )
+ !qt3? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/xforms/CJK-LyX-xforms-${PV}-1.patch ) )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-IUSE="cjk cups debug nls qt"
+IUSE="cjk cups debug nls qt3"
# these dependencies need looking at.
# does lyx only need qt to compile but not run ?
@@ -34,8 +34,8 @@ DEPEND="|| (
>=dev-lang/perl-5
nls? ( sys-devel/gettext )
app-text/aiksaurus
- qt? ( =x11-libs/qt-3* )
- !qt? ( cjk? ( =x11-libs/xforms-1.0-r1 )
+ qt3? ( =x11-libs/qt-3* )
+ !qt3? ( cjk? ( =x11-libs/xforms-1.0-r1 )
!cjk? ( =x11-libs/xforms-1* ) )"
RDEPEND="${DEPEND}
@@ -66,17 +66,17 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-1.3.2-nomktex.patch
epatch ${FILESDIR}/${PN}-1.3.3-configure-diff
epatch ${FILESDIR}/${P}-boost.patch
- if use cjk && use qt ; then
+ if use cjk && use qt3 ; then
epatch ${DISTDIR}/CJK-LyX-qt-${PV}-1.patch
elif use cjk && built_with_use '=x11-libs/xforms-1.0-r1' cjk ; then
epatch ${DISTDIR}/CJK-LyX-xforms-${PV}-1.patch
elif use cjk ; then
eerror
- eerror 'CJK-LyX requires qt USE flag enabled or x11-libs/xforms-1.0-r1'
+ eerror 'CJK-LyX requires qt3 USE flag enabled or x11-libs/xforms-1.0-r1'
eerror 'built with cjk USE flag. You should either'
- eerror '1) USE="cjk qt" emerge lyx'
+ eerror '1) USE="cjk qt3" emerge lyx'
eerror 'or'
- eerror '2) USE="cjk" emerge xforms-1.0-r1; USE="cjk -qt" emerge lyx'
+ eerror '2) USE="cjk" emerge xforms-1.0-r1; USE="cjk -qt3" emerge lyx'
eerror 'or'
eerror '3) USE="-cjk" emerge lyx (normal LyX will be built)'
eerror
@@ -87,7 +87,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if use qt ; then
+ if use qt3 ; then
set-qtdir 3
myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
else
@@ -143,10 +143,10 @@ pkg_postinst() {
einfo "2. unzip /usr/share/doc/${P}/preferences.gz into ~/.lyx/preferences"
einfo "or, read http://www.math.tau.ac.il/~dekelts/lyx/instructions2.html"
einfo "for instructions on using lyx's own preferences dialog to equal effect."
- einfo "3. use lyx's qt interface (compile with USE=qt) for maximum effect."
+ einfo "3. use lyx's qt interface (compile with USE=qt3) for maximum effect."
einfo ""
- if ! useq qt ; then
+ if ! useq qt3 ; then
draw_line
einfo ""
einfo "If you have a multi-head setup not using xinerama you can only use lyx"
diff --git a/app-office/lyx/lyx-1.3.5-r2.ebuild b/app-office/lyx/lyx-1.3.5-r2.ebuild
index 8191f23a8012..c9a27817ae16 100644
--- a/app-office/lyx/lyx-1.3.5-r2.ebuild
+++ b/app-office/lyx/lyx-1.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.5-r2.ebuild,v 1.9 2006/04/05 07:32:03 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.5-r2.ebuild,v 1.10 2006/06/24 01:17:29 cardoe Exp $
inherit kde-functions eutils libtool flag-o-matic
@@ -10,13 +10,13 @@ SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
http://movementarian.org/latex-xft-fonts-0.1.tar.gz
http://www.math.tau.ac.il/~dekelts/lyx/files/hebrew.bind
http://www.math.tau.ac.il/~dekelts/lyx/files/preferences
- cjk? ( qt? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/qt/CJK-LyX-qt-${PV}-1.patch )
- !qt? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/xforms/CJK-LyX-xforms-${PV}-1.patch ) )"
+ cjk? ( qt3? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/qt/CJK-LyX-qt-${PV}-1.patch )
+ !qt3? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/xforms/CJK-LyX-xforms-${PV}-1.patch ) )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-IUSE="cjk cups debug nls qt"
+IUSE="cjk cups debug nls qt3"
# these dependencies need looking at.
# does lyx only need qt to compile but not run ?
@@ -34,8 +34,8 @@ DEPEND="|| (
>=dev-lang/perl-5
nls? ( sys-devel/gettext )
app-text/aiksaurus
- qt? ( =x11-libs/qt-3* )
- !qt? ( cjk? ( =x11-libs/xforms-1.0-r1 )
+ qt3? ( =x11-libs/qt-3* )
+ !qt3? ( cjk? ( =x11-libs/xforms-1.0-r1 )
!cjk? ( =x11-libs/xforms-1* ) )"
RDEPEND="${DEPEND}
@@ -66,17 +66,17 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-1.3.2-nomktex.patch
epatch ${FILESDIR}/${PN}-1.3.3-configure-diff
epatch ${FILESDIR}/${P}-boost.patch
- if use cjk && use qt ; then
+ if use cjk && use qt3 ; then
epatch ${DISTDIR}/CJK-LyX-qt-${PV}-1.patch
elif use cjk && built_with_use '=x11-libs/xforms-1.0-r1' cjk ; then
epatch ${DISTDIR}/CJK-LyX-xforms-${PV}-1.patch
elif use cjk ; then
eerror
- eerror 'CJK-LyX requires qt USE flag enabled or x11-libs/xforms-1.0-r1'
+ eerror 'CJK-LyX requires qt3 USE flag enabled or x11-libs/xforms-1.0-r1'
eerror 'built with cjk USE flag. You should either'
- eerror '1) USE="cjk qt" emerge lyx'
+ eerror '1) USE="cjk qt3" emerge lyx'
eerror 'or'
- eerror '2) USE="cjk" emerge xforms-1.0-r1; USE="cjk -qt" emerge lyx'
+ eerror '2) USE="cjk" emerge xforms-1.0-r1; USE="cjk -qt3" emerge lyx'
eerror 'or'
eerror '3) USE="-cjk" emerge lyx (normal LyX will be built)'
eerror
@@ -87,7 +87,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if use qt ; then
+ if use qt3 ; then
set-qtdir 3
myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
else
@@ -151,10 +151,10 @@ pkg_postinst() {
einfo "2. unzip /usr/share/doc/${P}/preferences.gz into ~/.lyx/preferences"
einfo "or, read http://www.math.tau.ac.il/~dekelts/lyx/instructions2.html"
einfo "for instructions on using lyx's own preferences dialog to equal effect."
- einfo "3. use lyx's qt interface (compile with USE=qt) for maximum effect."
+ einfo "3. use lyx's qt interface (compile with USE=qt3) for maximum effect."
einfo ""
- if ! useq qt ; then
+ if ! useq qt3 ; then
draw_line
einfo ""
einfo "If you have a multi-head setup not using xinerama you can only use lyx"
diff --git a/app-office/lyx/lyx-1.3.6.ebuild b/app-office/lyx/lyx-1.3.6.ebuild
index 1db9e3013523..63487ee8c07a 100644
--- a/app-office/lyx/lyx-1.3.6.ebuild
+++ b/app-office/lyx/lyx-1.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.6.ebuild,v 1.3 2006/04/05 07:32:03 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.6.ebuild,v 1.4 2006/06/24 01:17:29 cardoe Exp $
inherit kde-functions eutils libtool flag-o-matic
@@ -10,13 +10,13 @@ SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
http://movementarian.org/latex-xft-fonts-0.1.tar.gz
http://www.math.tau.ac.il/~dekelts/lyx/files/hebrew.bind
http://www.math.tau.ac.il/~dekelts/lyx/files/preferences
- cjk? ( qt? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/qt/CJK-LyX-qt-${PV}-1.patch )
- !qt? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/xforms/CJK-LyX-xforms-${PV}-1.patch ) )"
+ cjk? ( qt3? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/qt/CJK-LyX-qt-${PV}-1.patch )
+ !qt3? ( ftp://cellular.phys.pusan.ac.kr/CJK-LyX/xforms/CJK-LyX-xforms-${PV}-1.patch ) )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="cjk cups debug nls qt"
+IUSE="cjk cups debug nls qt3"
RDEPEND="|| ( (
x11-libs/libXi
@@ -51,8 +51,8 @@ DEPEND="${RDEPEND}
>=dev-lang/perl-5
nls? ( sys-devel/gettext )
app-text/aiksaurus
- qt? ( =x11-libs/qt-3* )
- !qt? ( cjk? ( =x11-libs/xforms-1.0-r1 )
+ qt3? ( =x11-libs/qt-3* )
+ !qt3? ( cjk? ( =x11-libs/xforms-1.0-r1 )
!cjk? ( =x11-libs/xforms-1* ) )
>=sys-devel/autoconf-2.58"
@@ -62,17 +62,17 @@ src_unpack() {
unpack latex-xft-fonts-0.1.tar.gz
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
- if use cjk && use qt ; then
+ if use cjk && use qt3 ; then
epatch ${DISTDIR}/CJK-LyX-qt-${PV}-1.patch
elif use cjk && built_with_use '=x11-libs/xforms-1.0-r1' cjk ; then
epatch ${DISTDIR}/CJK-LyX-xforms-${PV}-1.patch
elif use cjk ; then
eerror
- eerror 'CJK-LyX requires qt USE flag enabled or x11-libs/xforms-1.0-r1'
+ eerror 'CJK-LyX requires qt3 USE flag enabled or x11-libs/xforms-1.0-r1'
eerror 'built with cjk USE flag. You should either'
- eerror '1) USE="cjk qt" emerge lyx'
+ eerror '1) USE="cjk qt3" emerge lyx'
eerror 'or'
- eerror '2) USE="cjk" emerge xforms-1.0-r1; USE="cjk -qt" emerge lyx'
+ eerror '2) USE="cjk" emerge xforms-1.0-r1; USE="cjk -qt3" emerge lyx'
eerror 'or'
eerror '3) USE="-cjk" emerge lyx (normal LyX will be built)'
eerror
@@ -83,7 +83,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if use qt ; then
+ if use qt3 ; then
set-qtdir 3
myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
else
@@ -147,10 +147,10 @@ pkg_postinst() {
einfo "2. unzip /usr/share/doc/${P}/preferences.gz into ~/.lyx/preferences"
einfo "or, read http://www.math.tau.ac.il/~dekelts/lyx/instructions2.html"
einfo "for instructions on using lyx's own preferences dialog to equal effect."
- einfo "3. use lyx's qt interface (compile with USE=qt) for maximum effect."
+ einfo "3. use lyx's qt interface (compile with USE=qt3) for maximum effect."
einfo ""
- if ! useq qt ; then
+ if ! useq qt3 ; then
draw_line
einfo ""
einfo "If you have a multi-head setup not using xinerama you can only use lyx"
diff --git a/app-office/lyx/lyx-1.4.1-r1.ebuild b/app-office/lyx/lyx-1.4.1-r1.ebuild
index 0bd26f95b0ac..074b27edb598 100644
--- a/app-office/lyx/lyx-1.4.1-r1.ebuild
+++ b/app-office/lyx/lyx-1.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.4.1-r1.ebuild,v 1.5 2006/05/23 06:16:58 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.4.1-r1.ebuild,v 1.6 2006/06/24 01:17:29 cardoe Exp $
inherit kde-functions fdo-mime eutils libtool flag-o-matic
@@ -15,7 +15,7 @@ SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-IUSE="cjk cups debug gtk nls qt gnome"
+IUSE="cjk cups debug gtk nls qt3 gnome"
RDEPEND="|| (
virtual/x11
@@ -57,8 +57,8 @@ DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.58
cjk? ( =x11-libs/qt-3* )
!cjk? (
- qt? ( =x11-libs/qt-3* )
- !qt? ( =x11-libs/xforms-1* )
+ qt3? ( =x11-libs/qt-3* )
+ !qt3? ( =x11-libs/xforms-1* )
)
gtk? (
>=dev-cpp/gtkmm-2.4
@@ -86,7 +86,7 @@ src_compile() {
local myconf=""
# Choose qt over gtk, since gtk is not feature complete
- if use qt || use cjk ; then
+ if use qt3 || use cjk ; then
set-qtdir 3
myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
elif use gtk ; then
@@ -167,10 +167,10 @@ pkg_postinst() {
einfo "2. unzip /usr/share/doc/${P}/preferences.gz into ~/.lyx/preferences"
einfo "or, read http://www.math.tau.ac.il/~dekelts/lyx/instructions2.html"
einfo "for instructions on using lyx's own preferences dialog to equal effect."
- einfo "3. use lyx's qt interface (compile with USE=qt) for maximum effect."
+ einfo "3. use lyx's qt interface (compile with USE=qt3) for maximum effect."
einfo ""
- if ! useq qt ; then
+ if ! useq qt3 ; then
einfo ""
einfo "If you have a multi-head setup not using xinerama you can only use lyx"
einfo "on the 2nd head if not using qt (maybe due to a xforms bug). See bug #40392."