summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-12 12:13:25 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-12 12:13:25 +0000
commit0c43d919c199a76799e4e228e926a4dcee6ef265 (patch)
treec80a0f1ab4dc5efe03136985a8f414a9ff3a2be8 /app-office
parentAdded sticky bit for /tmp (diff)
downloadgentoo-2-0c43d919c199a76799e4e228e926a4dcee6ef265.tar.gz
gentoo-2-0c43d919c199a76799e4e228e926a4dcee6ef265.tar.bz2
gentoo-2-0c43d919c199a76799e4e228e926a4dcee6ef265.zip
Some missed files
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/koffice-2.1.1_beta1.ebuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/app-office/koffice/koffice-2.1.1_beta1.ebuild b/app-office/koffice/koffice-2.1.1_beta1.ebuild
index 81dc50d43b45..2cf8e446acc4 100644
--- a/app-office/koffice/koffice-2.1.1_beta1.ebuild
+++ b/app-office/koffice/koffice-2.1.1_beta1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-2.1.1_beta1.ebuild,v 1.1 2001/05/10 04:37:18 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-2.1.1_beta1.ebuild,v 1.2 2001/05/12 12:13:25 achim Exp $
P=${PN}-1.1-beta1
A=${P}.tar.bz2
@@ -22,25 +22,25 @@ src_compile() {
QTBASE=/usr/X11R6/lib/qt
try ./configure --prefix=$KDEDIR --host=${CHOST} \
--with-qt-dir=$QTBASE
-
-# if [ "`use readline`" ]
-# then
-# # I use sed to patch a makefile to compile with python
-# for i in connector text zoom selector
-# do
-# cd ${S}/kivio/plugins/kivio${i}tool
-# cp Makefile Makefile.org
-# sed -e "s:^LDFLAGS =.*:LDFLAGS = -lreadline -lncurses:" Makefile.orig > Makefile
-# done
-# fi
- cd ${S}
if [ "`use readline`" ]
then
- try make LIBPYTHON=\"-lpython2.0 -lm -lutil -ldl -lz -lreadline -lncurses\"
- else
- try make
+ LIBPYTHON="-lpython2.0 -lm -lutil -ldl -lz -lreadline -lncurses -lcrypt"
fi
+ if [ "`use berkdb`" ]
+ then
+ LIBPYTHON="$LIBPYTHON -L/usr/lib -ldb-3.2"
+ fi
+ echo $LIBPYTHON
+ # I use sed to patch a makefile to compile with python
+ for i in connector text zoom selector
+ do
+ cd ${S}/kivio/plugins/kivio${i}tool
+ cp Makefile Makefile.orig
+ sed -e "s:^LDFLAGS =.*:LDFLAGS = $LIBPYTHON:" Makefile.orig > Makefile
+ done
+ cd ${S}
+ try LIBPYTHON=\"$LIBPYTHON\" make
}
src_install() {