summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2008-09-20 17:49:03 +0000
committerAndreas Proschofsky <suka@gentoo.org>2008-09-20 17:49:03 +0000
commit4fbf04d16d5b7ce34b3c9b0e786bbf721e89b0c6 (patch)
tree157d31fc81c6a6096feb28bd314ee2f942ba3d61 /app-office
parentAdd support for autoconf-2.63. (diff)
downloadgentoo-2-4fbf04d16d5b7ce34b3c9b0e786bbf721e89b0c6.tar.gz
gentoo-2-4fbf04d16d5b7ce34b3c9b0e786bbf721e89b0c6.tar.bz2
gentoo-2-4fbf04d16d5b7ce34b3c9b0e786bbf721e89b0c6.zip
Try to fix build without java, simplify nsplugin stuff an misc cleanups
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice/ChangeLog10
-rw-r--r--app-office/openoffice/files/gentoo-3.0.0_rc1.diff4
-rw-r--r--app-office/openoffice/files/lucene-no-java.diff31
-rw-r--r--app-office/openoffice/openoffice-3.0.0_rc1.ebuild59
4 files changed, 71 insertions, 33 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index b00c6b28ad7f..61bcab64aad3 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/openoffice
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.414 2008/09/19 08:57:01 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.415 2008/09/20 17:49:02 suka Exp $
+
+ 20 Sep 2008; Andreas Proschofsky <suka@gentoo.org>
+ files/gentoo-3.0.0_rc1.diff, +files/lucene-no-java.diff,
+ openoffice-3.0.0_rc1.ebuild:
+ Further simplify browser plugin stuff, drop seamonkey use-flag as a
+ consequence. Disable binfilter stuff for now, no source package available
+ atm and add some more info messages. Also try to fix the build without
+ java.
19 Sep 2008; Andreas Proschofsky <suka@gentoo.org>
openoffice-3.0.0_rc1.ebuild:
diff --git a/app-office/openoffice/files/gentoo-3.0.0_rc1.diff b/app-office/openoffice/files/gentoo-3.0.0_rc1.diff
index 5d4d32b54601..170b52a6445a 100644
--- a/app-office/openoffice/files/gentoo-3.0.0_rc1.diff
+++ b/app-office/openoffice/files/gentoo-3.0.0_rc1.diff
@@ -10,10 +10,12 @@
chmod 755 $1
--- patches/dev300/apply
+++ patches/dev300/apply
-@@ -1375,12 +1375,8 @@
+@@ -1375,12 +1375,10 @@
system-db-check.diff, i#65979, hmth
# User ~/.ooo3 as user dir
scp2-user-config-ooo3.diff, pmladek
++#fix build without java
++lucene-no-java.diff
-# unused java code
-disable-parser-jaxp.diff
# default inc/lib
diff --git a/app-office/openoffice/files/lucene-no-java.diff b/app-office/openoffice/files/lucene-no-java.diff
new file mode 100644
index 000000000000..4ea45874166b
--- /dev/null
+++ b/app-office/openoffice/files/lucene-no-java.diff
@@ -0,0 +1,31 @@
+Index: makefile.mk
+===================================================================
+RCS file: /cvs/external/lucene/makefile.mk,v
+retrieving revision 1.3.2.1
+diff -u -r1.3.2.1 makefile.mk
+--- lucene/makefile.mk 31 Jul 2008 20:07:34 -0000 1.3.2.1
++++ lucene/makefile.mk 19 Sep 2008 11:23:37 -0000
+@@ -41,6 +41,8 @@
+ .INCLUDE : antsettings.mk
+ # --- Files --------------------------------------------------------
+
++.IF "$(SOLAR_JAVA)" != ""
++
+ LUCENE_MAJOR=2
+ LUCENE_MINOR=3
+ LUCENE_MICRO=2
+@@ -58,9 +60,13 @@
+
+ OUT2BIN=.$/build$/$(LUCENE_CORE_JAR) .$/build$/contrib$/analyzers$/$(LUCENE_ANALYZERS_JAR)
+
++.ENDIF
++
+ # --- Targets ------------------------------------------------------
+
+ .INCLUDE : set_ext.mk
+ .INCLUDE : target.mk
+-.INCLUDE : tg_ext.mk
+
++.IF "$(SOLAR_JAVA)" != ""
++.INCLUDE : tg_ext.mk
++.ENDIF
diff --git a/app-office/openoffice/openoffice-3.0.0_rc1.ebuild b/app-office/openoffice/openoffice-3.0.0_rc1.ebuild
index c76d3a822765..87989f8ca1b9 100644
--- a/app-office/openoffice/openoffice-3.0.0_rc1.ebuild
+++ b/app-office/openoffice/openoffice-3.0.0_rc1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.0.0_rc1.ebuild,v 1.3 2008/09/19 08:57:01 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-3.0.0_rc1.ebuild,v 1.4 2008/09/20 17:49:02 suka Exp $
WANT_AUTOCONF="2.5"
WANT_AUTOMAKE="1.9"
inherit autotools check-reqs db-use eutils fdo-mime flag-o-matic java-pkg-opt-2 kde-functions mono multilib
-IUSE="binfilter cups dbus debug eds gnome gstreamer gtk kde ldap mono nsplugin odk opengl pam seamonkey"
+IUSE="binfilter cups dbus debug eds gnome gstreamer gtk kde ldap mono nsplugin odk opengl pam"
MY_PV="3.0.0.3.1"
PATCHLEVEL="OOO300"
@@ -139,10 +139,7 @@ DEPEND="${COMMON_DEPEND}
pam? ( sys-libs/pam )
!dev-util/dmake
>=dev-lang/python-2.3.4
- !seamonkey? ( nsplugin? ( >=net-libs/xulrunner-1.8
- >=dev-libs/nspr-4.6.6
- >=dev-libs/nss-3.11-r1 ) )
- seamonkey? ( =www-client/seamonkey-1*
+ nsplugin? ( || ( =net-libs/xulrunner-1.8 =net-libs/xulrunner-1.9 =www-client/seamonkey-1* )
>=dev-libs/nspr-4.6.6
>=dev-libs/nss-3.11-r1 )
java? ( || ( =virtual/jdk-1.6* =virtual/jdk-1.5* )
@@ -163,6 +160,9 @@ pkg_setup() {
ewarn " the minimum requirements. If you have less, use openoffice-bin "
ewarn " instead. "
ewarn
+ ewarn " Also if you experience a build break, please make sure to retry "
+ ewarn " with MAKEOPTS="-j1" before filing a bug. "
+ ewarn
# Check if we have enough RAM and free diskspace to build this beast
CHECKREQS_MEMORY="512"
@@ -183,7 +183,7 @@ pkg_setup() {
if use !java; then
ewarn " You are building with java-support disabled, this results in some "
- ewarn " of the OpenOffice.org functionality (i.e. help) being disabled. "
+ ewarn " of the OpenOffice.org functionality being disabled. "
ewarn " If something you need does not work for you, rebuild with "
ewarn " java in your USE-flags. "
ewarn
@@ -206,13 +206,15 @@ pkg_setup() {
fi
fi
- if use !seamonkey && use nsplugin; then
- if pkg-config --exists xulrunner-xpcom; then
- XULR="xulrunner"
- elif pkg-config --exists libxul; then
- XULR="libxul"
+ if use nsplugin; then
+ if pkg-config --exists libxul; then
+ BRWS="libxul"
+ elif pkg-config --exists xulrunner-xpcom; then
+ BRWS="xulrunner"
+ elif pkg-config --exists seamonkey-xpcom; then
+ BRWS="seamonkey"
else
- die "USE flag [nsplugin] set but no installed xulrunner found!"
+ die "USE flag [nsplugin] set but no installed xulrunner or seamonkey found!"
fi
fi
@@ -241,6 +243,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/gentoo-${PV}.diff"
epatch "${FILESDIR}/ooo-env_log.diff"
+ cp -f "${FILESDIR}/lucene-no-java.diff" "${S}/patches/dev300/"
#Use flag checks
if use java ; then
@@ -262,19 +265,15 @@ src_unpack() {
echo "--with-rhino-jar=$(java-pkg_getjar rhino-1.5 js.jar)" >> ${CONFFILE}
fi
- if use nsplugin || use seamonkey ; then
+ if use nsplugin ; then
echo "--enable-mozilla" >> ${CONFFILE}
- local browser
- use nsplugin && browser="${XULR}"
- use seamonkey && browser="seamonkey"
-
- echo "--with-system-mozilla=${browser}" >> ${CONFFILE}
+ echo "--with-system-mozilla=${BRWS}" >> ${CONFFILE}
else
echo "--disable-mozilla" >> ${CONFFILE}
echo "--without-system-mozilla" >> ${CONFFILE}
fi
- echo "`use_enable binfilter`" >> ${CONFFILE}
+ echo "--disable-binfilter" >> ${CONFFILE}
echo "`use_enable cups`" >> ${CONFFILE}
echo "`use_enable dbus`" >> ${CONFFILE}
echo "`use_enable eds evolution2`" >> ${CONFFILE}
@@ -296,7 +295,7 @@ src_unpack() {
src_compile() {
- # Use multiprocessing by default now, it tested upstream
+ # Use multiprocessing by default now, it gets tested by upstream
export JOBS=`echo "${MAKEOPTS}" | sed -e "s/.*-j\([0-9]\+\).*/\1/"`
# Compile problems with these ...
@@ -375,17 +374,15 @@ pkg_postinst() {
# Add available & useful jars to openoffice classpath
use java && /usr/$(get_libdir)/openoffice/basis3.0/program/java-set-classpath $(java-config --classpath=jdbc-mysql 2>/dev/null) >/dev/null
- elog " To start OpenOffice.org, run:"
- elog
- elog " $ ooffice"
- elog
- elog " Also, for individual components, you can use any of:"
- elog
- elog " oobase, oocalc, oodraw, oofromtemplate, ooimpress, oomath,"
- elog " ooweb or oowriter"
- elog
- elog " Spell checking is now provided through our own myspell-ebuilds, "
+ elog " Spell checking is provided through our own myspell-ebuilds, "
elog " if you want to use it, please install the correct myspell package "
elog " according to your language needs. "
+ elog
+ ewarn " Please note that this release of OpenOffice.org uses a "
+ ewarn " new user install dir. As a result you will have to redo "
+ ewarn " your settings. Alternatively you might copy the old one "
+ ewarn " over from ~/.ooo-2.0 to ~/.ooo3, but be warned that this "
+ ewarn " might break stuff. "
+ ewarn
}