summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-05 12:25:57 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-05 12:25:57 +0000
commit70dad29964314821611c7c272b0fb9ed53f3d8bc (patch)
treed882cebcaaad5c6e4b5db5c9fbc3d029684c4b5f /app-office
parentThe _correct_ digest. (diff)
downloadgentoo-2-70dad29964314821611c7c272b0fb9ed53f3d8bc.tar.gz
gentoo-2-70dad29964314821611c7c272b0fb9ed53f3d8bc.tar.bz2
gentoo-2-70dad29964314821611c7c272b0fb9ed53f3d8bc.zip
New version
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog7
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-1.0.121
-rw-r--r--app-office/gnumeric/gnumeric-1.0.12.ebuild112
3 files changed, 119 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index 85abe6cd8dfc..1fcacf78b828 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnumeric
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.20 2002/12/12 00:14:07 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.21 2003/01/05 12:25:57 foser Exp $
+
+*gnumeric-1.0.12 (05 Jan 2003)
+
+ 05 Jan 2003; foser <foser@gentoo.org> gnumeric-1.0.12.ebuild :
+ New gtk1 version, some dep fixes now uses gnome.org eclass
10 Dec 2002; foser <foser@gentoo.org> gnumeric-1.1.6.ebuild gnumeric-1.1.8.ebuild :
Fixed deps (bug #11634)
diff --git a/app-office/gnumeric/files/digest-gnumeric-1.0.12 b/app-office/gnumeric/files/digest-gnumeric-1.0.12
new file mode 100644
index 000000000000..293effd450eb
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-1.0.12
@@ -0,0 +1 @@
+MD5 54bd9e116859303cf92a945efb364664 gnumeric-1.0.12.tar.bz2 9850450
diff --git a/app-office/gnumeric/gnumeric-1.0.12.ebuild b/app-office/gnumeric/gnumeric-1.0.12.ebuild
new file mode 100644
index 000000000000..fa541fffcbc3
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.0.12.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.0.12.ebuild,v 1.1 2003/01/05 12:25:57 foser Exp $
+
+IUSE="nls libgda gb evo python bonobo guile perl"
+
+inherit virtualx libtool gnome.org
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+#Eye Of Gnome (media-gfx/eog) is for image support.
+RDEPEND="=x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12-r1
+ =gnome-base/libglade-0*
+ >=gnome-base/gnome-print-0.31
+ >=gnome-extra/gal-0.18
+ >=dev-libs/libole2-0.2.4
+ >=media-gfx/eog-0.6
+ =dev-libs/libxml-1.8*
+ =media-libs/freetype-1.3*
+ bonobo? ( >=gnome-base/bonobo-1.0.17 )
+ perl? ( >=sys-devel/perl-5.6 )
+ python? ( >=dev-lang/python-2.0 )
+ gb? ( ~gnome-extra/gb-0.0.17 )
+ libgda? ( >=gnome-extra/libgda-0.2.91
+ >=gnome-base/bonobo-1.0.17 )
+ evo? ( >=net-mail/evolution-0.13 )"
+
+#will only work once everybody has decided that they should support
+#the latest versions of programs, or if we live in a perfect world,
+#and subsequent versions do not break compatibility.
+# guile? ( >=dev-util/guile-1.5 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
+
+src_compile() {
+
+ # fix the relink bug, and invalid paths in .ls files.
+ elibtoolize
+
+ local myconf=""
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+ if [ -n "`use gb`" ]; then
+ myconf="${myconf} --with-gb"
+ else
+ myconf="${myconf} --without-gb"
+ fi
+ #broken as we cannot use guile-1.5 (break gnucash)
+ if [ -n "`use guile`" ]; then
+ myconf="${myconf} --without-guile"
+ else
+ myconf="${myconf} --without-guile"
+ fi
+ if [ -n "`use perl`" ]; then
+ myconf="${myconf} --with-perl"
+ else
+ myconf="${myconf} --without-perl"
+ fi
+ if [ -n "`use python`" ]; then
+ myconf="${myconf} --with-python"
+ else
+ myconf="${myconf} --without-python"
+ fi
+ if [ -n "`use libgda`" ]; then
+ myconf="${myconf} --with-gda --with-bonobo"
+ else
+ myconf="${myconf} --without-gda"
+ fi
+ if [ -n "`use evo`" ]; then
+ myconf="${myconf} --with-evolution"
+ fi
+ if [ -n "`use bonobo`" ]; then
+ myconf="${myconf} --with-bonobo"
+ elif [ -z "`use libgda`" ]; then
+ myconf="${myconf} --without-bonobo"
+ fi
+
+ CFLAGS="$CFLAGS `gdk-pixbuf-config --cflags`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ #'gnumeric --dump-func-defs' needs to write to ${HOME}/.gnome/, or
+ #else the build fails.
+ addwrite "${HOME}/.gnome"
+
+ #the build process have to be able to connect to X
+ Xemake || Xmake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+}
+