summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-04-17 04:16:18 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-04-17 04:16:18 +0000
commit85eb7925254c2ed674f531ab699a8a28b8907f6e (patch)
treef29c7b6fad4f2299a28ecd0a6a4be806bc91a331 /app-office
parentVersion bump, bug 312519. Patch by Gef Lebster (diff)
downloadgentoo-2-85eb7925254c2ed674f531ab699a8a28b8907f6e.tar.gz
gentoo-2-85eb7925254c2ed674f531ab699a8a28b8907f6e.tar.bz2
gentoo-2-85eb7925254c2ed674f531ab699a8a28b8907f6e.zip
Version bump, bug 311311. Patch by Myckel Habets
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/orage/ChangeLog7
-rw-r--r--app-office/orage/orage-4.7.5.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-office/orage/ChangeLog b/app-office/orage/ChangeLog
index b8a38f2253d0..8b1b3cd4c01e 100644
--- a/app-office/orage/ChangeLog
+++ b/app-office/orage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/orage
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.26 2010/01/02 10:50:17 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.27 2010/04/17 04:16:18 darkside Exp $
+
+*orage-4.7.5 (17 Apr 2010)
+
+ 17 Apr 2010; Jeremy Olexa <darkside@gentoo.org> +orage-4.7.5.ebuild:
+ Version bump, bug 311311. Patch by Myckel Habets
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org> orage-4.6.1.ebuild:
Transfer Prefix keywords
diff --git a/app-office/orage/orage-4.7.5.ebuild b/app-office/orage/orage-4.7.5.ebuild
new file mode 100644
index 000000000000..a50a4b3f93f2
--- /dev/null
+++ b/app-office/orage/orage-4.7.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.7.5.ebuild,v 1.1 2010/04/17 04:16:18 darkside Exp $
+
+EAPI=2
+
+inherit xfconf
+
+DESCRIPTION="Calendar suite for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/orage/"
+SRC_URI="mirror://xfce/src/apps/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="berkdb dbus debug libnotify"
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfcegui4-4.4
+ >=xfce-base/xfce4-panel-4.4
+ berkdb? ( >=sys-libs/db-4 )
+ libnotify? ( x11-libs/libnotify )
+ dbus? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+# source of 4.7.5 unpacks into 4.7.5.16.
+S="${WORKDIR}/${P}.16"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable dbus)
+ $(use_enable libnotify)
+ $(use_with berkdb bdb4)
+ $(xfconf_use_debug)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}