summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-04-19 21:45:36 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-04-19 21:45:36 +0000
commit89781b61b7daaa7ef59713de27a636c32606f9a5 (patch)
tree92dbffbe8f72894e3d865233dfb2d54e99f184e3 /app-office
parentversion bump (diff)
downloadgentoo-2-89781b61b7daaa7ef59713de27a636c32606f9a5.tar.gz
gentoo-2-89781b61b7daaa7ef59713de27a636c32606f9a5.tar.bz2
gentoo-2-89781b61b7daaa7ef59713de27a636c32606f9a5.zip
Bump to 0.14.4. Use GtkPrint, drop old libgda support and more.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/planner/ChangeLog8
-rw-r--r--app-office/planner/planner-0.14.4.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/app-office/planner/ChangeLog b/app-office/planner/ChangeLog
index fdcbe093aada..8dd36c747f47 100644
--- a/app-office/planner/ChangeLog
+++ b/app-office/planner/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/planner
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.49 2009/01/21 22:54:46 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.50 2009/04/19 21:45:36 eva Exp $
+
+*planner-0.14.4 (19 Apr 2009)
+
+ 19 Apr 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +planner-0.14.4.ebuild:
+ Bump to 0.14.4. Use GtkPrint, drop old libgda support and more.
21 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
-planner-0.14.2.ebuild, -planner-0.14.3.ebuild:
diff --git a/app-office/planner/planner-0.14.4.ebuild b/app-office/planner/planner-0.14.4.ebuild
new file mode 100644
index 000000000000..8a1032d4309d
--- /dev/null
+++ b/app-office/planner/planner-0.14.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/planner-0.14.4.ebuild,v 1.1 2009/04/19 21:45:36 eva Exp $
+
+EAPI="1"
+
+inherit eutils gnome2
+
+DESCRIPTION="Project manager for Gnome2"
+HOMEPAGE="http://live.gnome.org/Planner/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc eds libgda python examples"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libgnomecanvas-2.10
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.4
+ >=gnome-base/gnome-vfs-2.10
+ >=gnome-base/gconf-2.6
+ >=dev-libs/libxml2-2.6.27
+ >=dev-libs/libxslt-1.1.23
+ libgda? ( gnome-extra/libgda:3 )
+ python? ( >=dev-python/pygtk-2.6 )
+ eds? (
+ >=gnome-extra/evolution-data-server-1.1
+ >=mail-client/evolution-2.1.3 )"
+
+# FIXME: disable eds backend for now, its experimental
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35.5
+ doc? ( >=dev-util/gtk-doc-1.0 )"
+
+DOCS="AUTHORS COPYING ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with libgda database gda3)
+ $(use_enable python)
+ $(use_enable python python-plugin)
+ $(use_enable eds)
+ --disable-update-mimedb"
+# $(use_enable eds eds-backend)
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix compile failure with eds-plugin
+ epatch "${FILESDIR}/${PN}-0.14.3-eds-plugin.patch"
+}
+
+src_install() {
+ gnome2_src_install \
+ sqldocdir="\$(datadir)/doc/${PF}" \
+ sampledir="\$(datadir)/doc/${PF}/examples"
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ fi
+}