summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-13 13:47:48 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-13 13:47:48 +0000
commita9658aa1ff60813c48bb8f09b00fa6dbc21c266f (patch)
tree8d003579a8c364bda23dd5656867f5e2ab3ffe93 /app-office
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-a9658aa1ff60813c48bb8f09b00fa6dbc21c266f.tar.gz
gentoo-2-a9658aa1ff60813c48bb8f09b00fa6dbc21c266f.tar.bz2
gentoo-2-a9658aa1ff60813c48bb8f09b00fa6dbc21c266f.zip
Added a patch to fix compile problem with gcc 3.4.2. Thanks to Ed Catmur <ed@catmur.co.uk>, closing bug #67131.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/ChangeLog7
-rw-r--r--app-office/lyx/files/lyx-1.3.5-boost.patch17
-rw-r--r--app-office/lyx/lyx-1.3.5.ebuild3
3 files changed, 25 insertions, 2 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index baace20d343d..be871915a932 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/lyx
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.48 2004/10/10 12:32:39 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.49 2004/10/13 13:47:48 usata Exp $
+
+ 13 Oct 2004; Mamoru KOMACHI <usata@gentoo.org>
+ +files/lyx-1.3.5-boost.patch, lyx-1.3.5.ebuild:
+ Added a patch to fix compile problem with gcc 3.4.2. Thanks to Ed Catmur
+ <ed@catmur.co.uk>, closing bug #67131.
*lyx-1.3.5 (10 Oct 2004)
diff --git a/app-office/lyx/files/lyx-1.3.5-boost.patch b/app-office/lyx/files/lyx-1.3.5-boost.patch
new file mode 100644
index 000000000000..b3fdf985f4cd
--- /dev/null
+++ b/app-office/lyx/files/lyx-1.3.5-boost.patch
@@ -0,0 +1,17 @@
+===================================================================
+RCS file: /cvsroot/boost/boost/boost/format/feed_args.hpp,v
+retrieving revision 1.10
+retrieving revision 1.11
+diff -u -r1.10 -r1.11
+--- boost/boost/boost/format/feed_args.hpp 2003/05/28 11:20:49 1.10
++++ boost/boost/boost/format/feed_args.hpp 2003/08/27 03:24:41 1.11
+@@ -34,8 +34,7 @@
+
+ template<class Tr, class Ch> inline
+ void empty_buf(BOOST_IO_STD basic_ostringstream<Ch,Tr> & os) {
+- static const std::basic_string<Ch, Tr> emptyStr; // avoids 2 cases ( "" and L"" )
+- os.str(emptyStr);
++ os.str( std::basic_string<Ch, Tr>() );
+ }
+
+ template<class Ch, class Tr>
diff --git a/app-office/lyx/lyx-1.3.5.ebuild b/app-office/lyx/lyx-1.3.5.ebuild
index 54f75f986f34..701e49017b52 100644
--- a/app-office/lyx/lyx-1.3.5.ebuild
+++ b/app-office/lyx/lyx-1.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.5.ebuild,v 1.1 2004/10/10 12:32:39 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.5.ebuild,v 1.2 2004/10/13 13:47:48 usata Exp $
inherit kde-functions eutils libtool
@@ -48,6 +48,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PN}-1.3.2-nomktex.patch
epatch ${FILESDIR}/${PN}-1.3.3-configure-diff
+ epatch ${FILESDIR}/${P}-boost.patch
elibtoolize || die
}