summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-09-04 13:20:10 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-09-04 13:20:10 +0000
commitc25deafdb1a2d641de591ee150220a4a9955a7ce (patch)
treee0bfc2ea3677aca6f3c21f9657b3ce85f116e84f /app-office
parentBump (diff)
downloadgentoo-2-c25deafdb1a2d641de591ee150220a4a9955a7ce.tar.gz
gentoo-2-c25deafdb1a2d641de591ee150220a4a9955a7ce.tar.bz2
gentoo-2-c25deafdb1a2d641de591ee150220a4a9955a7ce.zip
Version bump to 1.3.18, wrt to bug #432928
(Portage version: 2.1.11.9/cvs/Linux i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/taskcoach/ChangeLog8
-rw-r--r--app-office/taskcoach/taskcoach-1.3.18.ebuild46
2 files changed, 52 insertions, 2 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index ad57fd4c909b..2d8ceff3130b 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.83 2012/03/01 16:04:39 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.84 2012/09/04 13:20:10 ago Exp $
+
+*taskcoach-1.3.18 (04 Sep 2012)
+
+ 04 Sep 2012; Agostino Sarubbo <ago@gentoo.org> +taskcoach-1.3.18.ebuild:
+ Version bump to 1.3.18, wrt to bug #432928
*taskcoach-1.3.8 (01 Mar 2012)
@@ -464,4 +469,3 @@
02 Jan 2008; Vlastimil Babka <caster@gentoo.org> +metadata.xml,
+taskcoach-0.68.0.ebuild:
New package, bug #144066.
-
diff --git a/app-office/taskcoach/taskcoach-1.3.18.ebuild b/app-office/taskcoach/taskcoach-1.3.18.ebuild
new file mode 100644
index 000000000000..f18a4281aaa4
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.3.18.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.3.18.ebuild,v 1.1 2012/09/04 13:20:10 ago Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org http://pypi.python.org/pypi/TaskCoach"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_install() {
+ distutils_src_install
+
+ # a bit ugly but...
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}