summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-06-09 05:42:07 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-06-09 05:42:07 +0000
commitca7f7a32139df549a33aac9a2ecda620be42c8a2 (patch)
treee40907c295642d1d5db3e7e496f775fb22ad5c69 /app-office
parentFix building with gcc-4.3 #225425 by Jose daLuz. (diff)
downloadgentoo-2-ca7f7a32139df549a33aac9a2ecda620be42c8a2.tar.gz
gentoo-2-ca7f7a32139df549a33aac9a2ecda620be42c8a2.tar.bz2
gentoo-2-ca7f7a32139df549a33aac9a2ecda620be42c8a2.zip
Add patch to fix build w/ GCC 4.3.
(Portage version: 2.2_pre7-r1/cvs/Linux 2.6.25-gentoo-r3 Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kformula/ChangeLog6
-rw-r--r--app-office/kformula/files/kformula-1.6.2-gcc-4.3.patch126
-rw-r--r--app-office/kformula/kformula-1.6.2.ebuild4
3 files changed, 134 insertions, 2 deletions
diff --git a/app-office/kformula/ChangeLog b/app-office/kformula/ChangeLog
index 5e45b0d6d0fe..918a91e2a4b2 100644
--- a/app-office/kformula/ChangeLog
+++ b/app-office/kformula/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/kformula
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kformula/ChangeLog,v 1.82 2008/02/19 01:32:00 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kformula/ChangeLog,v 1.83 2008/06/09 05:42:07 dirtyepic Exp $
+
+ 09 Jun 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/kformula-1.6.2-gcc-4.3.patch, kformula-1.6.2.ebuild:
+ Add patch to fix build w/ GCC 4.3.
19 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> kformula-1.6.2.ebuild:
Update kde-base/* dependencies so that KDE 4 doesn't satisfy it. bug 206528.
diff --git a/app-office/kformula/files/kformula-1.6.2-gcc-4.3.patch b/app-office/kformula/files/kformula-1.6.2-gcc-4.3.patch
new file mode 100644
index 000000000000..1f9ce05bc9c4
--- /dev/null
+++ b/app-office/kformula/files/kformula-1.6.2-gcc-4.3.patch
@@ -0,0 +1,126 @@
+--- branches/koffice/1.6/koffice/lib/kformula/textelement.h 2007/05/28 18:20:51 669185
++++ branches/koffice/1.6/koffice/lib/kformula/textelement.h 2007/05/28 18:26:19 669186
+@@ -75,7 +75,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+@@ -246,7 +246,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+--- branches/koffice/1.6/koffice/lib/kformula/symbolelement.h 2007/05/28 18:20:51 669185
++++ branches/koffice/1.6/koffice/lib/kformula/symbolelement.h 2007/05/28 18:26:19 669186
+@@ -67,7 +67,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+--- branches/koffice/1.6/koffice/lib/kformula/spaceelement.h 2007/05/28 18:20:51 669185
++++ branches/koffice/1.6/koffice/lib/kformula/spaceelement.h 2007/05/28 18:26:19 669186
+@@ -80,7 +80,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+--- branches/koffice/1.6/koffice/lib/kformula/sequenceelement.h 2007/05/28 18:20:51 669185
++++ branches/koffice/1.6/koffice/lib/kformula/sequenceelement.h 2007/05/28 18:26:19 669186
+@@ -94,7 +94,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+--- branches/koffice/1.6/koffice/lib/kformula/rootelement.h 2007/05/28 18:20:51 669185
++++ branches/koffice/1.6/koffice/lib/kformula/rootelement.h 2007/05/28 18:26:19 669186
+@@ -68,7 +68,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+@@ -79,7 +79,7 @@
+ * We can use our parentPosition to get our own origin then.
+ */
+ virtual void draw( QPainter& painter, const LuPixelRect& r,
+- const ContextStyle& style,
++ const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style,
+--- branches/koffice/1.6/koffice/lib/kformula/paddedelement.h 2007/05/28 18:20:51 669185
++++ branches/koffice/1.6/koffice/lib/kformula/paddedelement.h 2007/05/28 18:26:19 669186
+@@ -34,7 +34,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+--- branches/koffice/1.6/koffice/lib/kformula/matrixelement.h 2007/05/28 18:20:51 669185
++++ branches/koffice/1.6/koffice/lib/kformula/matrixelement.h 2007/05/28 18:26:19 669186
+@@ -82,7 +82,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+@@ -377,7 +377,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+--- branches/koffice/1.6/koffice/lib/kformula/indexelement.h 2007/05/28 18:20:51 669185
++++ branches/koffice/1.6/koffice/lib/kformula/indexelement.h 2007/05/28 18:26:19 669186
+@@ -79,7 +79,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
+--- branches/koffice/1.6/koffice/lib/kformula/glyphelement.h 2007/05/28 18:20:51 669185
++++ branches/koffice/1.6/koffice/lib/kformula/glyphelement.h 2007/05/28 18:26:19 669186
+@@ -33,7 +33,7 @@
+ * Calculates our width and height and
+ * our children's parentPosition.
+ */
+- virtual void calcSizes( const ContextStyle& style,
++ virtual void calcSizes( const ContextStyle& cstyle,
+ ContextStyle::TextStyle tstyle,
+ ContextStyle::IndexStyle istyle,
+ StyleAttributes& style );
diff --git a/app-office/kformula/kformula-1.6.2.ebuild b/app-office/kformula/kformula-1.6.2.ebuild
index 47ee3428b6c9..0de4a34123e1 100644
--- a/app-office/kformula/kformula-1.6.2.ebuild
+++ b/app-office/kformula/kformula-1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kformula/kformula-1.6.2.ebuild,v 1.13 2008/02/19 01:32:00 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kformula/kformula-1.6.2.ebuild,v 1.14 2008/06/09 05:42:07 dirtyepic Exp $
MAXKOFFICEVER=1.6.3
KMNAME=koffice
@@ -41,4 +41,6 @@ src_unpack() {
# Fixing desktop files, cf. bug 190006
sed -i -e "s:x-kformula$:x-kformula;:g" "${S}"/kformula/kformula.desktop
+
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch # 214365
}