summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-10-19 09:31:26 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-10-19 09:31:26 +0000
commitd2fa996101e65946f5ffeee99922acc672a53a16 (patch)
tree52e920c44ff1bcd4dde17b446c922c4092aed350 /app-office
parentFix the gcc checking to avoid bug 387515. (diff)
downloadgentoo-2-d2fa996101e65946f5ffeee99922acc672a53a16.tar.gz
gentoo-2-d2fa996101e65946f5ffeee99922acc672a53a16.tar.bz2
gentoo-2-d2fa996101e65946f5ffeee99922acc672a53a16.zip
Move the checks to pkg pretend properly.
(Portage version: 2.2.0_alpha68/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog6
-rw-r--r--app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild25
-rw-r--r--app-office/libreoffice/libreoffice-9999-r1.ebuild25
3 files changed, 30 insertions, 26 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 24356fade47e..9a61577f64e6 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.175 2011/10/18 07:33:46 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.176 2011/10/19 09:31:26 scarabeus Exp $
+
+ 19 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ libreoffice-3.4.9999-r1.ebuild, libreoffice-9999-r1.ebuild:
+ Move the checks to pkg pretend properly.
18 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org>
libreoffice-3.4.9999-r1.ebuild, libreoffice-9999-r1.ebuild:
diff --git a/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild b/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
index 3235ac180e79..8e167553a678 100644
--- a/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild,v 1.15 2011/10/18 07:33:46 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.9999-r1.ebuild,v 1.16 2011/10/19 09:31:26 scarabeus Exp $
EAPI=4
@@ -217,6 +217,19 @@ RESTRICT="test"
S="${WORKDIR}/${PN}-bootstrap-${PV}"
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ CHECKREQS_MEMORY="1G"
+ use debug && CHECKREQS_DISK_BUILD="15G" || CHECKREQS_DISK_BUILD="9G"
+ check-reqs_pkg_pretend
+
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ eerror "Compilation with gcc older than 4.0 is not supported"
+ die "Too old gcc found."
+ fi
+ fi
+}
+
pkg_setup() {
java-pkg-opt-2_pkg_setup
kde4-base_pkg_setup
@@ -224,11 +237,6 @@ pkg_setup() {
python_set_active_version 2
python_pkg_setup
- if [[ $(gcc-major-version) -lt 4 ]]; then
- eerror "Compilation with gcc older than 4.0 is not supported"
- die "Too old gcc found."
- fi
-
if use custom-cflags; then
ewarn "You are using custom CFLAGS, which is NOT supported and can cause"
ewarn "all sorts of build and runtime errors."
@@ -255,11 +263,6 @@ pkg_setup() {
ewarn "activate the 'gtk' use flag."
ewarn
fi
-
- # Check if we have enough RAM and free diskspace to build this beast
- CHECKREQS_MEMORY="1G"
- use debug && CHECKREQS_DISK_BUILD="15G" || CHECKREQS_DISK_BUILD="9G"
- check-reqs_pkg_setup
}
src_unpack() {
diff --git a/app-office/libreoffice/libreoffice-9999-r1.ebuild b/app-office/libreoffice/libreoffice-9999-r1.ebuild
index 548f3915a468..94f6de298bea 100644
--- a/app-office/libreoffice/libreoffice-9999-r1.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r1.ebuild,v 1.44 2011/10/18 07:33:46 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r1.ebuild,v 1.45 2011/10/19 09:31:26 scarabeus Exp $
EAPI=4
@@ -209,9 +209,16 @@ REQUIRED_USE="
S="${WORKDIR}/${PN}-core-${PV}"
pkg_pretend() {
- CHECKREQS_MEMORY="1G"
- use debug && CHECKREQS_DISK_BUILD="15G" || CHECKREQS_DISK_BUILD="9G"
- check-reqs_pkg_setup
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ CHECKREQS_MEMORY="1G"
+ use debug && CHECKREQS_DISK_BUILD="15G" || CHECKREQS_DISK_BUILD="9G"
+ check-reqs_pkg_pretend
+
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ eerror "Compilation with gcc older than 4.0 is not supported"
+ die "Too old gcc found."
+ fi
+ fi
}
pkg_setup() {
@@ -221,21 +228,11 @@ pkg_setup() {
python_set_active_version 2
python_pkg_setup
- if [[ $(gcc-major-version) -lt 4 ]]; then
- eerror "Compilation with gcc older than 4.0 is not supported"
- die "Too old gcc found."
- fi
-
if ! use gtk; then
ewarn "If you want the LibreOffice systray quickstarter to work"
ewarn "activate the 'gtk' use flag."
ewarn
fi
-
- # Check if we have enough RAM and free diskspace to build this beast
- CHECKREQS_MEMORY="1G"
- use debug && CHECKREQS_DISK_BUILD="15G" || CHECKREQS_DISK_BUILD="9G"
- check-reqs_pkg_setup
}
src_unpack() {