summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-08-24 21:07:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-08-24 21:07:02 +0000
commitdaf85ad0ab94891f18ba5f9c8514be40e0b12907 (patch)
treeb8754ee0dd2187d019f633036619cfc5f01746d4 /app-office
parentversion bump (diff)
downloadgentoo-2-daf85ad0ab94891f18ba5f9c8514be40e0b12907.tar.gz
gentoo-2-daf85ad0ab94891f18ba5f9c8514be40e0b12907.tar.bz2
gentoo-2-daf85ad0ab94891f18ba5f9c8514be40e0b12907.zip
version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/ChangeLog7
-rw-r--r--app-office/lyx/lyx-1.6.4.ebuild156
2 files changed, 162 insertions, 1 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index 22a5e58a8912..b74be2d3395d 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/lyx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.174 2009/08/23 15:48:24 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.175 2009/08/24 21:07:02 aballier Exp $
+
+*lyx-1.6.4 (24 Aug 2009)
+
+ 24 Aug 2009; Alexis Ballier <aballier@gentoo.org> +lyx-1.6.4.ebuild:
+ version bump
23 Aug 2009; Jeremy Olexa <darkside@gentoo.org> lyx-1.6.3.ebuild:
amd64 stable, bug 276990. Compile tested by myself, runtime tested by Ben
diff --git a/app-office/lyx/lyx-1.6.4.ebuild b/app-office/lyx/lyx-1.6.4.ebuild
new file mode 100644
index 000000000000..d8de1a1e151e
--- /dev/null
+++ b/app-office/lyx/lyx-1.6.4.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.6.4.ebuild,v 1.1 2009/08/24 21:07:02 aballier Exp $
+
+EAPI=1
+
+inherit qt4 eutils flag-o-matic font toolchain-funcs
+
+MY_P="${P/_}"
+
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.devel.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+#SRC_URI="http://www.lyx.org/~jamatos/lyx-1.6/${MY_P}.tar.bz2 #for betas
+#SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+#SRC_URI="ftp://ftp.devel.lyx.org/pub/lyx/pre/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cups debug nls latex monolithic-build html rtf dot docbook dia subversion rcs"
+
+LANGS="ar ca cs de en es eu fi fr gl he hu id it ja nb nn pl pt ro ru sk tr uk zh_CN zh_TW"
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+COMMONDEPEND="|| ( ( x11-libs/qt-gui x11-libs/qt-core ) =x11-libs/qt-4.3*:4 )
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libxml2
+ app-text/aiksaurus
+ virtual/aspell-dict
+ >=dev-lang/python-2.3.4
+ media-libs/fontconfig
+ media-libs/freetype
+ >=dev-libs/boost-1.34"
+
+RDEPEND="${COMMONDEPEND}
+ || ( dev-texlive/texlive-fontsextra app-text/ptex )
+ media-gfx/imagemagick
+ cups? ( virtual/lpr )
+ latex? (
+ virtual/latex-base
+ virtual/ghostscript
+ app-text/noweb
+ dev-tex/dvipost
+ dev-tex/chktex
+ || (
+ dev-tex/latex2html
+ dev-tex/tth
+ dev-tex/hevea
+ dev-tex/tex4ht
+ )
+ )
+ html? ( dev-tex/html2latex )
+ rtf? (
+ dev-tex/latex2rtf
+ app-text/unrtf
+ dev-tex/html2latex
+ )
+ linguas_he? ( dev-tex/culmus-latex )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ dia? ( app-office/dia )
+ subversion? ( dev-util/subversion )
+ rcs? ( app-text/rcs )"
+
+DEPEND="${COMMONDEPEND}
+ x11-proto/xproto
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+#bug 189925
+QT4_BUILT_WITH_USE_CHECK="png"
+
+src_compile() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS=${T}/fonts
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable monolithic-build) \
+ --with-aspell --without-included-boost --disable-stdlib-debug
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ANNOUNCE NEWS README RELEASE-NOTES UPGRADING "${FONT_S}"/*.txt
+
+ if use linguas_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind
+ fi
+
+ doicon ${PN} "$S/development/Win32/packaging/icons/lyx_32x32.png"
+ make_desktop_entry ${PN} "LyX" "/usr/share/pixmaps/lyx_32x32.png" "Office"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use linguas_he || use linguas_ar; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+
+ elog
+ elog "Be warned that LyX 1.6 changed syntax of key-binding functions."
+ elog "If some of usual editation keys stopped working you may need to fix"
+ elog "your private settings of shortcuts done for version 1.5."
+ elog
+}
+
+pkg_postrm() {
+ if use latex ; then
+ texhash
+ fi
+}