summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Chandler <sethbc@gentoo.org>2003-01-12 19:57:53 +0000
committerSeth Chandler <sethbc@gentoo.org>2003-01-12 19:57:53 +0000
commite36b493e41047b968c6b7d4032138591ade5238a (patch)
tree6f4d9bb93007b07f56d7a4515f18987a2b5c8b60 /app-office
parenteinfo / ewarn changes (diff)
downloadgentoo-2-e36b493e41047b968c6b7d4032138591ade5238a.tar.gz
gentoo-2-e36b493e41047b968c6b7d4032138591ade5238a.tar.bz2
gentoo-2-e36b493e41047b968c6b7d4032138591ade5238a.zip
added several fixes to OOo1.0.1-r3
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice/ChangeLog8
-rw-r--r--app-office/openoffice/files/1.0.1/openoffice-1.0.1-use-libstdc++-generic.patch64
-rw-r--r--app-office/openoffice/files/1.0.1/openoffice-1.0.1-xinteraction-fix.patch31
-rw-r--r--app-office/openoffice/openoffice-1.0.1-r3.ebuild36
4 files changed, 130 insertions, 9 deletions
diff --git a/app-office/openoffice/ChangeLog b/app-office/openoffice/ChangeLog
index 2fd8d6652c6d..a51c2e800b70 100644
--- a/app-office/openoffice/ChangeLog
+++ b/app-office/openoffice/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-office/openoffice
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.15 2002/12/24 03:43:21 sethbc Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/ChangeLog,v 1.16 2003/01/12 19:57:53 sethbc Exp $
*openoffice-1.0.1-r3 (12 Dec 2002)
+ 12 Jan 2003; Seth Chandler <sethbc@gentoo.org> openoffice-1.0.1-r3.ebuild
+ Fixed several java problems, as well as a generic fix for the libstdc++
+ stuff. Should fix most of the open compile error bugs in bugzilla.
+
23 Dec 2002; Seth Chandler<sethbc@gentoo.org> openoffice-1.0.1.ebuild-r3 :
Put in an addpredict to predict writes to /user and /share (same fix
applied to openoffice-bin ebuild). I'm looking for a permanent fix to this
@@ -12,6 +16,8 @@
12 Dec 2002; Martin Schlemmer <azarah@gentoo.org> openoffice-1.0.1.ebuild-r3 :
Fix to work with a gcc-config enabled gcc ...
+*openoffice-1.0.1-r2 (02 Dec 2002)
+
02 Dec 2002; Seth Chandler <sethbc@gentoo.org> openoffice-1.0.1-r2.ebuild:
Add -r2 to portage. I'm requiring jdk 1.4.0 becuase i'm not yet sure if
it works with a 1.3 jdk (some fixes applied to make blackdown 1.4 beta build
diff --git a/app-office/openoffice/files/1.0.1/openoffice-1.0.1-use-libstdc++-generic.patch b/app-office/openoffice/files/1.0.1/openoffice-1.0.1-use-libstdc++-generic.patch
new file mode 100644
index 000000000000..9fad0cc0039f
--- /dev/null
+++ b/app-office/openoffice/files/1.0.1/openoffice-1.0.1-use-libstdc++-generic.patch
@@ -0,0 +1,64 @@
+--- oo_1.0.1_src/product/util/makefile.mk Mon Apr 8 10:34:21 2002
++++ oo_1.0.1_src.azarah/product/util/makefile.mk Wed Apr 10 18:18:09 2002
+@@ -113,12 +113,12 @@
+ BINDINGDLL=$(COMNAME)_uno
+
+ .IF "$(COMID)"=="gcc3"
+-.IF "$(CCNUMVER)">="000300010000"
++.IF "$(CCNUMVER)">="000300020000"
+ ADDITIONAL_DLLS= \
+ $(DESTDIRDLL)$/libgcc_s.so.1 \
+ $(DESTDIRDLL)$/libgcc_s.so \
+- $(DESTDIRDLL)$/libstdc++.so.4 \
+- $(DESTDIRDLL)$/libstdc++.so.4.0.0
++ $(DESTDIRDLL)$/libstdc++.so.5 \
++ $(DESTDIRDLL)$/libstdc++.so.<libversion>
+ .ELSE
+ ADDITIONAL_DLLS= \
+ $(DESTDIRDLL)$/libgcc_s.so.1 \
+@@ -498,15 +498,15 @@
+ #---------------------------------------------------------
+ # special targets for linux gcc3
+
+-.IF "$(CCNUMVER)">="000300010000"
++.IF "$(CCNUMVER)">="000300020000"
+
+-$(DESTDIRDLL)$/libstdc++.so.4.0.0 : $(DLLOUT)$/libstdc++.so.4.0.0 $(DIRLIST)
++$(DESTDIRDLL)$/libstdc++.so.<libversion> : $(DLLOUT)$/libstdc++.so.<libversion> $(DIRLIST)
+ -rm -f $@
+- $(GNUCOPY) -p $(DLLOUT)$/libstdc++.so.4.0.0 $@
++ $(GNUCOPY) -p $(DLLOUT)$/libstdc++.so.<libversion> $@
+
+-$(DESTDIRDLL)$/libstdc++.so.4 : $(DESTDIRDLL)$/libstdc++.so.4.0.0 $(DIRLIST)
++$(DESTDIRDLL)$/libstdc++.so.5 : $(DESTDIRDLL)$/libstdc++.so.<libversion> $(DIRLIST)
+ -rm -f $@
+- +ln -s libstdc++.so.4.0.0 $@
++ +ln -s libstdc++.so.<libversion> $@
+
+ .ELSE
+
+--- oo_1.0.1_src/product/inc/scp/udk_basefiles.scp Wed Sep 11 08:18:10 2002
++++ oo_1.0.1_src.azarah/product/inc/scp/udk_basefiles.scp Wed Sep 11 08:18:40 2002
+@@ -11,11 +11,11 @@
+ Styles = (PACKED, SETUPZIP);
+ End
+
+-#if ( CCNUMVER >= 000300010000 )
++#if ( CCNUMVER >= 000300020000 )
+
+ File gid_File_Lib_Stdc
+ BIN_FILE_BODY;
+- Name = STRING(libstdc++.so.4.0.0);
++ Name = STRING(libstdc++.so.<libversion>);
+ Dir = GCFG_BINARY_DIR;
+ Styles = (PACKED, SETUPZIP);
+ End
+@@ -24,7 +24,7 @@
+ Shortcut gid_Shortcut_Lib_Stdc
+ FileID = gid_File_Lib_Stdc;
+ Dir = GCFG_BINARY_DIR;
+- Name = STRING(libstdc++.so.4);
++ Name = STRING(libstdc++.so.5);
+ Styles = (NETWORK,RELATIVE);
+ End
+
diff --git a/app-office/openoffice/files/1.0.1/openoffice-1.0.1-xinteraction-fix.patch b/app-office/openoffice/files/1.0.1/openoffice-1.0.1-xinteraction-fix.patch
new file mode 100644
index 000000000000..5d7966387510
--- /dev/null
+++ b/app-office/openoffice/files/1.0.1/openoffice-1.0.1-xinteraction-fix.patch
@@ -0,0 +1,31 @@
+diff -ur oo_1.0.1_src.orig/unoil/com/sun/star/document/makefile.mk oo_1.0.1_src/unoil/com/sun/star/document/makefile.mk
+--- oo_1.0.1_src.orig/unoil/com/sun/star/document/makefile.mk 2000-09-18 10:28:26.000000000 -0500
++++ oo_1.0.1_src/unoil/com/sun/star/document/makefile.mk 2002-09-12 18:05:27.000000000 -0500
+@@ -64,7 +64,9 @@
+ PRJ = ..$/..$/..$/..
+ TARGET = unoil_document
+ PACKAGE = com$/sun$/star$/document
+-
++KELL_MARKER = 1
+ # --- Settings -----------------------------------------------------
+
+ .INCLUDE : $(PRJ)$/makefile.pmk
++
++KELL_MARKER = 0
+diff -ur oo_1.0.1_src.orig/unoil/makefile.pmk oo_1.0.1_src/unoil/makefile.pmk
+--- oo_1.0.1_src.orig/unoil/makefile.pmk 2001-08-31 11:04:43.000000000 -0500
++++ oo_1.0.1_src/unoil/makefile.pmk 2002-09-12 18:05:27.000000000 -0500
+@@ -74,7 +74,15 @@
+ JAVAFILESLIST := $(shell +cd $(GENJAVADIR)$/$(PACKAGE) $(COMMANDSEPARATOR) ls *.java)
+ .ENDIF # "$(L10N_framework)"==""
+
++# WARNING!!! WARNING!!! THIS IS A HACK!!! Well...so is just about everything
++# else in this package.
++# Do a little something special for project com.sun.star.document.
++.IF "$(KELL_MARKER)"=="1"
++GENJAVAFILES := $(foreach,i,$(JAVAFILESLIST) $(GENJAVADIR)$/$(PACKAGE)$/$i) $(GENJAVADIR)$/com$/sun$/star$/task$/XInteractionContinuation.java
++.ELSE
+ GENJAVAFILES := $(foreach,i,$(JAVAFILESLIST) $(GENJAVADIR)$/$(PACKAGE)$/$i)
++.ENDIF
++
+ GENCLASSFILES := $(foreach,i,$(JAVAFILESLIST:b) $(GENCLASSDIR)$/$(PACKAGE)$/$i.class)
diff --git a/app-office/openoffice/openoffice-1.0.1-r3.ebuild b/app-office/openoffice/openoffice-1.0.1-r3.ebuild
index dea5567873e9..e26241e25f14 100644
--- a/app-office/openoffice/openoffice-1.0.1-r3.ebuild
+++ b/app-office/openoffice/openoffice-1.0.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.0.1-r3.ebuild,v 1.5 2002/12/24 03:45:54 sethbc Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.0.1-r3.ebuild,v 1.6 2003/01/12 19:57:53 sethbc Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -171,6 +171,8 @@ oo_setup() {
fi
fi
fi
+
+ export JAVA_BINARY="`which java`"
}
src_unpack() {
@@ -193,13 +195,25 @@ src_unpack() {
# Get OO to build with gcc-3.2's libstdc++.so (Az)
if [ "$(gcc-version)" = "3.2" ]
then
- if [ "$(gcc-fullversion)" = "3.2" ]
+ LIBLOCATION="/usr/lib"
+ if [ "${NEW_GCC}" -eq "1" ]
then
- epatch ${FILESDIR}/${PV}/${P}-use-libstdc++-5.0.0.patch
+ LIBLOCATION=`gcc-config --get-lib-path`
+ LIBFILE=`readlink ${LIBLOCATION}/libstdc++.so`
+ LIBVERSION=`echo ${LIBFILE} | sed -e 's|libstdc++\.so\.||g'`
+ sed -e "s|<libversion>|${LIBVERSION}|g" \
+ ${FILESDIR}/${PV}/${P}-use-libstdc++-generic.patch > \
+ ${T}/${P}-use-libstdc++-${LIBVERSION}.patch
+ epatch ${T}/${P}-use-libstdc++-${LIBVERSION}.patch
+ else
+ if [ "$(gcc-fullversion)" = "3.2" ]
+ then
+ epatch ${FILESDIR}/${PV}/${P}-use-libstdc++-5.0.0.patch
- elif [ "$(gcc-fullversion)" = "3.2.1" ]
- then
- epatch ${FILESDIR}/${PV}/${P}-use-libstdc++-5.0.1.patch
+ elif [ "$(gcc-fullversion)" = "3.2.1" ]
+ then
+ epatch ${FILESDIR}/${PV}/${P}-use-libstdc++-5.0.1.patch
+ fi
fi
fi
@@ -244,6 +258,9 @@ src_unpack() {
# New gcc layout use /usr/include/g++-v3/, and not /usr/include/g++-v32 ...
if [ "${NEW_GCC}" -eq "1" ]
then
+ perl -pi -e \
+ 's|_gxx_include_start=/usr/include|_gxx_include_start=/usr/lib/gcc-lib|g' \
+ ${S}/config_office/configure
epatch ${FILESDIR}/${PV}/${P}-use-STLport-4.5.3-newgcc.patch
else
epatch ${FILESDIR}/${PV}/${P}-use-STLport-4.5.3.patch
@@ -264,8 +281,9 @@ src_unpack() {
# Fix ./configure for gcc3 (Az)
perl -pi -e 's|CC --version|CC -dumpversion|g' \
${S}/config_office/configure
+
# perl -pi -e "s|_gccincname1=\"g++-v3\"|_gccincname1=\"g++-v${incver/\.}\"|g" \
-# ${S}/config_office/configure
+# ${S}/config_office/configure
# Fix header not supporting 3.2 and up (Az)
perl -pi -e "s|__GNUC_MINOR__ == 0|__GNUC_MINOR__ == ${minver}|g" \
@@ -288,11 +306,13 @@ src_unpack() {
done
# Seth -- Dec 1 2002
- if [ "$(echo ${JDK_HOME} | grep "jdk-1.4")" ]
+ if [ "$(echo ${JAVA_BINARY} | grep "jdk-1.4")" ]
then
epatch ${FILESDIR}/${PV}/${P}-fix-jdk-1.4.0.patch
+ epatch ${FILESDIR}/${PV}/${P}-xinteraction-fix.patch
fi
+
}
get_EnvSet() {