summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-01-23 15:27:02 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-01-23 15:27:02 +0000
commite572f48d9902d6b35cd693e2493153858a62d2ad (patch)
treed7ad8e5ee776441bbc082e14042d91f63052b13b /app-office
parentVersion bump. (diff)
downloadgentoo-2-e572f48d9902d6b35cd693e2493153858a62d2ad.tar.gz
gentoo-2-e572f48d9902d6b35cd693e2493153858a62d2ad.tar.bz2
gentoo-2-e572f48d9902d6b35cd693e2493153858a62d2ad.zip
Add 4.0 langpacks to fix weird crashers.
(Portage version: 2.2.0_alpha158/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice-l10n/ChangeLog10
-rw-r--r--app-office/libreoffice-l10n/files/lo_gen_langs.sh13
-rw-r--r--app-office/libreoffice-l10n/libreoffice-l10n-4.0.0.1.ebuild95
3 files changed, 111 insertions, 7 deletions
diff --git a/app-office/libreoffice-l10n/ChangeLog b/app-office/libreoffice-l10n/ChangeLog
index 4f1e1e47ce2a..dedfc2bcd4dc 100644
--- a/app-office/libreoffice-l10n/ChangeLog
+++ b/app-office/libreoffice-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/libreoffice-l10n
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/ChangeLog,v 1.65 2012/12/20 11:14:37 scarabeus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/ChangeLog,v 1.66 2013/01/23 15:27:02 scarabeus Exp $
+
+*libreoffice-l10n-4.0.0.1 (23 Jan 2013)
+
+ 23 Jan 2013; Tomáš Chvátal <scarabeus@gentoo.org>
+ +libreoffice-l10n-4.0.0.1.ebuild, files/lo_gen_langs.sh:
+ Add 4.0 langpacks to fix weird crashers.
20 Dec 2012; Tomáš Chvátal <scarabeus@gentoo.org>
-libreoffice-l10n-3.5.7.ebuild, -libreoffice-l10n-3.6.3.2.ebuild,
diff --git a/app-office/libreoffice-l10n/files/lo_gen_langs.sh b/app-office/libreoffice-l10n/files/lo_gen_langs.sh
index 880aff114725..809deed03f6e 100644
--- a/app-office/libreoffice-l10n/files/lo_gen_langs.sh
+++ b/app-office/libreoffice-l10n/files/lo_gen_langs.sh
@@ -7,8 +7,8 @@
# Find l10n packs for libreoffice and format it for use in ebuilds.
#
-VERSION=${1:-3.6.0}
-BASE_SRC_URI="http://download.documentfoundation.org/libreoffice/stable/${VERSION}/rpm/x86"
+VERSION=${1:-4.0.0}
+BASE_SRC_URI="http://download.documentfoundation.org/libreoffice/testing/${VERSION}/rpm/x86"
# needs lxml
print_available_tarballs() {
@@ -42,10 +42,13 @@ for tb in "${tarballs[@]}"; do
pack=${pack##*rpm_}
pack=${pack/en-US/en}
pack=${pack/-/_}
+ pack=${pack/en-US/en}
if [[ ${tb} =~ helppack ]]; then
- help_packs+=( ${pack/en-US/en} )
- else
- lang_packs+=( ${pack/en-US/en} )
+ pack=${pack/helppack_/}
+ help_packs+=( ${pack} )
+ elif [[ ${tb} =~ langpack ]]; then
+ pack=${pack/langpack_/}
+ lang_packs+=( ${pack} )
fi
done
diff --git a/app-office/libreoffice-l10n/libreoffice-l10n-4.0.0.1.ebuild b/app-office/libreoffice-l10n/libreoffice-l10n-4.0.0.1.ebuild
new file mode 100644
index 000000000000..6365f2102cef
--- /dev/null
+++ b/app-office/libreoffice-l10n/libreoffice-l10n-4.0.0.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-l10n/libreoffice-l10n-4.0.0.1.ebuild,v 1.1 2013/01/23 15:27:02 scarabeus Exp $
+
+EAPI=4
+
+inherit rpm eutils multilib versionator
+
+MY_PV=$(get_version_component_range 1-3)
+
+DESCRIPTION="Translations for the Libreoffice suite."
+HOMEPAGE="http://www.libreoffice.org"
+BASE_SRC_URI="http://download.documentfoundation.org/${PN/-l10n/}/testing/${MY_PV}/rpm"
+
+LICENSE="|| ( LGPL-3 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="offlinehelp"
+
+LANGUAGES_HELP="ast bg bn_IN bn bo bs ca_XV ca cs da de dz el en_GB en en_ZA eo
+es et eu fi fr gl gu he hi hr hu id is it ja ka km ko lb mk nb ne nl nn om pl
+pt_BR pt ro ru si sk sl sq sv ta tg tr ug uk vi zh_CN zh_TW"
+LANGUAGES="${LANGUAGES_HELP} af am ar as be br brx cy dgo fa ga gd kk kn kok ks
+ku lo lt lv mai ml mn mni mr my nr nso oc or pa_IN rw sa_IN sat sd sh sr ss st
+sw_TZ te th tn ts tt uz ve xh zu"
+
+for lang in ${LANGUAGES_HELP}; do
+ helppack=""
+ [[ ${lang} == en ]] && lang2=${lang/en/en_US} || lang2=${lang}
+ helppack="offlinehelp? ( ${BASE_SRC_URI}/x86/LibreOffice_${PV}_Linux_x86_rpm_helppack_${lang2/_/-}.tar.gz )"
+ SRC_URI+=" linguas_${lang}? ( ${helppack} )"
+done
+for lang in ${LANGUAGES}; do
+ langpack=""
+ [[ ${lang} == en ]] \
+ || langpack="${BASE_SRC_URI}/x86/LibreOffice_${PV}_Linux_x86_rpm_langpack_${lang/_/-}.tar.gz"
+ [[ -z ${langpack} ]] || SRC_URI+=" linguas_${lang}? ( ${langpack} )"
+ IUSE+=" linguas_${lang}"
+done
+unset lang helppack langpack lang2
+
+RDEPEND+="
+ app-text/hunspell
+ !<app-office/libreoffice-$(get_version_component_range 1-2)
+ !<app-office/libreoffice-bin-$(get_version_component_range 1-2)
+"
+
+RESTRICT="strip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default
+
+ local lang dir rpmdir i
+ local ooextused=()
+
+ for lang in ${LANGUAGES}; do
+ # break away if not enabled; paludis support
+ use_if_iuse linguas_${lang} || continue
+
+ dir=${lang/_/-}
+
+ # for english we provide just helppack, as translation is always there
+ if [[ ${lang} != en ]]; then
+ rpmdir="LibreOffice_${PV}_Linux_x86_rpm_langpack_${dir}/RPMS/"
+ [[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
+ # First remove dictionaries, we want to use system ones.
+ rm -rf "${S}/${rpmdir}/"*dict*.rpm
+ rpm_unpack "./${rpmdir}/"*.rpm
+ fi
+ if [[ "${LANGUAGES_HELP}" =~ "${lang}" ]] && use offlinehelp; then
+ [[ ${lang} == en ]] && dir="en-US"
+ rpmdir="LibreOffice_${PV}_Linux_x86_rpm_helppack_${dir}/RPMS/"
+ [[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
+ rpm_unpack ./"${rpmdir}/"*.rpm
+ fi
+ done
+}
+
+src_prepare() { :; }
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ local dir="${S}"/opt/${PN/-l10n/}$(get_version_component_range 1-2)/
+ # Condition required for people that do not install anything eg no linguas
+ # or just english with no offlinehelp.
+ if [[ -d "${dir}" ]] ; then
+ insinto /usr/$(get_libdir)/${PN/-l10n/}/
+ doins -r "${dir}"/*
+ fi
+ # remove extensions that are in the l10n for some weird reason
+ rm -rf "${ED}"/usr/$(get_libdir)/${PN/-l10n/}/share/extensions/
+}