summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-28 08:49:09 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-28 08:49:09 +0000
commitf5ea2831471d75719d2b6610d217200175d99aea (patch)
tree313ea775666a4f0fba7591dcd0cf7541e04a5c1b /app-office
parentAdded virtual/python (diff)
downloadgentoo-2-f5ea2831471d75719d2b6610d217200175d99aea.tar.gz
gentoo-2-f5ea2831471d75719d2b6610d217200175d99aea.tar.bz2
gentoo-2-f5ea2831471d75719d2b6610d217200175d99aea.zip
I could not wait for the stable release, so here is the package for the first beta
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/files/digest-koffice-1.1_beta11
-rw-r--r--app-office/koffice/koffice-1.1_beta1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-office/koffice/files/digest-koffice-1.1_beta1 b/app-office/koffice/files/digest-koffice-1.1_beta1
new file mode 100644
index 000000000000..5f872d73a640
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.1_beta1
@@ -0,0 +1 @@
+MD5 dc97d2b97122c9740377bb6339492e92 koffice-1.1-beta1.tar.bz2
diff --git a/app-office/koffice/koffice-1.1_beta1.ebuild b/app-office/koffice/koffice-1.1_beta1.ebuild
new file mode 100644
index 000000000000..650c7bf07f52
--- /dev/null
+++ b/app-office/koffice/koffice-1.1_beta1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1_beta1.ebuild,v 1.1 2001/04/28 08:49:09 achim Exp $
+
+P=${PN}-1.1-beta1
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="KDE ${PV} - KOffice"
+SRC_PATH="kde/unstable/${P}/src/${A}"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org/"
+
+DEPEND=">=kde-base/kdelibs-2.1.1
+ virtual/python"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+ QTBASE=/usr/X11R6/lib/qt
+ try ./configure --prefix=$KDEDIR --host=${CHOST} \
+ --with-qt-dir=$QTBASE
+
+ if [ "`use readline`" ]
+ then
+ # I use sed to patch a makefile to compile with python
+ for i in connector text zoom selector
+ do
+ cd ${S}/kivio/plugins/kivio${i}tool
+ cp Makefile Makefile.org
+ sed -e "s:^LDFLAGS =.*:LDFLAGS = -lreadline -lncurses:" Makefile.orig > Makefile
+ done
+ fi
+ cd ${S}
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc ChangeLog COPYING AUTHORS NEWS README
+}
+