summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-11-08 22:56:24 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-11-08 22:56:24 +0000
commitf716b13728059404573f9d6bcac8aa892c84a90d (patch)
tree840b9de4a3fe1dcefd287ff7e5ea7ebd3d65bca7 /app-office
parentAdd binary version for boost-1.55 (diff)
downloadgentoo-2-f716b13728059404573f9d6bcac8aa892c84a90d.tar.gz
gentoo-2-f716b13728059404573f9d6bcac8aa892c84a90d.tar.bz2
gentoo-2-f716b13728059404573f9d6bcac8aa892c84a90d.zip
Add binary version for boost-1.55
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice-bin-debug/ChangeLog8
-rw-r--r--app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.2.6.3-r2.ebuild86
2 files changed, 93 insertions, 1 deletions
diff --git a/app-office/libreoffice-bin-debug/ChangeLog b/app-office/libreoffice-bin-debug/ChangeLog
index 618d37f1205e..bd44ad71f40b 100644
--- a/app-office/libreoffice-bin-debug/ChangeLog
+++ b/app-office/libreoffice-bin-debug/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/libreoffice-bin-debug
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin-debug/ChangeLog,v 1.66 2014/11/04 08:58:00 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin-debug/ChangeLog,v 1.67 2014/11/08 22:56:24 dilfridge Exp $
+
+*libreoffice-bin-debug-4.2.6.3-r2 (08 Nov 2014)
+
+ 08 Nov 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libreoffice-bin-debug-4.2.6.3-r2.ebuild:
+ Add binary version for boost-1.55
04 Nov 2014; Mikle Kolyada <zlogene@gentoo.org>
libreoffice-bin-debug-4.2.6.3-r1.ebuild:
diff --git a/app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.2.6.3-r2.ebuild b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.2.6.3-r2.ebuild
new file mode 100644
index 000000000000..8f34f6f7b302
--- /dev/null
+++ b/app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.2.6.3-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin-debug/libreoffice-bin-debug-4.2.6.3-r2.ebuild,v 1.1 2014/11/08 22:56:24 dilfridge Exp $
+
+EAPI=5
+
+BASE_PACKAGENAME="debug"
+BASE_AMD64_URI="http://packages.gentooexperimental.org/packages/amd64-libreoffice/amd64-${BASE_PACKAGENAME}-"
+BASE_X86_URI="http://packages.gentooexperimental.org/packages/x86-libreoffice/x86-${BASE_PACKAGENAME}-"
+
+DESCRIPTION="LibreOffice, a full office productivity suite. Binary package, debug info"
+HOMEPAGE="http://www.libreoffice.org"
+SRC_URI_AMD64="
+ ${BASE_AMD64_URI}libreoffice-${PVR}.tar.xz
+ kde? (
+ !java? ( ${BASE_AMD64_URI}libreoffice-kde-${PVR}.xd3 )
+ java? ( ${BASE_AMD64_URI}libreoffice-kde-java-${PVR}.xd3 )
+ )
+ gnome? (
+ !java? ( ${BASE_AMD64_URI}libreoffice-gnome-${PVR}.xd3 )
+ java? ( ${BASE_AMD64_URI}libreoffice-gnome-java-${PVR}.xd3 )
+ )
+ !kde? ( !gnome? (
+ java? ( ${BASE_AMD64_URI}libreoffice-java-${PVR}.xd3 )
+ ) )
+"
+SRC_URI_X86="
+ ${BASE_X86_URI}libreoffice-${PVR}.tar.xz
+ kde? (
+ !java? ( ${BASE_X86_URI}libreoffice-kde-${PVR}.xd3 )
+ java? ( ${BASE_X86_URI}libreoffice-kde-java-${PVR}.xd3 )
+ )
+ gnome? (
+ !java? ( ${BASE_X86_URI}libreoffice-gnome-${PVR}.xd3 )
+ java? ( ${BASE_X86_URI}libreoffice-gnome-java-${PVR}.xd3 )
+ )
+ !kde? ( !gnome? (
+ java? ( ${BASE_X86_URI}libreoffice-java-${PVR}.xd3 )
+ ) )
+"
+
+SRC_URI="
+ amd64? ( ${SRC_URI_AMD64} )
+ x86? ( ${SRC_URI_X86} )
+"
+
+IUSE="gnome java kde"
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="=app-office/${PN/-debug}-${PVR}[gnome=,java=,kde=]"
+
+DEPEND="dev-util/xdelta:3"
+
+RESTRICT="test strip"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ einfo "Uncompressing distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar.xz"
+ xz -cd "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar.xz" > "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" || die
+
+ local patchname
+ use kde && patchname="-kde"
+ use gnome && patchname="-gnome"
+ use java && patchname="${patchname}-java"
+
+ if [ -n "${patchname}" ]; then
+ einfo "Patching distfile ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar using ${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3"
+ xdelta3 -d -s "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" "${DISTDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice${patchname}-${PVR}.xd3" "${WORKDIR}/tmpdist.tar" || die
+ mv "${WORKDIR}/tmpdist.tar" "${WORKDIR}/${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar" || die
+ fi
+
+ einfo "Unpacking new ${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar"
+ unpack "./${ARCH}-${BASE_PACKAGENAME}-libreoffice-${PVR}.tar"
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr
+ cp -aR "${S}"/usr/* "${ED}"/usr/ || die
+}