summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2004-04-22 17:00:17 +0000
committerJoel Martin <kanaka@gentoo.org>2004-04-22 17:00:17 +0000
commitfcde27c11a1146a042d9cc7439420549f7d58ea4 (patch)
tree645206e70fd779abc405bab666f4f6327f7e301a /app-office
parentAdding fix for bug #40970. (Manifest recommit) (diff)
downloadgentoo-2-fcde27c11a1146a042d9cc7439420549f7d58ea4.tar.gz
gentoo-2-fcde27c11a1146a042d9cc7439420549f7d58ea4.tar.bz2
gentoo-2-fcde27c11a1146a042d9cc7439420549f7d58ea4.zip
New ebuild, bug 46520
Diffstat (limited to 'app-office')
-rw-r--r--app-office/indeview/ChangeLog10
-rw-r--r--app-office/indeview/Manifest2
-rw-r--r--app-office/indeview/files/digest-indeview-0.6.51
-rw-r--r--app-office/indeview/indeview-0.6.5.ebuild73
-rw-r--r--app-office/indeview/metadata.xml6
5 files changed, 92 insertions, 0 deletions
diff --git a/app-office/indeview/ChangeLog b/app-office/indeview/ChangeLog
new file mode 100644
index 000000000000..ebd045d84585
--- /dev/null
+++ b/app-office/indeview/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-office/indeview
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/indeview/ChangeLog,v 1.1 2004/04/22 17:00:17 kanaka Exp $
+
+*indeview-0.6.5 (22 Apr 2004)
+
+ 22 Apr 2004; Joel Martin <kanaka@gentoo.org> indeview-0.6.5.ebuild,
+ metadata.xml:
+ New ebuild, bug 46520
+
diff --git a/app-office/indeview/Manifest b/app-office/indeview/Manifest
new file mode 100644
index 000000000000..677d1908b2d5
--- /dev/null
+++ b/app-office/indeview/Manifest
@@ -0,0 +1,2 @@
+MD5 1e103b16f5be393a589167881e168db8 indeview-0.6.5.ebuild 2380
+MD5 af867adfa8e9bd51546181498d308927 files/digest-indeview-0.6.5 64
diff --git a/app-office/indeview/files/digest-indeview-0.6.5 b/app-office/indeview/files/digest-indeview-0.6.5
new file mode 100644
index 000000000000..c57f87cdff7e
--- /dev/null
+++ b/app-office/indeview/files/digest-indeview-0.6.5
@@ -0,0 +1 @@
+MD5 b7959850b9fb2485160dcc00936ab4a0 indeview-0.6.5.tgz 6768036
diff --git a/app-office/indeview/indeview-0.6.5.ebuild b/app-office/indeview/indeview-0.6.5.ebuild
new file mode 100644
index 000000000000..02afe50bb151
--- /dev/null
+++ b/app-office/indeview/indeview-0.6.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/indeview/indeview-0.6.5.ebuild,v 1.1 2004/04/22 17:00:17 kanaka Exp $
+
+DESCRIPTION="Convert OpenOffice/KOffice to run independently on Linux, OSX, or Windows"
+HOMEPAGE="http://www.indeview.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="x11-libs/qt"
+
+S=${WORKDIR}/${P}/Viewer
+
+src_compile() {
+ qmake || die "qmake failed"
+ make || die "make failed"
+
+ # Fix up the OpenOffice macro file
+ cd ${S}/../Creator/OpenOffice/
+ cp IndeViewExport.bas IndeViewExport.mo.bas
+ sed -i -e 's:unknown:/usr/share/IndeView/ROOT_DATA:' IndeViewExport.mo.bas
+ # Convert special characters to &XXX; style
+ sed -i -e 's/&/\&amp;/g' IndeViewExport.mo.bas
+ sed -i -e 's/"/\&quot;/g' IndeViewExport.mo.bas
+ sed -i -e 's/</\&lt;/g' IndeViewExport.mo.bas
+ sed -i -e 's/>/\&gt;/g' IndeViewExport.mo.bas
+ sed -i -e "s/'/\&apos;/g" IndeViewExport.mo.bas
+ sed -i -e 's/ö/o/g' IndeViewExport.mo.bas
+
+ cat >> IndeViewExport.xba << _EOF_
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE script:module PUBLIC "-//OpenOffice.org//DTD OfficeDocument 1.0//EN" "module.dtd">
+<script:module xmlns:script="http://openoffice.org/2000/script" script:name="IndeViewExport" script:language="StarBasic">
+_EOF_
+ cat IndeViewExport.mo.bas >> IndeViewExport.xba
+ cat >> IndeViewExport.xba << _EOF_
+</script:module>
+_EOF_
+
+}
+
+src_install() {
+ dobin bin/indeview
+ dobin ../Creator/KPresenter/kpr2iv.sh
+
+ cd ${S}/..
+ dohtml -r doc/html/*
+ dodoc LICENSE README AUTHORS
+
+ dodir /usr/share/IndeView
+ cp -a ${S}/../ROOT_DATA ${D}/usr/share/IndeView/
+
+ dodir /opt/OpenOffice.org/share/basic/Tools
+ insinto /opt/OpenOffice.org/share/basic/Tools
+ cd ${S}/../Creator/OpenOffice/
+
+ doins IndeViewExport.xba
+}
+
+pkg_postinst() {
+ grep "IndeViewExport" /opt/OpenOffice.org/share/basic/Tools/script.xlb > /dev/null ||
+ sed -i -e 's;</library:library>; <library:element library:name="IndeViewExport"/>\n</library:library>;' /opt/OpenOffice.org/share/basic/Tools/script.xlb
+}
+
+pkg_postrm() {
+ if [ ! -e ${ROOT}/usr/bin/indeview ];
+ then
+ sed -i -e '/^ <library:element library:name="IndeViewExport"\/>$/d' /opt/OpenOffice.org/share/basic/Tools/script.xlb
+ fi
+}
diff --git a/app-office/indeview/metadata.xml b/app-office/indeview/metadata.xml
new file mode 100644
index 000000000000..fd224ee1cdb9
--- /dev/null
+++ b/app-office/indeview/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>kanaka@gentoo.org</email></maintainer>
+</pkgmetadata>